LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2003, 06:38 AM   #1
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Rep: Reputation: 30
...still getting errors


I figured this would be the best place to post because I think there is a real simple error for my problem.....and that I just cant find it...

Regarding proftp, I set up the proftpd.conf file and it has no errors....when i try to restart the service using "service proftpd restart"...i get this --->


service proftpd restart
Shutting down proftpd: [FAILED]
Starting proftpd: [ OK ]


I also have vsftpd...i don't know if it causes problems when having both services on here...

the .conf file is below...any help would be appreciated...thanks.

-Keerthan


Here's the .conf file....

ServerName "192.168.0.101"
ServerType standalone
DefaultServer on
Port 21
Umask 022
MaxInstances 30
User keerthan
Group users
# UserAlias Keerthan //commented this out because it
was giving me this error below
// - Fatal: UserAlias: missing arguments


MaxClients 10

DisplayLogin welcome.msg
DisplayFirstChdir .message
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>
 
Old 07-04-2003, 06:44 AM   #2
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
I looked at some other posts regarding proftpd ...and I typed in these commands....not sure what they exactly are supposed to mean..but they were taken from a post from MasterC on another thread...

root@ks root]# /etc/init.d/proftpd start
Starting proftpd: [ OK ]
[root@ks root]# /usr/sbin/proftpd &
[1] 6231
[root@ks root]# ps aux | grep ftp
root 2351 0.0 0.0 1604 212 ? S 03:30 0:00 /usr/sbin/vsftpd
/etc/vsftpd/vsftpd.conf
root 6234 0.0 0.2 3576 644 pts/0 S 05:41 0:00 grep ftp
[1]+ Done /usr/sbin/proftpd
 
Old 07-04-2003, 06:54 AM   #3
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Ok first, I think you can run vsftpd and proftpd both (specyfing different port number) but I hope Proftpd will be enough.
Secondly, to restart proftpd I type simply 'proftpd'.
Thirdly, you get fatal error because 'UserAlias' directive needs two parameters, for example 'UserAlias anonymous ftp', it means ftp user is the same thing as anonymous.
 
Old 07-04-2003, 06:57 AM   #4
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Ok, I think my config file will help you a bit:
#=======================================================================
ServerName "-=[Maniak's Underground FTP Server]=-"
#ServerType standalone
ServerType standalone
DefaultServer on

# Port 21 is the standard FTP port.
Port 21
Umask 022

MaxInstances 30

User 'someuser' //write your values here
Group 'somegroup' // and here
SystemLog '/var/log/proftpd.log'
TransferLog '/var/log/transfer.log'
DeferWelcome off
#===========
#TimeoutIdle 600
TimeoutLogin 30
#===========
<Anonymous 'ftp directory'>
RequireValidShell off
User 'youruser'
Group 'yourgroup'
UserAlias anonymous 'youruser'

MaxClients 5
DisplayLogin "welcome.msg"
# DisplayQuit "quit.msg"
AccessGrantMsg "Guest access granted for %u."


#upload
<Directory upload/>
#DisplayFirstChdir /underground/ftp/welcome.msg
<Limit STOR CWD XCWD PUT>
AllowAll
</Limit>

<Limit DELE MKD RMD XMKD XRMD>
DenyAll
</Limit>
</Directory>

#incoming
<Directory incoming/>
<Limit STOR CWD XCWD >
AllowAll
</Limit>

<Limit DELE MKD RMD XMKD XRMD RM>
DenyAll
</Limit>
</Directory>

#mp3
<Directory incoming/mp3>
<Limit STOR CWD XCWD >
AllowAll
</Limit>

<Limit DELE MKD RMD XMKD XRMD RM>
DenyAll
</Limit>
</Directory>

</Anonymous>
#=======================================================================
 
Old 07-04-2003, 06:59 AM   #5
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
if you want simple anonymous FTP server, my config will sute fine. Don't forget to create
'ftpuser' (and if you want 'ftpgroup'). Everything have to work fine now. type 'proftpd'
 
Old 07-04-2003, 07:02 AM   #6
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
and if you want to know more read ProFTPd manual. It is really good. And by the way your config file is incorrect, you start
Quote:
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>
Without <Anonymous> directive.

I belive that helps
 
Old 07-04-2003, 07:21 AM   #7
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
Thanks for the .conf file...appreciate it. However, I made some changes....and I'm still getting the "421 Service not Available" error.

One more thing, I was wondering if I would be able to set this up where I can connect through the IP assigned by my ISP...I'm behind a router and use that IP for SSH and telnet within the network at home....but I was wanting to be able to connect from any comp w/ an internet connection to my linux box....basically a remote server is what i wanted to set up ...Are there any alternatives to this(as far as maybe a better application for what I am wanting to do)? Thanks for suggestions.

-Keerthan
 
Old 07-04-2003, 07:23 AM   #8
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
wait a sec, do you have real IP? And maybe your FIREWALL rule blocks the FTP
 
Old 07-04-2003, 07:29 AM   #9
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
Sorry i forgot to include that there is an <Anonymous> directive at the top....this is how the anonymous portion of the file looks:

<Anonymous ~keerthan>
User keerthan
Group users

# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous Keerthan
# Limit the maximum number of anonymous logins
MaxClients 10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message
#
# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>
 
Old 07-04-2003, 07:30 AM   #10
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
I don't have a static IP...however, I figure I could still connect to my machine somehow if I knew the IP of it at the moment...it is dynamic but my connection is always running so I figure this is still workable.
 
Old 07-04-2003, 07:31 AM   #11
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
And when I start proftpd, it starts fine, however, when I try to restart the whole thing, it says "FAILED"....have no clue why this is still occuring. However, i looked at the basic.conf file in the sample configurations...I'll give that a try and see if it works.
 
Old 07-04-2003, 07:39 AM   #12
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
I went into the sample configurations.....looked at the basic.conf...mine is exactly the same as it except for diff. user na,es/group names...their user/group names are nobody/nogroup and the anonymous user/group is ftp/ftp......now my question is whether I needed diff. names for my user/group names for which the server was under and the anonymous user names.....it is "keerthan" for both of them.
 
Old 07-04-2003, 07:50 AM   #13
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Well you see ksoma, here is the situation:
As I understood you are on the network, having simple internal IP like 192.168.1.15, or smth similar, and if you setup your server right, only network users will can connect to your box. I think you need to contact you admin and ask for static IP, then fullly reconfigure ProfTPd ( I will help you) and them everything will work fine.
What about you config file, I think it is not very good.
 
Old 07-04-2003, 01:20 PM   #14
ksoma
Member
 
Registered: Jun 2003
Location: Austin,TX most of the year...in Euless,TX the rest of it
Distribution: RH 9.0
Posts: 154

Original Poster
Rep: Reputation: 30
Ok I decided to try with vsftpd now since I haven;t been getting luck with proftpd.....this is what I've done so far and what it is giving me:
-----
[root@ks vsftpd]# vsftpd
500 OOPS: vsftpd: does not run standalone, must be started from inetd
------

However, I thought the settings below were supposed to allow standalone(Anything wrong with these?):
--------
listen=YES
listen_address=192.168.0.101(local ip of my comp)
listen_port=21
--------
It is also still giving me the same 421 error that I was getting before:

-------
[root@ks etc]# ftp 192.168.0.101
Connected to 192.168.0.101.
421 Service not available.
--------

Are there any settings I should be aware of for standalone..anything in /etc/services I am missing...anything in any other vsftpd file that I need to configure? Because the vsftpd.conf is the only file I have configured for this. Thanks.

-Keerthan

Last edited by ksoma; 07-04-2003 at 01:21 PM.
 
Old 07-04-2003, 01:47 PM   #15
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Quote:
However, I thought the settings below were supposed to allow standalone(Anything wrong with these?):
--------
listen=YES
listen_address=192.168.0.101(local ip of my comp)
listen_port=21
--------
its ok
Quote:
Are there any settings I should be aware of for standalone..anything in /etc/services I am missing...anything in any other vsftpd file that I need to configure? Because the vsftpd.conf is the only file I have configured for this. Thanks.
check out /etc/hosts.deny , and reboot you PC, cause, may vsftpd won't start because proftpd is already running ...........
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with errors menthegnome Linux - Newbie 6 11-16-2005 04:26 PM
QT errors filburt1 Linux - Software 3 03-17-2004 02:16 PM
Errors during filesystem check with one kernel while no errors with other kernel Potentials Linux - General 11 12-30-2003 05:24 AM
QMAIL errors errors.. YourForum Linux - Software 0 11-27-2003 01:30 PM
2 many errors wesley Linux - Newbie 1 08-03-2001 12:42 AM


All times are GMT -5. The time now is 10:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration