LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2005, 08:05 PM   #1
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Rep: Reputation: 30
Still can't seem to get second hard drive to work


Top of the morning all,

I have two hard drives, one with xp and debian etch, and the other I would like to use as storage for both operating systems. The second drive, hdb, had been formatted as fat32 so I can see it with windows, but not with debian.

Here is the /etc/fstab output:

GNU nano 1.2.4 File: /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/hdb1 /mnt vfat rw,users 0 0
/dev/hda1 /mnt/hda1 ntfs noauto,users,rw 0 0

I would like to have the ability to see and browse the xp drive and get the storage drive mounted and working.

Idea as to what I am missing?

Much thanks,
Eric.
 
Old 07-28-2005, 08:35 PM   #2
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Debian, Android
Posts: 1,819

Rep: Reputation: 46
The entry

/dev/hdb1 /mnt vfat rw,users 0 0

is attempting to mount the second drive at /mnt, where hda1 is mounted under. It should read something more like

/dev/hdb1 /mnt/storage vfat rw,users 0 0
(don't forget to create the directory /mnt/storage or whatever you want it called.)

When you try to mount it, what is the error?
 
Old 07-28-2005, 08:37 PM   #3
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
Try to create a subdir under /mnt, instead of mounting directly under /mnt.
The line shall look like this:
/dev/hdb1 /mnt/hdb1 vfat rw,users 0 0

Before editing fstab, try to mount the partition with the console, as root. When you succeed, add the command to fstab, with the proper parameters.
Good luck!
 
Old 07-29-2005, 09:08 PM   #4
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Thanks for helping out, this is where I am at:

The fstab has been amended as follows:

GNU nano 1.2.4 File: /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/hdb1 /mnt/storage vfat rw,users 0 0
/dev/hda1 /windows ntfs rw,users 0 0


I can see the /mnt/storage, which I am assuming is my 80-gig storage drive; although I have as to yet to verify that. Additionally, I can navigate the windows directory, though only as root, the questions is: How do I change access so anyone can use them?

Again, much thanks!
Eric
 
Old 07-29-2005, 09:30 PM   #5
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
If you want all users to be given "full access" to the drives, add umask=000 to your fat32 drive, and umask=222 to your ntfs drive. (These go in the options area, right after 'users'). The 222 is probably redundant, but I've always done it that way and it worked fine.
 
Old 07-29-2005, 10:11 PM   #6
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
This is the new fstab output:

GNU nano 1.2.4 File: /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/hdb1 /mnt/storage vfat rw,users,unmask=000 0 0
/dev/hda1 /windows ntfs rw,users,unmask=222 0 0

When accessing /windows the following error message is prompted:

You do not have enough permissions to read file:/windows

As for the storge drive, it just states: Acess denied.

Thoughts?
 
Old 07-29-2005, 11:35 PM   #7
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 123Reputation: 123
The option is umask, not unmask.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems getting external USB hard drive to work pwaring Debian 4 11-24-2008 09:15 AM
I can't get ubuntu to work with my external hard drive! Kingrames Ubuntu 7 11-14-2005 11:35 PM
iPod as Hard Drive Doesn't Work Delpheno Linux - Hardware 9 10-23-2005 03:27 PM
Please Help - Trash doesn't work on external hard drive perrond Ubuntu 1 08-17-2005 09:03 AM
Need help getting 2nd hard drive to work. BajaNick Linux - General 1 08-28-2004 09:41 PM


All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration