LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   static ipv6 address not showing on eth0 interface (http://www.linuxquestions.org/questions/linux-newbie-8/static-ipv6-address-not-showing-on-eth0-interface-731938/)

gitecravirs 06-10-2009 10:01 AM

static ipv6 address not showing on eth0 interface
 
my /etc/network/interfaces file is
cat /etc/network/interfaces
auto lo
iface lo inet loopback
iface eth1 inet dhcp
auto eth1
#pre-up modprobe ipv6
#iface eth0 inet manual
#up ifconfig $IFACE up
#up ifconfig $IFACE promisc
#up ifconfig $IFACE -arp
#down ifconfig $IFACE down

iface eth0 inet6 static
address 2001:468::3
netmask 64
#up route -A inet6 add default gw 2001:468::1 dev eth0
#down route -A inet6 del default gw 2001:468::1 dev eth0
auto eth0
==>According to my above configuration file i should get global ipv6 address as 2001:468::3 0n interface eth0(one week before i was getting), but im right now not getting it.i did # /etc/init.d/networking restart then im getting-- * Reconfiguring network interfaces... There is already a pid file /var/run/dhclient.eth1.pid with pid 5821
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:1e:58:a7:3c:7e
Sending on LPF/eth1/00:1e:58:a7:3c:7e
Sending on Socket/fallback
DHCPRELEASE on eth1 to 10.114.1.13 port 67
ifconfig: can not resolve `down': Unknown host
There is already a pid file /var/run/dhclient.eth1.pid with pid 0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:1e:58:a7:3c:7e
Sending on LPF/eth1/00:1e:58:a7:3c:7e
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
DHCPOFFER of 10.114.4.50 from 10.114.1.13
DHCPREQUEST of 10.114.4.50 on eth1 to 255.255.255.255 port 67
DHCPACK of 10.114.4.50 from 10.114.1.13
bound to 10.114.4.50 -- renewal in 7065 seconds.
ifconfig: can not resolve `up': Unknown host
Failed to bring up eth0.
==>that is eth0 is not bringing up.i tried these commands to bring it up-# sudo ifconfig eth0 up, #ifup eth0 , but still im getting that my eth0 is unable to bring it up. i tried #mii-tool eth0(and its showing that my link is ok). My ifconfig still doesn't show 2001:468::3 address, its showing something like this--
#/sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:19:d1:1e:e0:cc
inet6 addr: 2001:468::219:d1ff:fe1e:e0cc/64 Scope:Global
inet6 addr: fe80::219:d1ff:fe1e:e0cc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:237 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:27018 (26.3 KB) TX bytes:426 (426.0 B)
Base address:0x30c0 Memory:90300000-90320000

eth1 Link encap:Ethernet HWaddr 00:1e:58:a7:3c:7e
inet addr:10.114.4.50 Bcast:10.114.255.255 Mask:255.255.0.0
inet6 addr: fe80::21e:58ff:fea7:3c7e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:10755 errors:0 dropped:0 overruns:0 frame:0
TX packets:5212 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3866106 (3.6 MB) TX bytes:978833 (955.8 KB)
Interrupt:22

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3057 errors:0 dropped:0 overruns:0 frame:0
TX packets:3057 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:190316 (185.8 KB) TX bytes:190316 (185.8 KB)
==>Please Help Me Soon , im helpless


All times are GMT -5. The time now is 07:37 AM.