LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2012, 12:36 PM   #1
walshman
LQ Newbie
 
Registered: Apr 2012
Posts: 1

Rep: Reputation: Disabled
static ip


Help please
I have installed linux Debian and I want a static ip , I have followed numerous tutorials + youtube tutorials word for word . But when I put in the sudo vim /ect/network/interfaces nothing is there it just opens a new directory. Can anybody tell me where I am going wrong? help would be much appreciated .
 
Old 06-06-2012, 07:29 PM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Well, I don't know Debian, but I do know that typo (ect != ect) won't work.
That path doesn't exist in RHEL; equivalent would be /etc/sysconfig/network-scripts and then you'd edit the appropriate cfg eg ifcfg-eth0.
Hope that's of some help; maybe you could search for that file (or similar) and go from there?
 
Old 06-06-2012, 08:03 PM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
that typo is the key----I have Debian installed, but have not done anything with it---I did confirm the presence of /etc/networks/interfaces.

BUT--in Debian, there's also a really good GUI for networking---or you could install wicd
 
Old 06-06-2012, 11:20 PM   #4
nixblog
Member
 
Registered: May 2012
Posts: 426

Rep: Reputation: 52
Quote:
Originally Posted by walshman View Post
But when I put in the sudo vim /ect/network/interfaces nothing is there it just opens a new directory. Can anybody tell me where I am going wrong? help would be much appreciated .
Yeah, as mentioned above it should be

Code:
/etc/network/interfaces
Follow the Debian Wiki article to configure a static ip.

It should end up similar to this,

Code:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

Last edited by nixblog; 06-06-2012 at 11:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setting static IP on linux PCs with no static IP address from internet provider? solvetek Linux - Networking 1 10-22-2011 09:04 AM
Java non-static variable cannot be referenced from a static context issue rickrvo Programming 2 02-12-2010 04:26 PM
How to initialize a static array of a class in a static member function lali.p Programming 9 02-16-2008 10:27 AM
Howto Assign Multiple Static Public IP Addresses under SBC's PPPoE Static Ip system o trekgraham Linux - Networking 8 04-17-2007 11:51 AM
FC2 Overriding static if in favor of dhcp system set for static pkraus109 Linux - Networking 8 09-21-2004 12:13 PM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration