LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-02-2010, 09:25 PM   #1
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Rep: Reputation: 0
Question Startx via SSH questions.


Hey guys I have Slax installed on a server. Ive started applications like Konqueror from SSH on my windows PC before. I was using exceed as an Xserver. I installed Fedora 12 on my PC now want to go all Linux but I cant start applications remotely. It says "cannot connect to X server".

Ive tried disabling my firewall just to make sure it wasnt a port issue and still no go. How on Fedora 12 am I supposed to host an Xserver to launch apps remotely? Thanks for any advice

Last edited by memysabu; 03-02-2010 at 09:26 PM.
 
Old 03-03-2010, 03:48 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
OK, enable X Forwarding on SSH with a -Y and then all X launches should get implicitly pulled back through the SSH session. Of course you'll need (want...) to be running the ssh client as the same user as the SSH server owner on the local machine,
 
Old 03-03-2010, 03:57 AM   #3
sunnydrake
Member
 
Registered: Jul 2009
Location: Kiev,Ukraine
Distribution: Ubuntu,Slax,RedHat
Posts: 289
Blog Entries: 1

Rep: Reputation: 41
you don't need to just use ssh +X to connect
 
Old 03-03-2010, 10:49 AM   #4
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by acid_kewpie View Post
OK, enable X Forwarding on SSH with a -Y and then all X launches should get implicitly pulled back through the SSH session. Of course you'll need (want...) to be running the ssh client as the same user as the SSH server owner on the local machine,
Well I am running terminal as root and then ssh to root on the remote box. I was doing this on a windows machine before although it was intermittent. X11 forwarding is enabled on the remote machine. I dont understand -Y I did an ssh -Y 192.168.xxx.xxx to the machine still no luck.

Right now Im just trying to launch konqueror. I did a:

DISPLAY=192.168.1.xxx:0 (host machine)
export DISPLAY

to tell it where to put it. Doesnt work. As I said firewall is setup correctly. I have never done this using a local linux machine though its always been a windows system ssh to a linux. I figured the xserver support was built in.
 
Old 03-03-2010, 11:39 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
OK, well if it is Konqueror that you're really trying to load, PLEASE don't do that as root. No need to at all. Certainly you don't want to be root on the local end, and that'll be the problem, as even though root is root, it doesn't have permissions by default to use the local X server running as a normal user. you coul drun "xhost +" on the x server to open access, but it shouldn't become your normal way of making it work.

If using SSH forwarding there is no need to export your display, as it is all tunnelled automagically through SSH, so your session environment should already have something like "DISPLAY=localhost:15" on it, which will cause the client to come back to the local machine, and connect exactly as if it were running locally from the perspective of the X server.
 
Old 03-03-2010, 11:57 AM   #6
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Slax only supports a root login by default. I am not surfing the internet as root it is a test application to see if I can get it to work. I was launching guarddog over ssh as root on my windows machine before I changed to a linux machine. Btw Xhost + doesnt work. There is also no way for me to login to the remote machine as anything but root. Turning off access control didnt do it. Heck I cant even ssh 127.0.0.1 and launch a gnome session. This is extremely annoying I dont want an OS to think for me I can do that myself. Linux not looking so good today being all locked down. This is why I stopped using windows.
 
Old 03-03-2010, 12:15 PM   #7
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Original Poster
Rep: Reputation: 0
I did add a user in Slax and dropped down to a normal user account on my local end. Exact same problem so it has nothing to do with account rights.
 
Old 03-03-2010, 12:30 PM   #8
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Original Poster
Rep: Reputation: 0
WOW this is like the dumbest thing ever if Linux cant see itself lol! Both firewalls disabled. User accounts being used vs root. Both on local network. Xserver does not work period! This is a brand new Fedora 12 install and its the Fedora machine thats having the issue. When I had windows installed on the exact same machine it worked. This makes like no sense.
 
Old 03-03-2010, 12:51 PM   #9
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Original Poster
Rep: Reputation: 0
I fixed it. Its ridiculous that its this hard to set up something so simple. I can only assume that people writing linux explanations(man pages) dont really want people to figure out how to use the system because it was not this friggen hard.
 
Old 03-03-2010, 01:09 PM   #10
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
You should be able to do something like:
Code:
ssh -X mortal@the.remote.host
Doing so should set $DISPLAY as described by acid_kewpie, and your local X server should be none the wiser about whose traffic it is serving.

--- rod.
 
Old 03-03-2010, 01:10 PM   #11
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,051

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
^ um. what did you do to fix it. please share so that others can benefit from this thread.
 
Old 03-03-2010, 01:49 PM   #12
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
I'm sure you were missing something very simple, when set up correctly, using -X or -Y with ssh, it'll work without any other configuration at all. Seeing as you were complaining about one machine not being able to "see" the other would show you don't understand the way ssh forwarding works, which is clearly an important stage here.
 
Old 03-03-2010, 02:10 PM   #13
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
I see a lot of confusion arising out of the client/server relationship in the context of X. Most people naturally equate the server component with the remote host, which is the opposite of what is generally the case for users at an X-hosting workstation. I sense that some of this misunderstanding has crept into this thread.

--- rod.
 
Old 04-02-2010, 10:22 AM   #14
memysabu
LQ Newbie
 
Registered: Mar 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Was not -X that can be accomplished thru exporting the display. I was doing everything right the problem is Xservers for Windows do not function at all. Ive used Xceed and Xming with several distros of Linux and they do not work. Ive tried multiple machines, multiple networks they all run like trash or just dont work. I have a 100% Linux setup now and it all works perfectly I do a ssh -X soandso@whateveraddy now instead of using the export display command but either works. Anyhow I stopped posting because I thought I had it working, Xceed works more often than Xming. I was wrong so ended up just running Linux for everything and now everything works fine.

I stand by my statement the Man Pages were written by people who didnt want you to figure out Linux. When I want to know something I google it. People learn from examples not gibberish.
 
Old 04-02-2010, 03:52 PM   #15
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
Interesting. I used Exceed for years, and only had problems with selected applications that wanted to use certain X visuals (whatever those are). Getting an X server that didn't crash with these particular applications (Lab Windows on Solaris, especially) was the biggest motivator I had for moving to Linux. That and KDE's & Gnome's multiple desktop capability.
Who said man pages were ever intended to be tutorial in nature?
--- rod.
 
0 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it possible to SSH into a server and startx? punt Linux - Virtualization and Cloud 2 11-17-2009 12:50 AM
2 questions about SSH yogaboy Linux - Security 15 12-20-2006 07:27 AM
2 questions: uninstall & startx tomave Linux From Scratch 1 09-15-2005 12:16 AM
StartX with ssh-agent johnnydangerous Fedora 1 03-15-2005 12:55 AM
StartX Problems. Prevention and Cure Questions. JC404 Linux - Software 1 09-01-2003 12:17 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration