LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2009, 07:12 AM   #1
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
Smile startx or init 4 in Slackware


I installed Slackware successfully.
After installing slackware the default runlevel was 3.

I tried to start graphical mode. So I entered startx
But the screen became blank

I also tried init 4, same problem there comes blank screen.
What is the problem.

Why I am unable to start graphical mode?
 
Old 02-14-2009, 07:24 AM   #2
millgates
Member
 
Registered: Feb 2009
Location: 192.168.x.x
Distribution: Slackware
Posts: 840

Rep: Reputation: 380Reputation: 380Reputation: 380Reputation: 380
have you configured X (using xorgconfig, xorgsetup or editing xorg.conf)?
 
Old 02-14-2009, 07:24 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Have you configured X? If not, you may want to do that. You can run xorgsetup or xorgconfig to do so, both of which will need to be run as root. Some info about these can be found here.
 
Old 02-14-2009, 10:20 AM   #4
richwmn
LQ Newbie
 
Registered: Dec 2005
Location: Athens, GA
Distribution: Slackware (various),Ubuntu 9.04
Posts: 27

Rep: Reputation: 17
A good start would be to download Slax (Slackware live disk) and boot it. It will generate a pretty good xorg.conf file which you could copy to /etc/X11 and be able to use startx or init 4 to bring up the GUI.

Rich
 
Old 02-15-2009, 03:59 AM   #5
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Download Link?

Can anyone give me a link to get SLAX?
 
Old 02-15-2009, 04:03 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Google it? Really, it's not that hard.
 
Old 02-15-2009, 04:08 AM   #7
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Google?

tried all the links.
All of them are blank
 
Old 02-15-2009, 04:12 AM   #8
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The "Get Slax" at the bottom of slax.org works, so obviously you didn't try all the links.
 
Old 02-15-2009, 04:17 AM   #9
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
slax.org?

Tried that also, even I became member of slax.org as errorsunknownp
Same problem while downloading slax for cd as well as slax for usb
 
Old 02-15-2009, 04:30 AM   #10
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Smile mistake

I've replied that i tried all the links. It was mistake
I meant that I've tried most of the links.
Finally I got slax in http://fileforum.betanews.com/downlo...X/1178288086/1
 
Old 02-17-2009, 09:47 PM   #11
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
SLAX?

I've downloaded Slax 6.0.9 and tried it also.
It works fine.
Now does copying xorg.conf file from slax to my / partition really solves
my problem.
If it is unsure then why to damage the default xorg.conf
Can anybody suggest
 
Old 02-17-2009, 11:02 PM   #12
richwmn
LQ Newbie
 
Registered: Dec 2005
Location: Athens, GA
Distribution: Slackware (various),Ubuntu 9.04
Posts: 27

Rep: Reputation: 17
Quote:
Originally Posted by errorsunknownp View Post
I've downloaded Slax 6.0.9 and tried it also.
It works fine.
Now does copying xorg.conf file from slax to my / partition really solves
my problem.
If it is unsure then why to damage the default xorg.conf
Can anybody suggest
While SLAX is running go to a terminal window. Change directories to the X11 directory on your hard disk. It will be something like
/mnt/hda1/etc/X11

rename the xorg.conf that is on the disk
mv xorg.conf xorg.config.default (for example)

copy the xorg.conf from the running SLAX this directory
should be
cp /etc/X11/xorg.conf xorg.conf

Then when you reboot from your hard disk, you will have a configured GUI.

Rich
 
Old 02-18-2009, 02:09 AM   #13
errorsunknownp
Member
 
Registered: Dec 2008
Location: Nepal
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Unhappy hangs

I copied xorg.conf from slax's etc/X11 to my Slacware's etc/X11

After rebooting from my hard disk
I entered startx mode
Then mouse pointer appeared after sometime my system got stucked.....


What to do now???
 
Old 02-18-2009, 04:52 AM   #14
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Forget about slax.

I would recommend you first run 'xorgsetup' and setup X properly.
Then, you may need to run 'xwmconfig'.
If you run that and it doesn't work, try posting your '/var/log/Xorg.0.log', you may also want to browse through the slackbook and see if you missed something:
http://www.slackbook.org/html/book.html#X-WINDOW-SYSTEM
 
Old 02-18-2009, 05:31 AM   #15
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,094

Rep: Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240Reputation: 2240
The command to change run level is telinit, not init. So you should have typed 'telinit 4'.

If that or 'startx' does not work, send the output of following command:
Code:
grep "(EE)" /var/log/Xorg.O.log

Last edited by Didier Spaier; 02-18-2009 at 05:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
startx problem with slackware 8 robertunes Linux - Newbie 3 04-27-2005 11:25 PM
problems with startx and init 6 einstien Slackware - Installation 1 11-30-2004 10:25 AM
Is startx still in Slackware 9.0? Kayaker Slackware 8 03-25-2003 10:55 PM
Does init 5 call startx? linuxlah Linux - General 4 03-05-2003 12:48 AM
slackware 8.1 startx k3v0 Linux - Newbie 3 11-10-2002 12:59 AM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration