LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2010, 06:53 AM   #1
gwolf2u
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Rep: Reputation: 0
startx - no screens found


hello you all
well I need some help from you guys
recently I tried to install vncserver over my dedicated server and after lots and lots of tries I have got to a stop since I don't know how to go further
so let me describe what I did

first of all my linux distro is CentOS
now

I have managed to install and run vncserver successfully (firewall is off on server) and added fluxbox to the vnc startup script
but seems I have some issues connecting with the IP and so on

tried to debug and see what exactly is wrong and got to thing that there is no issue with vnc as it's installed and runs correctly

so tried to open startx (X Window System - well at least I think that is is since I'm no expert in Linux/CentOS) and got a error that says

Code:
 startx
xauth:  creating new authority file /root/.serverauth.2458

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/ks305626.kimsufi.com:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 x86_64 Red Hat, Inc.
Current Operating System: Linux ks305626.kimsufi.com 2.6.34-xxxx-std-ipv4-64 #2 SMP Thu Jun 17 0
7:14:52 UTC 2010 x86_64
Build Date: 13 May 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jul 18 12:51:23 2010
(==) Using config file: "/etc/X11/xorg.conf"
(EE) No devices detected.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
says that no screen found
not sure how to set one up since I don't have one as it's a dedicated server so no physical access to it

not sure if that is the problem here but any help is highly appreciated

thanks all you reply,
Gwolf2u
 
Old 07-18-2010, 11:45 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL
Distribution: Funtoo
Posts: 6,926

Rep: Reputation: 128Reputation: 128
You should check your /etc/X11/xorg.conf file like it says:
Code:
(EE) No devices detected.
The device it needs is a graphics driver to run your card so
that it gives output to your monitor. Maybe start with what you
have in the /etc/X11/xorg.conf file on the native system?
 
Old 07-18-2010, 11:48 AM   #3
gwolf2u
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Original Poster
Rep: Reputation: 0
this is what I got
Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "vmware"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
also tried installing KDE and that didn't work also think since it needs access to this
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Startx - Fatal server error, No screens found Optyx *BSD 21 09-24-2008 12:25 AM
Startx, no screens found error spacerobots Linux - Newbie 2 02-06-2005 09:21 AM
No Screens Found Error when startx Ckesey Linux - Laptop and Netbook 13 09-28-2004 05:04 PM
startx: no screens found Anti-Corporate Linux - Newbie 3 01-01-2004 01:59 AM
startx error: no screens found Smerk Linux - Software 5 03-18-2003 07:55 AM


All times are GMT -5. The time now is 07:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration