LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-19-2004, 04:55 PM   #1
kpachopoulos
Member
 
Registered: Feb 2004
Location: Athens, Greece
Distribution: Gentoo,FreeBSD, Debian
Posts: 704

Rep: Reputation: 30
startx doesn't work for all users


After Slackware 10 installation, i created an account for user kostas. When i logged in as root and typed "startx" Gnome 2.6 started immediately. However, when i logged in as "kostas" startx didn't work. A bunch of messages appeared, among them:
----------------------------------------------------------------------------------------------
xauth:timeout in locking authority file /home/kostas/.Xauthority
XSERVTTransSockOpenCOTSServer: unable to open socket for inet6
XSERVTTransOpen: transport open failed for inet6/base.o
Unable to create ~./gnome directory: permission denied
Could not create per-user gnome configuration directory /home/kostas/.gnome: Permission denied
----------------------------------------------------------------------------------------------
I think the problem has something to do with Gnome not having been configured. I also had a look in "/home/kostas" directory for hidden files, which have to do with Gnome, but there was none.
What can i do in order for all users to be able to use "startx"?
 
Old 09-19-2004, 06:05 PM   #2
sether
Member
 
Registered: Aug 2004
Posts: 695

Rep: Reputation: 30
what method did you use to create the user? "adduser" at the command line always works fine for me. you can always copy the config files over from root's folder to user's folder.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gui login failed despite users created. but Text mode + root + startx works OK Emmanuel_uk VectorLinux 2 11-21-2005 03:41 PM
X (startx) won't work. Peanutman Slackware - Installation 12 04-24-2005 01:54 PM
startx works for root but not users aldenfuchs Red Hat 3 04-01-2005 10:28 AM
Users can't startx SolarBear Debian 7 10-16-2004 04:57 PM
'startx' command unavailable to normal users abs Slackware 13 02-14-2004 09:52 PM


All times are GMT -5. The time now is 07:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration