LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2004, 05:38 PM   #1
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Rep: Reputation: 15
Startx Debian failing


I just installed a Debian distribution without much problems I guess;
I get a username/password prompt which let's me in. When I then type 'startx' it gives me some error messages:

/usr/X11R6/lib/X11/xinit/xserverrc: /usr/bin/x11/X: no such file or directory
...cannot execute X windows


Does anyone know how this comes? Any inputs are welcome.

Thanks

WiWa
 
Old 03-10-2004, 05:43 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hi WiWa!!!

Did you try to run:

xf86config

before running "startx". I assume that you've installed xserver-common package as well
 
Old 03-10-2004, 05:46 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 69
apt-get install x-window-system then give it a try you may also want to install Gnome or KDE as well.
 
Old 03-11-2004, 03:06 AM   #4
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Original Poster
Rep: Reputation: 15
That's just the weird part. I installed all KDE and GNOME packages. i'll try the suggestions asap. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 08:34 AM
Mandrake 10 default boot and startx failing Nekow42 Mandriva 3 01-17-2005 11:48 AM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 03:37 PM
Won't startx on debian 3.0 Tech1 Linux - Distributions 29 04-26-2003 07:28 PM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 07:14 AM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration