LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-12-2002, 09:14 PM   #1
19802974
LQ Newbie
 
Registered: Aug 2002
Posts: 4

Rep: Reputation: 0
startx crashes


when i run startx i get the following message

no mode definition 1024*7xx

i guess this is s a display/ screen config prob.
any ideas ???????
 
Old 08-12-2002, 09:18 PM   #2
X11
Member
 
Registered: Dec 2001
Location: Brisie, Australia
Distribution: Slackware 8.1
Posts: 324

Rep: Reputation: 30
Look for the file XF86Config or XF86Config-4 under the directory /etc/X11/ and post the contents of it here.
 
Old 08-13-2002, 02:06 AM   #3
19802974
LQ Newbie
 
Registered: Aug 2002
Posts: 4

Original Poster
Rep: Reputation: 0
wont fit on page ?? mail me ??
or what sections do you want
broomehilde@hotmail.com
 
Old 08-13-2002, 02:23 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Post the relevant sections, the sections pertaining to Screen would come to mind, and maybe graphics card.

Or, you can upload the file to my ftp and post a link here

ftp://masterc.no-ip.org and here is a username and pass:

USER: CCSpoon
PASS: s2000

It's not always up, but I will leave it up for a couple days so people can see your file.

The link should look something like:
ftp://CCSpoon:s2000@masterc.no-ip.org/XF86Config-4 (If you click this, and there is no file XF86Config-4 (which currently there isn't), then it will return an error, so edit that portion)

Last edited by MasterC; 08-13-2002 at 02:26 AM.
 
Old 08-13-2002, 02:39 AM   #5
19802974
LQ Newbie
 
Registered: Aug 2002
Posts: 4

Original Poster
Rep: Reputation: 0
alas no ftp
heres some sections

# **********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"
Identifier "Generic VGA Card"
VendorName "Unknown"
BoardName "Unknown"
Chipset "generic"
EndSection


Section "Device"
Identifier "S3 ViRGE (generic)"
VendorName "S3 Incorporated. 86C325"
#Option "xaa_benchmark"
#Option "fifo_moderate"
#Option "pci_burst_on"
#Option "pci_retry"
VideoRam 2048
EndSection


# **********************************************************************
# Screen section
# **********************************************************************

# The kernel framebuffer server
Section "Screen"
Driver "fbdev"
Device "Generic VGA Card"
Monitor "Generic Standard VGA, 640x480 @ 60 Hz"
Subsection "Display"
# Depth 16
Depth 16
Modes "default"
EndSubsection
EndSection

# The 16-color VGA server
Section "Screen"
Driver "vga16"
Device "Generic VGA Card"
Monitor "Generic Standard VGA, 640x480 @ 60 Hz"
Subsection "Display"
Modes "640x480" "800x600"
ViewPort 0 0
EndSubsection
EndSection

# The Mono server
Section "Screen"
Driver "vga2"
Device "Generic VGA Card"
Monitor "Generic Standard VGA, 640x480 @ 60 Hz"
Subsection "Display"
Modes "640x480" "800x600"
ViewPort 0 0
EndSubsection
EndSection


# The svga server
Section "Screen"
Driver "svga"
Device "S3 ViRGE (generic)"
Monitor "Generic Standard VGA, 640x480 @ 60 Hz"
DefaultColorDepth 16

Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
EndSection

# The accel server
Section "Screen"
Driver "accel"
Device "S3 ViRGE (generic)"
Monitor "Generic Standard VGA, 640x480 @ 60 Hz"
DefaultColorDepth 16

Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
EndSection
 
Old 08-13-2002, 02:49 AM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Have you tried running XF86Config as root? And gone through the setup completely and accurately that way?

No ftp? Is it down?
 
Old 08-13-2002, 03:06 AM   #7
19802974
LQ Newbie
 
Registered: Aug 2002
Posts: 4

Original Poster
Rep: Reputation: 0
how do i run a text file ?????
 
Old 08-13-2002, 03:07 AM   #8
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
he he he, sorry, it's lower case I think

xf86config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
startx crashes computer artificialGekko Slackware 17 03-12-2005 10:14 PM
"startx" crashes entire system after xorgconfig is run sether Arch 7 11-16-2004 02:11 PM
Bug / Xwindows / startx : xinit works but startx crash www.rzr.free.fr Linux - Software 4 10-17-2004 08:06 AM
XFCE crashes when i startx. kriep Slackware 1 12-06-2003 11:31 PM
startx crashes divekar Linux - Software 1 11-22-2000 06:49 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration