LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2004, 05:34 PM   #1
dualcyclone
LQ Newbie
 
Registered: Mar 2004
Location: UK
Posts: 2

Rep: Reputation: 0
Question Startup question and Shut-down problem


Hi,

Just a couple of issues:

On startup, how do i get linux to turn the num-lock on so that it is usable as soon as linux is booted.

And, secondly, when i shut down, the machine does turn off.... but for some reason, after about 10 seconds of being powered down, the computer boots itself again. This only occurs when shutting down from linux!

Anyone know how i can solve these?

Thanks
 
Old 03-26-2004, 06:17 PM   #2
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
I can sort of help with one, if you're flexible...

I could not find a way to get the numlock on either when using gnome desktop, which frustrated me so much that I tried the KDE desktop instead, which allows you to set that option in the keyboard configuration. I found that I really like KDE, and haven't gone back since...

Who knows, maybe trying that will help with your shutdown issue as well, as I assume that this process is controlled by whichever desktop manager you're using.

Just a thought...
 
Old 03-26-2004, 07:12 PM   #3
caesius_01
LQ Newbie
 
Registered: Oct 2003
Posts: 21

Rep: Reputation: 15
You can set NumLK boot status under the BIOS settings of your computer.
 
Old 03-26-2004, 07:25 PM   #4
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
From my experience it seems as though Gnome "resets" the numlk status upon boot, as I checked the BIOS setting when trying to fix this and boot numlock status was set to on.

fyi...
 
Old 03-26-2004, 07:30 PM   #5
Dunedain
Member
 
Registered: Jan 2004
Location: Norway
Distribution: FC12
Posts: 77

Rep: Reputation: 15
I don't really know about Gnome... But there should be some sort of way to make the NumLock start at DE init.

Check if you can find any Desktop Enviroment settings or a control centre or such. Look for it under Keyboard(duh)
 
Old 03-08-2005, 12:58 AM   #6
Francis
Member
 
Registered: Nov 2004
Location: New Zealand
Distribution: Slackware 10.0
Posts: 37

Rep: Reputation: 15
I've been having the same problem and find it quite annoying. I checked my BIOS and found that it was set to turn it on, but in KDE it was automatically off. In KDE there is a setting for Numlock status that has the following options..

#Always Turn Numlock on
#Always Turn Numlock off
#Leave it the same

I tried the first option and as expected, when I started KDE it turned Numlock on. For the purposes of experimentation I set KDE to leave the Numlock status alone and rebooted, when I started KDE again Numlock was off. It seems that my BIOS turns Numlock on but when Linux boots it turns if off. KDE can be configured to either turn it on, turn it off or leave it the same which kind of eliminates the problem, but I'm interested in why Linux turns it off when it boots, I think I'll browse some config files
 
Old 03-09-2005, 03:20 AM   #7
Francis
Member
 
Registered: Nov 2004
Location: New Zealand
Distribution: Slackware 10.0
Posts: 37

Rep: Reputation: 15
Aha!

http://www.justlinux.com/nhf/Hardwar...o_Stay_On.html

basically you put..

for t in 1 2 3 4 5 6 7 8
do
setleds -D +num < /dev/tty$t > /dev/null
done

at the end of your /etc/rc.d/rc.local file

worked for me, numlock is on in my shell after rebooting, doesn't necessarily change numlock status for your window manager though.
 
Old 03-10-2005, 04:03 PM   #8
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Wow, good find. Thanks for sharing...

I had been using numlockx when I'm using Gnome, but I'll have to give that a try...

Jeff
 
Old 03-12-2005, 03:07 AM   #9
mario8723
Member
 
Registered: Feb 2005
Distribution: Ubuntu Hoary 5.04
Posts: 65

Rep: Reputation: 15
I know for Debian distros it would be:

sudo apt-get install numlockx

That's it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shut down problem fireball003 Linux - General 5 05-18-2005 07:25 AM
Shut-down question on 10.1? wardialer Mandriva 7 05-17-2005 03:34 PM
Question Shut-down?? wardialer Linux - Newbie 15 03-06-2005 06:03 PM
Shut-down problem payasam Mandriva 4 12-02-2004 02:51 PM
shut-down problem ronss Linux - Hardware 6 04-16-2003 07:59 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration