LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2015, 09:24 AM   #1
Jim Lup
LQ Newbie
 
Registered: Apr 2014
Posts: 12

Rep: Reputation: Disabled
Startup manager


I have 2 OS using mint.

I would like to select either OS by default.

I have tried to download startup manger, but it is not found.

Is there a substitute method?

Thanks, Jim
 
Old 02-01-2015, 10:39 AM   #2
wpeckham
Senior Member
 
Registered: Apr 2010
Location: USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,660

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Startup

To select one of multiple installed OS:
Grub (Recommended, there are two versions, both very good.)
Lilo (older, works well, less compatible with non--linux OS families like Microsoft's)

Other options are out there, but not as 'core'. Grub is supportable and the Mint default. I am confused a bit about why it is not already installed and giving you the choice on boot.
 
Old 02-01-2015, 12:54 PM   #3
Jim Lup
LQ Newbie
 
Registered: Apr 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Let me rephrase my original question.

When the system boots I always have the choice to select either OS.

What I would like is to set one OS as default,so it will boot on every switch on.

I shut my system down every night.


I have loaded Lilo using Synaptic PM.

Nothing has changed concerning boot.

Also, I can not find Lilo on my system.
 
Old 02-02-2015, 07:31 AM   #4
wpeckham
Senior Member
 
Registered: Apr 2010
Location: USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,660

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
LILO

Check the man page. The control is in the conf file (generally /etc/lilo.conf)

If LILO is in fact in control of your start and not grub, you will find the settings in the conf file. One is default, another is delay. Default is the name of the default OS to boot, and delay is how long to wait for an interrupt before acting (in 0.1 second counts). IF an interrupt (shift key, for example) is detected then the count stops and start is under user control.

If your current start works, just does not autostart the one you want, I would make only the minimum changes required to fix this.

The default boot manager for your OS is grub, which is far more powerful. Are you sure that your start is lilo controled and not grub? Settings grub is quite different.
 
Old 02-02-2015, 08:01 AM   #5
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Ubuntu MATE, Mint MATE & antiX MX-15
Posts: 1,666
Blog Entries: 5

Rep: Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562
You need to edit the /etc/default/grub file:

Code:
gksu gedit /etc/default/grub
Next, change the line:

GRUB_DEFAULT=

to whatever is required and then save the changes.

By default, GRUB_DEFAULT=0 uses the first entry as the default.

Change the number to 1 to use the second entry, 2 to use the third etc.

Next, you must run 'update-grub':

Code:
sudo update-grub
http://www.howtogeek.com/196655/how-...ders-settings/
 
Old 02-02-2015, 01:36 PM   #6
Jim Lup
LQ Newbie
 
Registered: Apr 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Ok, grub is controlling the boot process.


The choices that are shown at boot are;


Mint 16 cinnamon

Mint 16 cinnamon---recovery mode

Memory test

Memory test---serial console

Mint 17

Mint 17---Advanced options


Does this mean, if I want to make (Mint 17---Advanced options)

the default selection, then I need to add a (5) in the grub

system default options line of code?
 
Old 02-02-2015, 02:57 PM   #7
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Ubuntu MATE, Mint MATE & antiX MX-15
Posts: 1,666
Blog Entries: 5

Rep: Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562
Yes, it should be 5, since Mint 17-Advanced is the sixth item on the list.

Edit the grub file:

Code:
GRUB_DEFAULT=5
Then run 'update-grub':

Code:
sudo update-grub
Are you sure that you want to choose Mint 17-Advanced and not just Mint 17, which would be the more usual option?

Then again you may have a good reason for doing so.

All the best.

Last edited by beachboy2; 02-02-2015 at 03:05 PM.
 
Old 02-02-2015, 03:10 PM   #8
Jim Lup
LQ Newbie
 
Registered: Apr 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Ok, not sure which is better for me, standard or advanced.

I honestly do not know the differences.

Also, which OS do I change the Grub value in?

Is it the 16, or the 17?

Thanks
 
Old 02-02-2015, 06:42 PM   #9
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Ubuntu MATE, Mint MATE & antiX MX-15
Posts: 1,666
Blog Entries: 5

Rep: Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562
I would recommend using Mint 17 standard as the default.

There is only a single grub file covering Mint 16, Mint 17 and the other 4 entries (6 entries in total).

Use this:

Code:
gksu gedit /etc/default/grub
and change the original (GRUB_DEFAULT=) setting to this:

Code:
GRUB_DEFAULT=4
Save the changed file.

You must then do this:

Code:
sudo update-grub
 
Old 02-03-2015, 07:00 AM   #10
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by Jim Lup View Post
Also, which OS do I change the Grub value in?

Is it the 16, or the 17?

Thanks
Whichever one was installed last -- there can only be one bootloader active.

You can change this by running `grub-install /dev/sd<x>` from whichever OS you want to be "in charge" (where <x> is the block device assigned to your main hard drive -- check by using `lsblk`).

If you decide to change this, you will also have to change /etc/default/grub and run `update-grub` from that system.

Last edited by Head_on_a_Stick; 02-03-2015 at 08:04 AM. Reason: awful grammer
 
Old 02-03-2015, 07:49 AM   #11
wpeckham
Senior Member
 
Registered: Apr 2010
Location: USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 1,660

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Caution

If ever you decide to retire the default OS, make sure you go through the process to migrate the config to another and make IT the default and boot control first. Forgetting this IS fixable, but can make your machine temporarily unbootable.
 
Old 02-03-2015, 08:32 AM   #12
Jim Lup
LQ Newbie
 
Registered: Apr 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
I just want to thank Wpeckhan, Head on a Stick and beachboy2 for

your patience and most helpful guidance.

It is people like all of you that make Linux awesome!!!


Thanks much,
Jim
 
Old 02-03-2015, 09:43 AM   #13
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Ubuntu MATE, Mint MATE & antiX MX-15
Posts: 1,666
Blog Entries: 5

Rep: Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562
Jim Lup,

Glad you got it sorted.

Don't forget to mark the thread as SOLVED (see Thread Tools above your original post).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Startup Manager dragonfish52 Debian 4 05-17-2012 04:00 PM
[SOLVED] startup manager in gos soloman498 Linux - General 3 06-30-2009 05:43 PM
Problem installing startup manager phil66 Linux - Newbie 1 05-16-2008 04:30 PM
Remove Power Manager from Startup varaonaid Linux - Software 2 07-08-2007 06:29 PM
KDM Session Manager Startup Murdock1979 Slackware 2 08-04-2005 08:51 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration