LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-06-2004, 08:16 PM   #1
chrisbhall
LQ Newbie
 
Registered: Oct 2004
Posts: 10

Rep: Reputation: 0
startup in a terminal


I am trying to install updated drivers for my video card on my Fedora Core 2 system. It says I cannot be in a GUI such as Gnome, which is how my computer starts by default. I cannot seem to find how to start it in a terminal only. Can someone provide me with some insight on this?
 
Old 10-06-2004, 08:34 PM   #2
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Take a look at your /etc/inittab with a text editor.

Somewhere in it you should find the boot options for your distro such as:

Code:
# These are the default runlevels in Slackware:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot
Set your "default runlevel" to multiuser mode. (3 in this case.)

Next time you reboot you should be in console. Switch it back when you're ready for X again.
 
Old 10-06-2004, 08:39 PM   #3
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,870

Rep: Reputation: 87
I often do not worry about how a distro starts when I need to "not be in X-windows" for something.
I just use CTRL-ALT-Fx (x=2-6?), when the GUI login shows up to go to a text login. Do whatever I need to do, and reboot.

The command "init 3" (I think) would be correct to drop to console from GUI in Fedora.

Editing "/etc/inittab" for the default runlevel is also an option.
 
Old 10-06-2004, 08:47 PM   #4
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Oh right, sorry, I'm assuming you don't want X even loaded in the background
Ctrl+Alt+F2-6, right

If indeed you don't want X loaded at all, then go with the 'init 3' option. (some systems require /sbin/init 3, what's up witht hat anyway?)
 
Old 10-06-2004, 09:38 PM   #5
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,870

Rep: Reputation: 87
Quote:
(some systems require /sbin/init 3, what's up witht hat anyway?)
I don't think I have run across that, but if you are using one distro and think you can tell what must be done in another you often need to think again.
My Debian Woody installs boot to GUI in run level 3 by default.
Administration tools are not the same across distributions and utilities may not be compiled with the same options.
 
Old 10-07-2004, 08:40 AM   #6
chrisbhall
LQ Newbie
 
Registered: Oct 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks

I tried the first suggestion made by Awatto there, setting the defaultlevel to 3 in the /etc/inittab file. worked like a charm. I'm still getting used to all this stuff and did have a bit of trouble changing it back. I had used gedit to change it while in gnome. after the reboot, i installed the drivers, and opened inittab back up in vi. Took me a bit of time to figure out how to delete/append/save. I feel like such an id10t playing with Linux, but, after reading through some manuals I printed I got it done. Anyways, thanks for your help guys.
 
Old 10-07-2004, 03:20 PM   #7
Awatto
Member
 
Registered: Aug 2003
Location: Halifax, NS
Distribution: Debian, Gentoo, Ubuntu, Fedora
Posts: 128

Rep: Reputation: 30
Hehehe, took me a while to figure all that my first time too, I ran into the same problems... We've all done it before

Sorry I didn't think about that and mention that sort of thing :-\

You could've done "startx" and booted into X and used your GUI editor you know
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
terminal windows open at startup blizunt7 Linux - General 1 07-24-2005 03:46 PM
terminal window on startup? zeviddalop Linux - General 4 09-21-2004 03:38 PM
Fortune on gnome-terminal startup? schmmd Linux - Software 1 03-08-2004 06:18 PM
log in to virtual terminal when startup yenonn Linux - General 5 06-30-2003 08:06 AM
terminal at startup? lyinghappyeyes Linux - Newbie 2 08-27-2001 03:40 PM


All times are GMT -5. The time now is 02:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration