LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-26-2004, 05:51 AM   #16
batfastad
Member
 
Registered: Nov 2004
Location: London, UK
Distribution: CentOS, RHEL, Debian, IPCop, PS2Linux
Posts: 95

Original Poster
Rep: Reputation: 23

Any idea why that's not working?

Thanks

Ben
 
Old 11-26-2004, 04:45 PM   #17
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
I'm not in front of a redhat box at the moment but have you tried 'chkconfig nmbd on' or 'chkconfig nmd on'? Another thing you can try is 'ntsysv' and enabling nmb (or nmbd). Most likely it's not working because you are mis-spelling it.

-twantrd

Last edited by twantrd; 11-26-2004 at 04:46 PM.
 
Old 11-30-2004, 04:22 PM   #18
batfastad
Member
 
Registered: Nov 2004
Location: London, UK
Distribution: CentOS, RHEL, Debian, IPCop, PS2Linux
Posts: 95

Original Poster
Rep: Reputation: 23
I've tried...

chkconfig nmbd on
chkconfig nmd on
chkconfig nmb on

and they all produce the same error above when I'm logged in as root.

If I type ntsysv I get a screen with options to enable various services.

smb is selected but there's no sign of nmbd, nmb or nmd in that list.

There's...
named, ndtps, netfs, network, nfs and nscd

If I do...

locate nmb it comes up with various results but the most likely is /usr/sbin/nmbd

How do I get nmbd added to that list in ntsysv?

Thanks

Ben
 
Old 01-25-2005, 11:35 PM   #19
alejandroye
Member
 
Registered: May 2004
Location: SOUTH FLORIDA USA
Distribution: MANDRIVA / CENTOS
Posts: 146

Rep: Reputation: 15
Question restarting samba

hey

I am curios, I have linux(drake) in one of my computer and XP other, so I tried to enable samba to see linux from Xp, but, when I make some change in smb.conf, look like samba no get the change that I did

I added this

[myshareweb]
comment = website
path = /var/www/html
valid users = user1 user2 user3
public = no
writable = yes
printable = no

but when I take any user from there and restsart samba, I still accessing by xp to that path in linux with the user that I deleted

even doing big change in smbd.conf and restasting samba, still conected

command that I am using to stop and start are
#smbd stop
#smbd start

any idea what is happening

Last edited by alejandroye; 01-25-2005 at 11:42 PM.
 
Old 01-26-2005, 02:50 AM   #20
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Batfatstad - If you just enable smbd, that should be enough as it *should* start nmbd as well.

alejandroye - Have you restarted your XP workstation and then tried logging in? Windows usually caches the username/password during that session.

-twantrd
 
Old 01-26-2005, 09:59 AM   #21
alejandroye
Member
 
Registered: May 2004
Location: SOUTH FLORIDA USA
Distribution: MANDRIVA / CENTOS
Posts: 146

Rep: Reputation: 15
thank you for you FAST answer twantrd, look like worked

but now I have other question

when I try to access from XP to linux I get a window asking me for login and password

I know is because in smb.conf I defined like that:
---------------
[myshareweb]
comment = website
path = /var/www/html
valid users = user1 user2 user3
public = no
writable = yes
printable = no
--------------------------
BUT even when I type the login and password can not access

I am typing, user1 and password, the system do not let me access to the folder, the only way that I can access to the folder is going to linux and chmod the directory as 777 and that is not my idea, the idea is the owner and the group can access to the folder through XP

I create user1 and I included in the folder group but still, I cannot access

any idea to solve this problem of

thk
 
Old 01-26-2005, 10:09 AM   #22
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,948

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
samba consists of two daemons smbd and nmbd. You should be able to start them as root in a console window.
nmbd -D
smbd -D

The startup script smb will start both daemons. To start via ntsysv
service smb on

To see how samba is configured to start at boot
chkconfig --list smb

To configure samba to start at boot
chkconfig --level 35 smb on

If you still have problems then check the logs
/var/log/samba
 
Old 01-26-2005, 12:07 PM   #23
alejandroye
Member
 
Registered: May 2004
Location: SOUTH FLORIDA USA
Distribution: MANDRIVA / CENTOS
Posts: 146

Rep: Reputation: 15
this didn't help to my question, sorry
 
Old 01-26-2005, 03:02 PM   #24
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Michael's response was to help batfastad .

alejandroye - You said that you added 'user1' to the group. Looks like there is something incorrect with the permissions you set. You don't need to chmod 777 to make samba work (755 is enough). Is user1 the owner of the directory? If you want groups to have access via smbd, then change "valid users = user 1 .... " to "valid users = @groupname"

-twantrd
 
Old 01-29-2005, 07:28 PM   #25
alejandroye
Member
 
Registered: May 2004
Location: SOUTH FLORIDA USA
Distribution: MANDRIVA / CENTOS
Posts: 146

Rep: Reputation: 15
Unhappy STILL HAVING PROBLEM

Thank you for your help, but I am still having problem, I am getting crazy with this

This is my scenario

2 machines, XP and Linux, I am trying to get access from XP to Linux with the idea is to read and write files to those specific folders, but when I open explorer on XP to get the linux folder, I see the MKGROUP, SAMBA SERVER 3.0.7 (LOCALHOST), and the folders already configured on smb.conf; "public" and "myshareweb", until here is ok

Now, when I try to open those folder, one, I get the window asking me "User Name" and "Password" and when I try the other folder just say "\\localhost\public\ is not accessible. You might not have permission to use ......"


this is my smb.conf
===================================
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[Profiles]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[pdf-gen]"
Global parameter printcap name found in service section!
Processing section "[admin]"
Processing section "[public]"
Processing section "[myshareweb]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
workgroup = MDK1MANGOSGROUP
netbios name = MANGOS
server string = Samba Server %v
security = SHARE
map to guest = Bad User
passdb backend = tdbsam, smbpasswd, guest
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
printer admin = @adm

[homes]
comment = Home Directories
read only = No
browseable = No
root preexec = /usr/bin/ntlogon -u '%u' -g '%g' -o %a -d /var/lib/samba/netlogon/
root postexec = rm -f '/var/lib/samba/netlogon/%u.bat'

[Profiles]
path = /var/lib/samba/profiles
read only = No
guest ok = Yes
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
use client driver = Yes
browseable = No

[print$]
path = /var/lib/samba/printers
write list = @adm, root
inherit permissions = Yes
guest ok = Yes

[pdf-gen]
comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
printing = bsd
print command = /usr/share/samba/scripts/print-pdf "%s" "%H" "//%L/%u" "%m" "%I" "%J" &
lpq command = /bin/true
lprm command = lprm -P'%p' %j

[admin]
path = /
valid users = "@Domain Admins"
admin users = "@Domain Admins"
read only = No
browseable = No

[public]
comment = Public Stuff
path = /var/www/test
write list = @staff
read only = No
guest ok = Yes

[myshareweb]
comment = Ale Website
path = /var/www/html
valid users = @ale
force user = ale
force group = ale
read only = No
guest ok = Yes

=====================
the owner of those folder is ale that is also group ale


please, please please any idea to solve this


the only way that I do not have problem is setting the folder mod 777, by doing this let me see the folder and write in there


Last edited by alejandroye; 01-29-2005 at 11:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SMB services tonyr321 Linux - Newbie 3 10-21-2005 04:04 PM
SMB connection failed sichen Linux - Networking 1 08-13-2004 09:51 PM
Start services automatically (httpd & SMB) krazyglue Linux - Newbie 8 07-11-2004 04:48 AM
SMB connection failed Geefthegreat Linux - Networking 3 03-31-2004 08:04 AM
SMB Failed rbanonuevo Linux - Newbie 1 01-24-2002 09:03 AM


All times are GMT -5. The time now is 04:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration