LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2003, 12:13 PM   #1
OceanSurf
Member
 
Registered: Aug 2003
Location: Si
Distribution: SuSE, Slackware
Posts: 37

Rep: Reputation: 15
starting httpd won't work


I installed RedHat 9 last night and i'm trying to get the apache/php/mysql thing to work but no go! when i try to start the httpd like

service httpd start it returns bash: service : command not found !

same with httpd or when i use whereis to find such files it can't find it!
same with apachectl and other stuff!
why where what...???

these are the packages that came with the distro. but if i try to compile it ends with fatal errors like there are none header files needed and i can't even find them.

please explain or point me to the direction with explanation.

I've already read the RedHat 9 documentation. No help.

isn't it supposed to work already if it comes with the distro, how do i find it then and run everything?
 
Old 08-16-2003, 01:00 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Are you running these commands as root? And did you make sure that apache was installed in the default install, or whatever type of install you performed?
 
Old 08-17-2003, 05:34 AM   #3
OceanSurf
Member
 
Registered: Aug 2003
Location: Si
Distribution: SuSE, Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
Yes, I'm running 'em as root and it's all installed (i believe so). Well I didn't run any commands like config stuff after the CD install. Am I supposed to?

It's funny cause most of basic commands won't work and I don't know why. noob!
 
Old 08-17-2003, 05:51 AM   #4
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
try as root

/etc/init.d/httpd start
 
Old 08-17-2003, 09:42 AM   #5
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Quote:
It's funny cause most of basic commands won't work and I don't know why.
It is possible that the PATH variable is not setup correctly,
post the output of the following command (as root):
Code:
echo $PATH
 
Old 08-19-2003, 05:42 AM   #6
OceanSurf
Member
 
Registered: Aug 2003
Location: Si
Distribution: SuSE, Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
Looking_Lost: As root i typed the command and got this:

/etc/init.d/httpd start
Zaganjam httpd: httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

Mathieu: this is what it printed:

# echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/marko/bin

Is it causing me problems mostly because I installed RH9 as workstation and not server? Maybe I'll try and install it again as server and then I'll see. How is with other aplications if I install as server? All I need is KDevelop, Apache+PHP+MySQL/PostgreSQL, Quanta+, Blender3D, internet stuff (http, ftp) and maybe Xine.

I'll be away from home for a couple of weeks so I'll post an answer what happened. Cheers and thanks for your help.-
 
Old 08-19-2003, 09:31 AM   #7
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Well you've got it going then, does it show the deault page if you point you browser to 127.0.0.1, if it don't you have to change a setting in httpd.conf relating to your server name or put in your ip address,
or add the name you're using for your server to /etc/hosts.

Can't be more specific at the moment as I am linux-less for the next few days.


Someone will point you to the specific
 
Old 08-19-2003, 10:27 AM   #8
OceanSurf
Member
 
Registered: Aug 2003
Location: Si
Distribution: SuSE, Slackware
Posts: 37

Original Poster
Rep: Reputation: 15
it does not show the default page. connection to localhost (127.0.0.1) refused! httpd fails to start in the first place. I'll try installing RH9 as server and see what happens. Thanks for your time.
 
Old 08-19-2003, 01:08 PM   #9
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
You need to set the NameVirtualHost option to 127.0.0.1 in httpd.conf
Take a look at the Setting Up Virtual Hosts section in this tutorial.
http://www.e-gineer.com/instructions...on-linux.phtml

As for the service command, you need to be root.
To become root at the command lne, type the following command and enter your root password:
Code:
su -
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting httpd: /usr/sbin/httpd: symbol lookup error: /usr/local/lib/libaprutil-0.so. bijuhpd Linux - Newbie 1 10-30-2005 06:07 PM
starting httpd upon boot strimp099 Red Hat 6 06-06-2004 09:23 PM
Starting httpd-2.0.47-8 sthf Red Hat 3 11-03-2003 01:28 PM
starting httpd hrishikesh Linux - Software 4 08-29-2003 10:45 PM
Starting/stopping httpd bughunter Linux - Newbie 3 10-20-2001 11:02 AM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration