LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-01-2006, 02:51 AM   #1
ch485de
LQ Newbie
 
Registered: Nov 2006
Distribution: PCLinuxOS
Posts: 29

Rep: Reputation: 15
Starting hangs after CUPS installed


I'm in my first few days of Linux. I've installed PCLinuxOS - it seemed the most laptop friendly distro I've found. I've been adding hardware in an orderly manner.

Yesterday I installed my printer (a Samsung ML1510 Laser) and that worked well after installing the drivers within the distro.

However I now cannot boot PCLinuxOS - it hangs at the CUPS installation point. I've tried using Failsafe at boot, but other than showing me where the problem is, it hasn't allowed me to fully boot into Linux.

So what do I do to regain control of my Linux installation?
 
Old 12-01-2006, 03:39 AM   #2
ch485de
LQ Newbie
 
Registered: Nov 2006
Distribution: PCLinuxOS
Posts: 29

Original Poster
Rep: Reputation: 15
I've found the following in a previous post on this forum:

i think your cups is started to early in the boot-sequence.
to try you could comment-out the cups-call in /etc/rc.d/rc.M and copy it to /etc/rc.d/rc.local.

It may be the same in my case, but how do I boot into Linux to try it? How would I 'comment out' the cups call?

Sorry but I'm still very very new to all this.
 
Old 12-01-2006, 07:22 AM   #3
ch485de
LQ Newbie
 
Registered: Nov 2006
Distribution: PCLinuxOS
Posts: 29

Original Poster
Rep: Reputation: 15
Well I've regained access to my Linux by running the LiveCD version and then renaming the CUPS directory. It's a bit brutal because I can't now print.

How can I disable auto boot of CUPS and so manually restart CUPS after everything else has loaded?
 
Old 12-01-2006, 07:59 AM   #4
ch485de
LQ Newbie
 
Registered: Nov 2006
Distribution: PCLinuxOS
Posts: 29

Original Poster
Rep: Reputation: 15
I've now found how to disable the auto boot of CUPS. That's solved the problem with hanging when I boot.

So, how do I turn CUPS on after booting so I can print?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS is not starting whitehawk77 Linux - Newbie 1 07-11-2006 05:56 AM
rc.cups hangs on boot Barx Slackware 3 10-28-2004 03:51 AM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 07:39 PM
FC2 CUPS Hangs on Startup Sliceman Fedora 0 07-13-2004 01:03 PM
Starting CUPS sharpie Slackware 6 04-18-2004 07:32 AM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration