LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-26-2008, 11:19 AM   #1
deputybill
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Rep: Reputation: 0
Starting gftp


What do I need to type at the command line to start gftp. I have already installed it but when I try to run it I get that is is disabled.

Thank you.

Bill Mann
 
Old 06-26-2008, 01:04 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
gftp can't be "disabled", it's just an ftp client. what actually happens? if you're typing in "gftp" in a console then copy and paste here the whole console activity.
 
Old 06-27-2008, 10:58 AM   #3
deputybill
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Original Poster
Rep: Reputation: 0
gftp-text has been disabled

[root@ip-72-167-52-157 username]# gftp
Sorry, gftp-text has been disabled.
[root@ip-72-167-52-157 username]#

Last edited by deputybill; 06-27-2008 at 11:00 AM.
 
Old 06-27-2008, 11:20 AM   #4
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
It looks like gftp can't open in the current X environment (if any) and tries to run in text mode. On recent distributions the text mode has been disabled, so the only option is to compile from source. Anyway, are you trying to run gftp on a remote machine? What is the output of
Code:
echo $DISPLAY
 
Old 06-27-2008, 04:56 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
hmm, I would have thought you'd have gotten an X refusal as well as any fall out if it was trying to do that. maybe your as yet unnamed distro has an additional package like gftp-gtk like ubuntu does.
 
Old 06-27-2008, 05:07 PM   #6
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Don't know for other distros, but on fedora the gftp command is a shell wrapper which checks for DISPLAY and launches the gtk or the text version accordingly:
Code:
#!/bin/sh

if [ "$DISPLAY " != " " ] && [ -f /usr/bin/gftp-gtk ]; then
        exec /usr/bin/gftp-gtk ${1+"$@"}
elif [ -f /usr/bin/gftp-text ]; then
        exec /usr/bin/gftp-text ${1+"$@"}
else
        echo "Error: Can't find gFTP binaries installed in /usr/bin"
fi
When X is not available, I think the only advantage for using text-based gftp is the ability to download an entire directory, even if the same can be accomplished using wget over ftp with recursion.
 
Old 06-27-2008, 05:24 PM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
ahh, yeah that makes sense. wonder where that actual message would come from then? surely you'd just not have the check in the first place... developers eh?
 
Old 06-27-2008, 05:29 PM   #8
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,793

Rep: Reputation: 292Reputation: 292Reputation: 292
Quote:
Originally Posted by colucix View Post

Don't know for other distros, but on fedora the gftp command is a shell wrapper which checks for DISPLAY and launches the gtk or the text version accordingly:
I wrote some documentation for gftp in 2002. What you describe is the way that gftp comes from the author. Here is what I had to say about gftp text and gtk versions:

Quote:
gftp-gtk is a the name of the GUI version of gFTP. The command gftp is actually a script which decides whether, under the circumstances, to launch gftp-text or gftp-gtk. If gftp does not launch the version that you want you can use gftp-text or gftp-gtk.

acid_kewpie said:
Quote:
ahh, yeah that makes sense. wonder where that actual message would come from then? surely you'd just not have the check in the first place... developers eh?
I would check deputybill's script in /usr/bin/gftp. Most likely somebody (what distribution is deputybill using?) changed the gftp script to give an error message instead of starting gftp-text. When I start gftp from the console I get gftp-gtk. When I start gftp-text from the console I get gftp-text. am using Debian 4.0

---------------
Steve Stites

Last edited by jailbait; 06-27-2008 at 05:44 PM.
 
Old 06-27-2008, 05:40 PM   #9
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by acid_kewpie View Post
ahh, yeah that makes sense. wonder where that actual message would come from then?
It comes from the (disabled) gftp-text script itself...
Code:
#!/bin/sh

echo "Sorry, gftp-text has been disabled."
Quote:
If gftp does not launch the version that you want you can use gftp-text or gftp-gtk.
Nevertheless, it seems the OP has not an X-server available. If he runs on a remote machine, he should enable X11 forwarding.
 
Old 06-28-2008, 02:44 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
i'd guess at running as root meself.
 
Old 06-29-2008, 09:10 AM   #11
deputybill
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Original Poster
Rep: Reputation: 0
gftp-gtk

When I run gftp-gtk I get the following:

(gftp-gtk:5412): Gtk-WARNING **: cannot open display:

Does this shed more light on the problem?

Thank you.

Bill
 
Old 06-29-2008, 11:09 AM   #12
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
not really, we know that that would be the error if you ran it directly, but you've not confirmed how you are running it to comment further. My money is still on you incorrectly trying to run it as root when you've logged into X with a normal user account, in xhost case "xhost +localhost" will sot you out, but better still, don't run any user applications as root.
 
Old 03-12-2012, 12:23 PM   #13
frakman1
LQ Newbie
 
Registered: Jan 2006
Posts: 3

Rep: Reputation: 0
I am running into the same exact problem. I am running it as user (not root). I hope the log below is clear and answers any of your previous questions.
My system is a Red Hat Fedora: 2.6.27.38-170.2.113.fc10.i686


[alnaumf@fraklinux bin]$ gftp
Sorry, gftp-text has been disabled.
[alnaumf@fraklinux bin]$ cat ./gftp
#!/bin/sh

prefix=/usr
exec_prefix=/usr

if [ "$DISPLAY " != " " ] && [ -f /usr/bin/gftp-gtk ]; then
exec /usr/bin/gftp-gtk ${1+"$@"}
elif [ -f /usr/bin/gftp-text ]; then
exec /usr/bin/gftp-text ${1+"$@"}
else
echo "Error: Can't find gFTP binaries installed in /usr/bin"
fi

[alnaumf@fraklinux bin]$ gftp-gtk

(gftp-gtk:15738): Gtk-WARNING **: cannot open display:
 
Old 03-12-2012, 06:02 PM   #14
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
please do not hijack dead threads.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gFTP help swamprat SUSE / openSUSE 1 06-15-2007 05:02 PM
gftp? hitest SUSE / openSUSE 6 08-28-2005 02:10 PM
gFTP riluve Linux - Software 2 03-14-2005 02:58 AM
gFTP Mahony Linux - Software 4 04-14-2004 05:02 PM
gFTP nautilus_1987 Linux - Software 5 11-29-2002 12:57 PM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration