LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Stale NFS File Handle problem (http://www.linuxquestions.org/questions/linux-newbie-8/stale-nfs-file-handle-problem-661350/)

mpnorth 08-08-2008 02:36 AM

Stale NFS File Handle problem
 
Hi

I wasn't aware that I even had NFS on my machine ( Suse 11.0) I have found NFS client in Yast and I have uninstalled it. I have not used NFS and have no requirement to do so.

My problem is that a number of files and directories on my system cannot be "stated" for example

Suse-Raid:/home/martin # cd .VirtualBox
-bash: cd: .VirtualBox: Stale NFS file handle

This obviously makes them unusable. I have tried rebooting and running fsck, which finds no problems.

I guess this is just a flag on the files that has been set, does anybody know how to reset it ?

I asked this question in the forum on opensuse.org but got absolutely no response, hopefully here I will find somebody to help.

Regards

Mr. C. 08-08-2008 07:49 PM

Just to double check, what's the output of the commands:

Code:

mount
cat /etc/fstab
cat /etc/auto.master
ps -aux | egrep 'automount|nfs'

Stale file handle error occurs when an object on the NFS server has been pulled out from under a client, and the client tries to access a file or directory from the NFS mounted file system. There is no flag attached to files. Rather this problem is noticed when the kernel is doing path traversal.

mpnorth 08-09-2008 06:50 AM

This is what I get.............................


cat /etc/fstab............

/dev/mapper/sil_ahbhcacaciba_part6 / ext3 acl,user_xattr 1 1
/dev/mapper/sil_ahbhcacaciba_part5 /boot ext3 acl,user_xattr 1 2
/dev/mapper/sil_ahbhcacaciba_part7 /home ext3 acl,user_xattr 1 2
/dev/mapper/sil_ahbhcacaciba_part8 /Archive/SCSIPar8 ext3 acl,user_xattr 1 2
/dev/sdc1 /NonRaid/windows/XP ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
/dev/sdc2 swap swap
/dev/sdc4 /NonRaid/Archives/HD0Par4 ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_GB.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
/dev/sdd1 /NonRaid/MCE ext3 acl,user_xattr 1 2
/dev/sdd2 /NonRaid/linux2 ext3 acl,user_xattr 1 2
/dev/sdd3 /NonRaid/linux3 ext3 acl,user_xattr 1 2


Suse-Raid:~ # cat /etc/auto.master
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#
#/misc /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
# "nosuid" and "nodev" options unless the "suid" and "dev"
# options are explicitly given.
#
#/net -hosts
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master


Suse-Raid:~ # ps -aux | egrep 'automount | nfs'
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root 647 0.0 0.0 1992 664 pts/0 S+ 12:49 0:00 egrep automount | nfs


Does this help ?

Mr. C. 08-09-2008 10:53 AM

Ok, it appears this is an issue with LVM (logical volume manager). I don't know the solution, but here is a reference that can help move you forward focusing on LVM instead of NFS:

http://linux.derkeiler.com/Mailing-L.../msg01102.html

mpnorth 08-10-2008 05:37 AM

Thanks

I'll follow it up

Regards

mpnorth 08-11-2008 04:30 AM

...................

mpnorth 08-11-2008 04:32 AM

Unless anybody else here has a suggestion ?

Regards

mpnorth 08-11-2008 04:48 AM

I don't believe that I am using LVM. How can I tell ?

Mr. C. 08-11-2008 09:41 AM

It is pretty evident from the output of the mount command.

mpnorth 08-12-2008 05:36 AM

Hi

Sorry I'm a bit if a Newbie I'm afraid but I assumed that the LVM was a method of using multiple partitions for 1 file system.

I have 2 separate IDE drives with multiple partitions and a pair of drives set up as a Raid drive, also with separate partitions, and each of these partitions has an individual mount point.

Is this considered a LVM system ?

Regards

Mr. C. 08-12-2008 10:57 AM

Some distros use LVM by default. This allows you to add more drives and include more partitions to grow file systems. Your fstab above indicates use of "/dev/mapper", hence my conclusion about LVM.

There are several links found via google regarding other users who indicate the same problem. I don't know the answer. Here is one such link, with two posts:

http://readlist.com/lists/redhat.com...vm/0/1679.html

I search Google with: "/dev/mapper" "Stale NFS"


All times are GMT -5. The time now is 01:56 AM.