LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-14-2010, 07:05 AM   #1
Unix_Queen
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Rep: Reputation: 0
Unhappy SSHd not running on Ubuntu 10.10 VM


Hi there,

I have just built my first ever Linux desktop, using VM Ware and it is running Ubuntu 10.10. I wish to try and use SSH to contact the machine but I don't believe the SSHD is running.

I have done a grep for SSHD shows nothing and have checked the Synaptic Package Manager and can see an openssh-client version 1:5.5.p1-4ubuntu is currently installed.

On Solaris, you can start SSH by typing /etc/init.d/ssh start but when checking /etc/init.d on Linux, there is nothing in there called SSH so am unable to restart it.

Please can someone help me? I just want to have the SSH running on the machine.

Many thanks in advance,
Donna
 
Old 10-14-2010, 07:10 AM   #2
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 111Reputation: 111
Install ssh server on ubuntu if not

Code:
$sudo apt-get install openssh-server
$sudo /etc/init.d/ssh start

Regards,

Last edited by sem007; 10-14-2010 at 07:12 AM. Reason: typo
 
Old 10-14-2010, 07:10 AM   #3
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

This is the command

Code:
sudo /etc/init.d/ssh restart
Disable firewall and selinux to get connected
 
Old 10-14-2010, 09:15 AM   #4
Unix_Queen
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Hiya guys,

Thanks for your help but I have fixed it! Looks like it wasn't the SSH not working at all, more a case of the apt-get wasn't working due to not having any proxy settings set. Once I had done this, openssh server became available to download and install and now it all works

Yay!

Thanks anyway!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PRNG is not set while running sshd saurin Programming 1 10-10-2009 10:32 PM
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied sumanc Linux - Server 5 03-28-2008 04:59 AM
Problems running sshd on gentoo locazor Linux - Security 8 05-20-2007 11:26 PM
SSHD Not Running on Debian System. JanusPaul Linux - Software 7 08-19-2006 02:52 PM
check to see if sshd is running naijaguy Linux - Newbie 1 08-14-2004 02:37 AM


All times are GMT -5. The time now is 05:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration