LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2010, 01:27 AM   #16
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147

Hi,

Can you remove the ssh rpm and re-install in!It may solve the problem!
 
Old 10-08-2010, 07:20 AM   #17
k1ck3r
LQ Newbie
 
Registered: Mar 2005
Posts: 1

Rep: Reputation: 0
...
 
Old 10-08-2010, 01:54 PM   #18
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
The variable $OPTIONS should be unset since it isn't set anywhere in that script. But you'd get an "illegal instruction" if it is set improperly.

As root, enter "echo $OPTIONS" and report on what it says. Should give a blank line.

Also, that line 102 has to be wrong; that is a left brace. I suggest you put some debug echo statements into the script in order to figure out exactly what line the script is failing on.

Last edited by jiml8; 10-08-2010 at 01:57 PM.
 
Old 10-08-2010, 05:15 PM   #19
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by amartlk View Post
hi sir
pls find the error exact as follows

starting sshd: /etc/init.d/sshd:line102:29984 illegal instruction $sshd$ option
It's still not making any sense. Line 102 has (as jiml8
pointed out earlier) an open curly brace "{" that couldn't
produce this error.

I'm inclined to accept the suggestion made to re-install
the package.


Cheers,
Tink
 
Old 10-09-2010, 01:06 AM   #20
amartlk
Member
 
Registered: Sep 2010
Location: Nagpur India
Posts: 347

Original Poster
Rep: Reputation: 1
reply pls need help
 
Old 10-09-2010, 01:43 PM   #21
raviteja_s
Member
 
Registered: Jun 2010
Location: India
Distribution: Redhat
Posts: 68

Rep: Reputation: 1
reinstall this packages


chkconfig-1.3.30.1-2


openssh-server-4.3p2-36.el5

Last edited by raviteja_s; 10-09-2010 at 01:44 PM.
 
Old 10-09-2010, 11:41 PM   #22
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Quote:
Originally Posted by amartlk View Post
reply pls need help
You have had many replies. What action have you taken to respond to the suggestions made???
 
Old 10-11-2010, 01:38 AM   #23
amartlk
Member
 
Registered: Sep 2010
Location: Nagpur India
Posts: 347

Original Poster
Rep: Reputation: 1
hi sir
i fired command echo $options shows balnk line, still i not installed ssh
 
Old 10-11-2010, 01:51 AM   #24
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
$OPTIONS != $options ...
 
Old 10-11-2010, 02:26 AM   #25
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Quote:
Originally Posted by jiml8
The variable $OPTIONS should be unset since it isn't set anywhere in that script. But you'd get an "illegal instruction" if it is set improperly.

As root, enter "echo $OPTIONS" and report on what it says. Should give a blank line.
Not entirely accurate. You're right that the script does not set the value of OPTIONS, but the script does indeed source other files:
Code:
# source function library
. /etc/rc.d/init.d/functions

# pull in sysconfig settings
[ -f /etc/sysconfig/sshd ] && . /etc/sysconfig/sshd
I used Red Hat many moons ago. The functions file contains generic utilities used across all startup scripts. Granted, this is CentOS, but I see no reason why they'd change things.

My bet would be that /etc/sysconfig/sshd is where OPTIONS gets set. Also, if I'm not mistaken, those sysconfig files are updated through some gui helper-config app. So, I'm thinking the OP used that app, changed some things without knowing exactly what was going on.

And if I'm right, OPTIONS wouldn't be an environment variable--meaning that trying to echo it wouldn't yield any useful info.

So, amartlk, please post the entire contents of /etc/sysconfig/sshd.
 
Old 10-11-2010, 04:36 AM   #26
amartlk
Member
 
Registered: Sep 2010
Location: Nagpur India
Posts: 347

Original Poster
Rep: Reputation: 1
hi
unable to find sshd in etc/sysconfig/sshd.i havwe centos5.3
 
Old 10-15-2010, 05:59 AM   #27
amartlk
Member
 
Registered: Sep 2010
Location: Nagpur India
Posts: 347

Original Poster
Rep: Reputation: 1
hi

first remove openssh rpm and reinstall same but the same error is shown

pls suggest what to do
 
Old 10-26-2010, 08:08 AM   #28
amartlk
Member
 
Registered: Sep 2010
Location: Nagpur India
Posts: 347

Original Poster
Rep: Reputation: 1
hi

first remove openssh rpm and reinstall same but the same error is shown

pls suggest what to do pls reply its urgent
 
Old 10-27-2010, 06:07 AM   #29
amartlk
Member
 
Registered: Sep 2010
Location: Nagpur India
Posts: 347

Original Poster
Rep: Reputation: 1
hi

no reply pls reply
 
Old 10-27-2010, 06:11 AM   #30
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Please let us know log:

Code:
tail -f /var/log/secure
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied sumanc Linux - Server 5 03-28-2008 05:59 AM
FC4-Starting sshd: Privilege separation user sshd does not exist FAILED kiranherekar Fedora 5 12-29-2005 03:22 PM
Sshd TimeBandit Linux - Software 4 06-20-2005 12:00 PM
Enabling SSH in mandrake 9.2 - sshd vs. sshd-xinetd DogTags Linux - Newbie 7 11-25-2003 01:17 PM


All times are GMT -5. The time now is 11:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration