LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-18-2016, 08:25 PM   #1
faizzeya
LQ Newbie
 
Registered: Feb 2016
Posts: 1

Rep: Reputation: Disabled
ssh -v localhost not working


Faiz ul haque Zeya@DESKTOP-JBSLACP ~
$ ssh -v localhost
OpenSSH_7.1p2, OpenSSL 1.0.2f 28 Jan 2016
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to localhost [::1] port 22.
debug1: Connection established.
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_rsa-cert type -1
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_dsa type 2
debug1: key_load_public: No such file or directory
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_dsa-cert type -1
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_ecdsa type 3
debug1: key_load_public: No such file or directory
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/Faiz ul haque Zeya/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.1
debug1: match: OpenSSH_7.1 pat OpenSSH* compat 0x04000000
debug1: Authenticating to localhost:22 as 'Faiz ul haque Zeya'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client chacha20-poly1305@openssh.com <implicit> none
debug1: kex: client->server chacha20-poly1305@openssh.com <implicit> none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:/dYsjCyGqzCLEvm0KylXSACdbxDR7n9HEOz6N2S1Btk
debug1: Host 'localhost' is known and matches the ECDSA host key.
debug1: Found key in /home/Faiz ul haque Zeya/.ssh/known_hosts:1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/Faiz ul haque Zeya/.ssh/id_rsa
Connection closed by ::1
 
Old 02-18-2016, 08:34 PM   #2
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,094

Rep: Reputation: Disabled
Quote:
Originally Posted by faizzeya View Post
Faiz ul haque Zeya@DESKTOP-JBSLACP ~
$ ssh -v localhost

debug1: Authentications that can continue: publickey,password,keyboard-interactive

debug1: Next authentication method: publickey


debug1: Offering RSA public key: /home/Faiz ul haque Zeya/.ssh/id_rsa
Connection closed by ::1
check your /etc/hosts if you see what I put in bold that is what closed you down.
try commenting it out. see if that effects anything.

localhost should be 127.0.0.1 but ::1 shut you down not 127.0.0.1.

for some reason your ssh is loging into ::1

my hosts file shows old host set up commented out and the ::1 is localhost and ip6-localhost.

Code:
#<ip-address>		<hostname.domain.org>	<hostname>
#127.0.0.1		localhost.localdomain	localhost
#::1			localhost.localdomain	localhost ip6-localhost


127.0.0.1               voided.brainwave.bw     brainwave.bw 
::1                     voided.brainwave.bw     voided ip6-localhost

127.0.1.1               voided.mybrain.bw       mybrain.bw
:1:1                    voided.mybrain.bw       voided ip6-localhost
when I try my ssh
Code:
%userx@voided ~>>$sudo ssh userx@mybrain.bw
userx@mybrain.bw's password: 
channel 0: open failed: administratively prohibited: open failed
Last login: Thu Feb 18 19:39:18 2016 from 127.0.0.1
%userx@voided ~>>$exit
logout
Connection to mybrain.bw closed.
%userx@voided ~>>$
I use sudo for tunneling because I was having a tunneling error.

though you should check your logs to see if that underline part had anything to do with it too.

it looks like it was

Quote:

debug1: Next authentication method: publickey


debug1: Offering RSA public key: /home/Faiz ul haque Zeya/.ssh/id_rsa
looking for another authentication from a publickey for some reason then that ::1 took over then shut you down for its reasons.... logs got a check them I suppose ...

Last edited by BW-userx; 02-18-2016 at 09:10 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH to localhost without password nixanwin Linux - Newbie 15 04-02-2014 04:25 PM
[SOLVED] linux(in VirtualBox) apache http://localhost working, but 127.0.0.1 not working zousheng Linux - Newbie 12 02-09-2013 07:21 PM
[SOLVED] SSH passwordless to localhost ikidntu Ubuntu 10 07-29-2010 10:16 AM
ssh in the localhost linderox Linux - Networking 3 02-20-2008 11:05 PM
ssh + pop3 with kmail: Could not connect to host localhost, but ok without ssh Emmanuel_uk Linux - Networking 0 07-20-2006 05:56 PM


All times are GMT -5. The time now is 08:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration