LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-14-2006, 04:14 PM   #1
b345713
LQ Newbie
 
Registered: Dec 2005
Posts: 19

Rep: Reputation: 0
ssh remote desktop - xserver config for x11 forwarding


Hello all,

I'm running fedora 4 (and cygwin under windows on the other and I get similar errors on both) and just configured ssh for remote access!

My question regards x11 forwarding setup!

When I establish my ssh connection through mindterm's or appgate's online java applets I have no difficulty, yet when I try running startx to get a remote desktop manager going which is my real objective, it reports a fatal server error saying server is already active for display 0!

It then says that if x is no longer running I should remove /tmp/.X0-lock and start again!

if ii try xinit I get the very same message!

If I try - startkde - i get the following:

X connection to localhost:10.0 broken (explicit kill or server shutdown).
X connection to localhost:10.0 broken (explicit kill or server shutdown).
X connection to localhost:10.0 broken (explicit kill or server shutdown).
X connection to localhost:10.0 broken (explicit kill or server shutdown).
startkde: Starting up...
ksplash: Fatal IO error: client killed
kded: Fatal IO error: client killed
DCOP aborting call from 'anonymous-21770' to 'kded'
kdeinit: Fatal IO error: client killed
kdeinit: sending SIGHUP to children.
klauncher: Exiting on signal 1
kdeinit: sending SIGTERM to children.
kdeinit: Exit.
Warning: connect() failed: : No such file or directory
ksmserver: Fatal IO error: client killed
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.


and with the - gnome-session - command I get:

The application 'gnome-session' lost its connection to the display localhost:10.
0;
most likely the X server was shut down or you killed/destroyed
the application.


I first thought (wrongly) it had something to do with creating a tunnel for x so I created one from 6000 to 127.0.0.1:6000 without luck

I then tried messing with the allowed hosts so i tried the command:

xhosts +, without sucess!

What am I doing wrong?

Do I need to reconfigure the xserver to listen for remote connections somehow? How can I do that!

Note: Yes I do have x11 forwarding yes in my sshd_config!

Thanks in advance for your time, and pardon me for my incorrect english!

Best regards

A
 
Old 03-14-2006, 06:38 PM   #2
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 48
don't double post
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH/X11 Forwarding - Performance Gort32 Linux - Software 1 01-23-2006 06:04 PM
X11 forwarding over SSH SirSlappy Linux - Networking 1 10-18-2005 01:37 PM
ssh forwarding+remote desktop Metroid Linux - Networking 2 06-23-2004 03:14 PM
Problems with ssh and X11 forwarding Dabria Linux - General 5 02-13-2004 10:28 AM
Port forwarding and remote X11 sessions lfabiani Linux - Networking 6 04-01-2002 06:11 AM


All times are GMT -5. The time now is 06:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration