LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-09-2010, 04:19 AM   #1
yasir453
LQ Newbie
 
Registered: Jan 2010
Posts: 27

Rep: Reputation: 15
Post ssh problem


hi all
me using redhat on server and open suse on clint.when i want to ssh from my server machine the following error occur
"connection refuse"
i execute the following command on clien machine
"/etc/init.d/sshd start"
it shows the following error just after command execution
"sshd re-exec requires execution with an absolute path"

what can be the solution?
 
Old 02-09-2010, 05:11 AM   #2
angel115
Member
 
Registered: Jul 2005
Location: France / Ireland
Distribution: Debian mainly, and Ubuntu
Posts: 528

Rep: Reputation: 78
Hi Yasir

Have you try with the real location of sshd instead the one of init.d?
Ex:/usr/sbin/sshd start
 
Old 02-09-2010, 05:12 AM   #3
sloy
LQ Newbie
 
Registered: Feb 2008
Posts: 1

Rep: Reputation: 0
Did you try:
on this forum: ht*p://3*w.linuxquestions.org /questions/linux-software-2/problems-with-sshd-693893 ?

Code:
/usr/sbin/sshd
should work.

To change entry in actual /etc/init.d/sshd use template and change PROGRAM there:
Code:
cat /etc/init.d/template |sed 's/PROGRAM/\/usr\/sbin\/sshd/g' >/etc/init.d/sshd
As Angel said.

Last edited by sloy; 02-09-2010 at 05:15 AM.
 
Old 02-09-2010, 05:48 AM   #4
sohail0399
Member
 
Registered: Oct 2008
Location: Pakistan, Islamabad
Distribution: CentOS, Fedora, Solaris
Posts: 154

Rep: Reputation: 23
Are they on the same network?


you can also check ssh at locahost

ssh username@localhost
if fine then there may network issue, because servers in most of the cases are on live while client are on local network.
 
Old 02-09-2010, 05:49 AM   #5
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 49
Quote:
Originally Posted by yasir453 View Post
...
"/etc/init.d/sshd start"
it shows the following error just after command execution
"sshd re-exec requires execution with an absolute path"
...
ssh is already running.

Try
Code:
/etc/init.d/sshd restart
Also, see that no firewall is blocking traffic on port 22
 
Old 02-09-2010, 05:52 AM   #6
janhe
Member
 
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 49
OT

Quote:
Originally Posted by sloy View Post
..
on this forum: ht*p://3*w.linuxquestions.org /questions/linux-software-2/problems-with-sshd-693893 ?
...
Please don't mangle the links. Links are more helpful if they are clickable. (IMHO)
 
Old 02-09-2010, 06:04 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
For suse, run "sudo /usr/sbin/rcsshd start" to start the sshd server. Most services have an rc script you use to start or stop a service manually. You can use the YaST2 services module to start it as well. You can also use chkconfig.
For one-off starting an stopping, use rcsshd. To have it start automatically use YaST2 or chkconfig.

You will need to configure your /etc/ssh/sshd_config file, enable ssh (port 22) in the firewall, check the permissions of /home/, /home/username/, /home/username/.ssh/ and your private key.

Be sure you run "ssh-keygen" to generate a pair of keys if you haven't already. This will create your ~/.ssh directory and a pair of keys.

OpenSuSE uses the "users" group by default to allow users to share directories via samba. You may need to remove read access to your home directory's "users" default group so sshd doesn't balk at permissions.
I can't test this because the first thing I do is create a group for myself and change my default group.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chroot SSH problem: ssh working, not SFTP & SCP. NaCo Linux - Security 3 02-01-2009 03:23 AM
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 03:50 AM
SSH problem - ssh-add not respond FerkoPica Linux - Security 6 05-07-2006 04:47 PM
ssh problem after creating an ssh alias. porotothorpe Linux - General 2 01-25-2006 08:56 PM


All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration