LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2013, 09:05 PM   #1
Benygh
LQ Newbie
 
Registered: Jan 2012
Posts: 5

Rep: Reputation: Disabled
SSH Over Port 443 | Doesn't Work !


Hi,
I'm new to this forum and i hope I'm posting this in the right section.

I have a Linux VPS with CentOS installed.

I'm trying to follow this tutorial and i will need to change SSH Port from 22 to 443.

http://www.thewestbrooks.com/downloa...P_thru_SSH.pdf

I changed Port section of /sshd_config file to 443 and added the rule below to iptables and restarted both of these services.

-A INPUT -p tcp -m tcp --dport 443 -j ACCEPT

but the SSH hasn't started on 443 and its still on its default port 22.

I used "netstat -nlp" to get the running ports and as you can see in the results, 443 isn't used for anything.

tcp 0 0 127.0.0.1:199 0.0.0.0:* LISTEN 3189/snmpd
tcp 0 0 0.0.0.0:973 0.0.0.0:* LISTEN 2911/rpc.statd
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 2871/portmap
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 7111/sshd
tcp 0 0 127.0.0.1:5432 0.0.0.0:* LISTEN 3281/postmaster
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 3310/sendmail: acce
tcp 0 0 0.0.0.0:2076 0.0.0.0:* LISTEN 7151/(squid)
udp 0 0 0.0.0.0:39296 0.0.0.0:* 3468/avahi-daemon:
udp 0 0 0.0.0.0:161 0.0.0.0:* 3189/snmpd
udp 0 0 0.0.0.0:3130 0.0.0.0:* 7151/(squid)
udp 0 0 0.0.0.0:967 0.0.0.0:* 2911/rpc.statd
udp 0 0 0.0.0.0:970 0.0.0.0:* 2911/rpc.statd
udp 0 0 0.0.0.0:5353 0.0.0.0:* 3468/avahi-daemon:
udp 0 0 0.0.0.0:111 0.0.0.0:* 2871/portmap
udp 0 0 0.0.0.0:43888 0.0.0.0:*


Can you tell me whats im doing wrong ?

Thank you.

Last edited by Benygh; 03-15-2013 at 09:30 PM.
 
Old 03-16-2013, 01:23 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,430

Rep: Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350
I suggest that you try stopping the sshd service and then starting the sshd service.
Using restart may be preserving the listening process so that an admin can remain logged in.

Last edited by allend; 03-16-2013 at 11:59 AM.
 
Old 03-16-2013, 02:23 AM   #3
p2006.prashant
LQ Newbie
 
Registered: Dec 2007
Location: India
Distribution: Redhat Linux 5,6.2, Solaris
Posts: 16
Blog Entries: 1

Rep: Reputation: 5
restart ssh and iptables service both to take effect new settings.
 
Old 03-16-2013, 10:04 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,933

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by p2006.prashant View Post
restart ssh and iptables service both to take effect new settings.
Please stop just reposting what others have said. allend already gave this advice. Also, the OP clearly posted that SSH is still on port 22, so restarting IPtables will have no effect on its performance on port 443.
 
Old 03-16-2013, 12:01 PM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,430

Rep: Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350Reputation: 1350
The OP wrote in the initial post
Quote:
and restarted both of these services
and so is aware of the need to
Quote:
restart ssh and iptables service both to take effect new settings.
 
Old 03-16-2013, 02:41 PM   #6
Benygh
LQ Newbie
 
Registered: Jan 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
stopping and starting it again sealed the Deal !
Thank YOU
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot use ssh with port 443 as proxy bogwato Linux - Networking 2 07-15-2009 05:20 PM
SSH on port 443? nsusa Linux - Newbie 1 11-08-2005 09:53 PM
SSH on port 443 Randvegeta Linux - Networking 4 09-25-2005 07:17 AM
ssh over port 443 pupton Linux - Software 18 10-08-2004 08:15 AM
FAVICON with apache server at port 443 doesn't seem 2 work ganninu Linux - General 0 12-21-2003 04:58 AM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration