LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-11-2004, 01:15 PM   #1
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
ssh keys


I used to program on the server at my school because there is much of software installed on it.
But yesterday, when I connected using ssh there was this message from the system administrator (translated from dutch):

"The new version of the server uses openssh as daemon. You have to make new ssh keys or at least convert the old ones."

I can still connect, but when I try to scp I get:

scp: warning: Executing scp1.
scp: FATAL: Executing ssh1 in compatibility mode failed (Check that scp1 is in your PATH).

Does this has something to do with the change on the server?
 
Old 10-11-2004, 01:26 PM   #2
magicsmoke
LQ Newbie
 
Registered: Oct 2004
Location: Reno, NV
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
They are probably blocking/disallowing ssh1 requests (which is a _good_ thing). Make sure that you have ssh configured to use ssh2 exclusively via the following:

`grep Protocol /etc/ssh/ssh_config`

If this search returns a line different from 'Protocol 2', edit that line in /etc/ssh/ssh_config to reflect this setting. All should be well after that. (You may also want to remove/recreate your key files, but that's not usually necessary).
 
Old 10-11-2004, 05:25 PM   #3
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
It says:

# Protocol 2,1
 
Old 10-11-2004, 06:35 PM   #4
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
Found the solution.
 
Old 10-12-2004, 01:12 AM   #5
magicsmoke
LQ Newbie
 
Registered: Oct 2004
Location: Reno, NV
Distribution: Slackware
Posts: 15

Rep: Reputation: 0
Glad to hear it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh keys exodist Linux - Networking 3 02-16-2005 11:16 AM
SSH keys alon005 Linux - Security 5 10-14-2004 04:39 AM
ssh keys Lucasite Linux - Security 2 03-11-2004 01:43 PM
Configuring SSH to accept only keys (already have keys) fr0st Linux - Security 3 11-04-2003 04:31 AM
SSh Keys shaggz Linux - General 2 02-19-2003 10:09 PM


All times are GMT -5. The time now is 09:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration