LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2012, 07:59 AM   #1
karthikeyankk
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Rep: Reputation: Disabled
Ssh Connection in Suse Linux


Hi Guys,

I am new to Linux,
In Suse Linux , I am unable to SSH, I tried sshroot@10.0.0.1, I get an error in my console as below.Please give me the step by step procedure to fix the problem.

I get an error in my console as

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
3b:97:34:33:2b:31:b5:e7:cd:5e:8c:a4:43:2d:29:b7.
Please contact your system administrator.
Add correct host key in /home/db/.ssh/known_hosts to get rid of this message.
Offending key in /home/db/.ssh/known_hosts:17
RSA host key for 10.0.0.1 has changed and you have requested strict checking.
Host key verification failed.

Last edited by karthikeyankk; 10-13-2012 at 08:23 AM.
 
Old 10-13-2012, 08:18 AM   #2
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 12.04/14.04, Scientific Linux 6.3/6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,791

Rep: Reputation: 157Reputation: 157
Are root logins to ssh enabled on the machine??

Check the sshd config... (don't post the whole thing here, as it would ID the port assigned to ssh logins).

You probably DON'T want to ssh as root, but ssh as a regular user and get root by su'ing or (better yet) using sudo. Getting root logins on a server is poor security procedure. You should also consider changing the port from the default 22 to something in the 50000+ range, if you haven't already. Doing that won't make you immune to attack, but it should help keep out the common script kiddies and the bots they use.

By the way, ... The above message indicates that the keys don't match,... and it tells you what to look at...

Last edited by JaseP; 10-13-2012 at 08:21 AM.
 
Old 10-13-2012, 08:25 AM   #3
karthikeyankk
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hi Buddy,
I cant able to ssh in any of the user,
What Can I do??
 
Old 10-13-2012, 08:36 AM   #4
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 12.04/14.04, Scientific Linux 6.3/6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,791

Rep: Reputation: 157Reputation: 157
Follow up;


I'm not a SuSE user,... Not since about 2004, anyway... but found this helpful guide;
http://en.opensuse.org/SDB:Configure_openSSH

Check that out...
 
Old 10-13-2012, 09:59 AM   #5
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
As I can see the output, login using simple password will not possible on this machine, but will be possible using "passphrase"
For that you'll need to generate your ssh keys using:
# ssh-keygen -t rsa
This will generate two files id_rsa.pub and id_rsa.
Now, this needs to be copied to the authorized_keys file on server you're accessing.
Copy the file to the remote server server_rsa.pub and then append the contents to authorized_keys as follows. This will allow the existing authroized_keys from being wiped off.
# scp id_rsa.pub serverB:~/.ssh/serverA_rsa.pub
# cat serverA_rsa.pub >> authorized_keys

Further, first read the following document: http://en.wikipedia.org/wiki/Ssh-keygen
 
Old 10-13-2012, 10:11 AM   #6
torchnw
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu, Debian, Mint, Fedora, Arch
Posts: 23

Rep: Reputation: 4
It means that you've either connected to another computer with the same IP address before, the remote computer has been reinstalled, or for some other reason, the public key of the remote computer has changed.

Just edit ~/.ssh/known_hosts with a text editor of your choice and remove the line starting with '10.0.0.1'

When you try to ssh afterwards, you should get a prompt to accept the new public key.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh: connection to host port: 22: Connection timed out lost connection cucolin@ Linux - Server 4 11-22-2011 07:15 AM
restart linux from SSH connection? deWin Linux - Newbie 6 09-28-2004 11:22 PM
SSH connection refused using linux box 90coders Linux - Security 3 10-18-2003 03:53 AM
SSH connection Windows to Linux time112852 Linux - Networking 11 09-19-2003 03:11 AM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration