LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-12-2004, 01:23 AM   #1
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Rep: Reputation: 30
ssh change port


hello

how do i change the port that ssh uses?

i have changed the port number in the ssh_config and sshd_config
but i still does not work.
 
Old 05-12-2004, 02:04 AM   #2
ner
Member
 
Registered: Oct 2003
Posts: 40

Rep: Reputation: 15
I am not sure, but did you restart the ssh, usually changes do not take place, until you send the HUP signal to the proccess and make it reread its config files, or until you stop it and restart it again.
 
Old 05-12-2004, 02:49 AM   #3
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
hrmm

how would i restart it?

i typed in:

sshd restart

and it gives me:

Extra argument restart.
 
Old 05-12-2004, 07:25 AM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,958

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Try:
service sshd restart
 
Old 05-12-2004, 09:56 AM   #5
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
when i do service sshd restart it says:

-bash: service: command not found
 
Old 05-12-2004, 09:59 AM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
redhat:
Code:
/sbin/service sshd restart
slackware:
Code:
/etc/rc.d/rc.sshd stop && /etc/rc.d/rc.sshd start
 
Old 05-12-2004, 10:03 AM   #7
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
oh it worked

but now i get some kind of an error:

cipher_encrypt: bad plaintext length 337

is that something i should worry about?

Last edited by Longinus; 05-18-2004 at 01:40 PM.
 
Old 05-12-2004, 08:45 PM   #8
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
hrmmm i still cant get ssh working

any ideas on what

cipher_encrypt: bad plaintext length 337

means?
 
Old 05-16-2004, 10:31 PM   #9
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
anyone? anyone? anyone?

(echos) lol
 
Old 05-17-2004, 03:33 AM   #10
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
At the console type "cat -A /etc/ssh/sshd_config". If you see ^M (aka Control M) or a lot of space then it has $. I could be that the ssh does not like like lines. You have to edit it. I suggest using vi but you can use any text editor. vi is the standard text editor for LINUX because it does not take up much room and it consumes less memory.
 
Old 05-18-2004, 10:29 AM   #11
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Original Poster
Rep: Reputation: 30
i couldnt find a ^M or alot of spaces before a $

but here is what cat says:

#^I$OpenBSD: sshd_config,v 1.65 2003/08/28 12:54:34 markus Exp $$
$
# This is the sshd server system-wide configuration file. See$
# sshd_config(5) for more information.$
$
# This sshd was compiled with PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin$
$
# The strategy used for options in the default sshd_config shipped with$
# OpenSSH is to specify options with their default value where$
# possible, but leave them commented. Uncommented options change a$
# default value.$
$
Port 4444$
#Protocol 2,1$
#ListenAddress 0.0.0.0$
#ListenAddress ::$
$
# HostKey for protocol version 1$
#HostKey /etc/ssh/ssh_host_key$
# HostKeys for protocol version 2$
#HostKey /etc/ssh/ssh_host_rsa_key$
#HostKey /etc/ssh/ssh_host_dsa_key$
$
# Lifetime and size of ephemeral version 1 server key$
#KeyRegenerationInterval 1h$
#ServerKeyBits 768$
$
# Logging$
#obsoletes QuietMode and FascistLogging$
#SyslogFacility AUTH$
#LogLevel INFO$
$
# Authentication:$
$
#LoginGraceTime 2m$
#PermitRootLogin yes$
#StrictModes yes$
$
#RSAAuthentication yes$
#PubkeyAuthentication yes$
#AuthorizedKeysFile^I.ssh/authorized_keys$
$
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts$
#RhostsRSAAuthentication no$
# similar for protocol version 2$
#HostbasedAuthentication no$
# Change to yes if you don't trust ~/.ssh/known_hosts for$
# RhostsRSAAuthentication and HostbasedAuthentication$
#IgnoreUserKnownHosts no$
# Don't read the user's ~/.rhosts and ~/.shosts files$
#IgnoreRhosts yes$
$
# To disable tunneled clear text passwords, change to no here!$
#PasswordAuthentication yes$
#PermitEmptyPasswords no$
$
# Change to no to disable s/key passwords$
#ChallengeResponseAuthentication yes$
$
# Kerberos options$
#KerberosAuthentication no$
#KerberosOrLocalPasswd yes$
#KerberosTicketCleanup yes$
$
# GSSAPI options$
#GSSAPIAuthentication no$
#GSSAPICleanupCreds yes$
$
# Set this to 'yes' to enable PAM authentication (via challenge-response)$
# and session processing. Depending on your PAM configuration, this may$
# bypass the setting of 'PasswordAuthentication'$
#UsePAM yes$
$
#AllowTcpForwarding yes$
#GatewayPorts no$
#X11Forwarding no$
#X11DisplayOffset 10$
#X11UseLocalhost yes$
#PrintMotd yes$
#PrintLastLog yes$
#KeepAlive yes$
#UseLogin no$
#UsePrivilegeSeparation yes$
#PermitUserEnvironment no$
#Compression yes$
#ClientAliveInterval 0$
#ClientAliveCountMax 3$
#UseDNS yes$
#PidFile /var/run/sshd.pid$
#MaxStartups 10$
$
# no default banner path$
#Banner /some/path$
$
# override default of no subsystems$
Subsystem^Isftp^I/usr/libexec/sftp-server$

Last edited by Longinus; 05-19-2004 at 12:46 AM.
 
Old 12-16-2006, 04:05 PM   #12
LOLobo
Member
 
Registered: Dec 2004
Location: Los Angeles
Distribution: Slackware 10.0 & 11.0
Posts: 31

Rep: Reputation: 16
HELP!!!

I was having this problem
http://www.linuxquestions.org/questi...d.php?t=510959

and now have the issue referenced in this thread!!!

This thread is very old, but I'm going to
 
Old 12-16-2006, 04:20 PM   #13
LOLobo
Member
 
Registered: Dec 2004
Location: Los Angeles
Distribution: Slackware 10.0 & 11.0
Posts: 31

Rep: Reputation: 16
Solved the Issue.... FINALLY!!!!

Got the solution from http://www.linuxforums.org/forum/sus...nfig-file.html

Quote:
> It looks like it is having trouble reading the ssh_host_key files. Try
> moving all the /etc/ssh/ssh_host* files out of the way and let the server
> recreate them.
>
> Note that this will cause your clients to tell you that the host's key has
> changed.


hey,

I deleted all the ssh_host* files under /etc/ssh. Now the sshd service
is running fine.

Thanks for your efforts and guidance.

Thanks & Regards

Ankush Grover
 
Old 12-16-2006, 04:24 PM   #14
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Check if your server's keys are OK. If not, re-create them.
 
Old 12-16-2006, 04:34 PM   #15
LOLobo
Member
 
Registered: Dec 2004
Location: Los Angeles
Distribution: Slackware 10.0 & 11.0
Posts: 31

Rep: Reputation: 16
Thank you. All is now well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change SSH to diffrent port kamtono Linux - Security 5 08-13-2009 07:55 PM
Change ssh port number israel Linux - Software 2 08-30-2006 06:18 AM
can i change the host's ssh port? guardianx Linux - Software 7 07-11-2005 02:47 PM
Change SSH Port? flamesrock Linux - Software 6 10-02-2004 08:12 PM
Able to change port number between telnet and ssh? x5452 Linux - General 3 03-28-2004 06:04 PM


All times are GMT -5. The time now is 03:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration