LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-03-2009, 11:14 AM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 617

Rep: Reputation: 33
SSH authentication methods


I want to login to my server through ssh and with a public/private key pair and only this way.

But when executing the ssh-command with some verbosity, I see this :
Code:
debug1: Authentications that can continue: publickey,keyboard-interactive
This is my sshd_config (authentication part) :
Code:
PubkeyAuthentication yes
GSSAPIAuthentication no
GSSAPICleanupCredentials yes
UsePAM yes
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES 
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT 
AcceptEnv LC_IDENTIFICATION LC_ALL
Where could this "keyboard-interactive" be coming from ?!
 
Old 10-03-2009, 12:48 PM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Instead of relying on sshd's default behavior (which often varies from OS to OS and from distro to distro), I would recommend that you explicitly disable all unwanted authentication forms found in the sshd_config(5) manpages.

In your case, you should at least add:
Code:
PasswordAuthentication no
ChallengeResponseAuthentication no

Last edited by anomie; 10-03-2009 at 12:53 PM. Reason: grammatical correction
 
Old 10-09-2009, 08:50 AM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 617

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by anomie View Post
In your case, you should at least add:
Code:
ChallengeResponseAuthentication no
The above was commented out. It seems by default the value is 'yes'.
By un-commenting the above in sshd_config, I now get :
Code:
debug1: Authentications that can continue: publickey
Thanks for the feedback !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SME Linux SSH "No supported authentication methods available" tryangle Linux - General 7 06-29-2009 07:18 AM
No further authentication methods available rogee Debian 9 03-15-2009 01:12 PM
ssh - No supported authentication methods rajah9 Linux - Networking 4 08-19-2005 01:59 PM
Samba Authentication Methods garullon245136 Linux - Newbie 2 08-07-2005 01:20 PM
Samba Authentication Methods garullon245136 Linux - Networking 2 07-12-2005 06:31 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration