LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-18-2014, 05:29 PM   #1
jcope
LQ Newbie
 
Registered: Apr 2014
Posts: 2

Rep: Reputation: Disabled
ssh-add doesn't resolve "Agent admitted failure to sign using the key."


I'm setting up some VMs on my laptop and I want to establish passwordless ssh from local machine to VM. The process I followed was:

- ssh-keygen (all default values)
- ssh-copy-id root@VM -- confirmed key existed in node:~/.ssh/authorized_keys
- ssh root@VM
returns:
Agent admitted failure to sign using the key.
root@VM's password:

So I tried `ssh-add`, it asks for passphrase; there is none. Hit enter and it returns to prompt. ssh root@VM again just repeats the same "Agent admitted..."

Digging around the web, ssh-add has been the solution for everyone with this problem except for me. What can I do next?

Here is verbose output of ssh root@node:

[jcope@jcope ~]$ ssh root@VM -v
OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to VM [172.16.108.128] port 22.
debug1: Connection established.
debug1: identity file /home/jcope/.ssh/identity type -1
debug1: identity file /home/jcope/.ssh/identity-cert type -1
debug1: identity file /home/jcope/.ssh/id_rsa type 1
debug1: identity file /home/jcope/.ssh/id_rsa-cert type -1
debug1: identity file /home/jcope/.ssh/id_dsa type -1
debug1: identity file /home/jcope/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'VM' is known and matches the RSA host key.
debug1: Found key in /home/jcope/.ssh/known_hosts:21
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure. Minor code may provide more information
Invalid argument

debug1: Unspecified GSS failure. Minor code may provide more information
Invalid argument

debug1: Unspecified GSS failure. Minor code may provide more information


debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Offering public key: /home/jcope/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 277
Agent admitted failure to sign using the key.
debug1: Trying private key: /home/jcope/.ssh/identity
debug1: Trying private key: /home/jcope/.ssh/id_dsa
debug1: Next authentication method: password
root@VM's password:
 
Old 06-21-2014, 03:01 AM   #2
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,307
Blog Entries: 2

Rep: Reputation: Disabled
The client has to have used ssh-add to register the key with the ssh-agent

Quote:
ssh-add adds RSA or DSA identities to the authentication agent, ssh-agent(1). When run without arguments, it adds the files ~/.ssh/id_rsa, ~/.ssh/id_dsa and ~/.ssh/identity. Alternative file names can be given on the command line
 
  


Reply

Tags
agent, ssh, ssh-copy-id remove, ssh-keygen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh inside ssh asks for "Enter passphrase for key..." hedpe Linux - Newbie 1 04-30-2012 10:20 AM
[SOLVED] ssh error: agent admitted to failure to sign using the key austinium Linux - Security 7 02-15-2011 12:23 AM
how to resolve "Public key for cacti-0.8.7b-2.el4.rf.noarch.rpm is not installed" creviceru Linux - Newbie 1 06-13-2009 02:13 AM
"Set Encode" (8B2A) error while trying to add WEP key dahouse Linux - Wireless Networking 20 04-30-2007 12:41 PM
"Error failure to add user" Brianfast Linux - Newbie 2 10-22-2006 09:34 PM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration