LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2004, 11:52 AM   #1
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Rep: Reputation: 15
ssh


Ok,

First I would like to say thanks for all the help.....Here is the question

1. I have 2 Pc's connected through a router. one is a RedHat box the other XP. Both can communicate with the web fine.

2. The ip on the Red Hat box is 192.168.1.114 (I think)
3. I can ping the RedHat box from my Windows box
4. SSH from my Windows box to REDHAT box and it times out

However, at the command line inside RedHat I can ssh to myself

The question is I CANNOT get Telnet from my XP box to REDHAT box using ssh. In the RedHat box I went to server configuration and made sure sshd is running. Is there a way to determine if sshd daemon is running and if it is not how to I start that process?

I did a ps -ef and I do not remember seeing sshd or anything like that. I did not check to validate the port number though

Oh ya, what is the defallut port to connect at is it 22. I think on my router setting I allow connections on ports 20-24 on ip address 192.168.1.114

Thanks,
any other suggetions would be great!!
 
Old 07-30-2004, 12:29 PM   #2
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
this will show you if sshd is running:

ps aux | grep sshd
 
Old 07-30-2004, 01:34 PM   #3
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,276

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Make sure you don't have a firewall running on the Red Hat box that's blocking access to port 22.
 
Old 07-30-2004, 03:34 PM   #4
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Thanks, I did not know Red Hat has a firewall on it...How do I allow port forwarding for port 22 on the RedHat box?

Is it a configureation file that I have to manually edit?
 
Old 07-30-2004, 03:42 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,276

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
In Fedora at least you can change it with system-config-securitylevel -- in RH I think it may be redhat-config-firewall but I'm not sure. The way to do it by hand is to modify your iptables ruleset, but if you aren't familiar with it, it can be sort of difficult. I don't even know that your firewall is the problem, but it's something to look at.
 
Old 07-30-2004, 07:34 PM   #6
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Correct...On Redhat

This was the problem

1. goto system settings-->security level--->check ssh

thanks
 
Old 07-30-2004, 11:42 PM   #7
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Whoa Whoa Whoa

At first I interpreted your post to be a typo. Are you trying to telnet into ssh? Be sure about this, because it won't happen. In order to ssh into your redhat machine, you need an ssh client on windows. I personally use cygwin with all it's little goodies, but if you want help on that. You'll need to ask again. For now, I'll just point you to a great free program for M$ PuTTY

Download this, and now you'll be able to "ssh into your machine"
 
Old 07-31-2004, 05:32 AM   #8
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Yes, I can telnet into my machine. but I cannot ftp to it for some reason. I know sshd has an sftp attached to it, but I cannot seem to get it to work


Thanks
 
Old 07-31-2004, 12:54 PM   #9
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Okay, let's be clear here.
I telnet'd into the machine means you typed "telnet machine"
I ssh'd into the machine means you typed "ssh machin"
ftp is insecure, because people can view everything you're typing. Almost nobody in this forum will recommend using telnet.

With that said, check out this link to another post
 
Old 08-01-2004, 02:28 PM   #10
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
what is happenning is this. I am logging in from a XP machine to a UNIX machine using open ssh on my XP box.

1. I can ssh into the UNIX box fine. However, when I open up a transfer window using open ssh I get this error

"File transfer could not be started or exited unexpectedly. sftp-server is not in the path on the server side"

Now the file sftp-server is on my machine in the proper location.

I have been trying to get this to work for a few days now!!!

Thanks
 
Old 08-01-2004, 02:44 PM   #11
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Hmm, I'm still unclear on whether you are doing this properly.

When you open up this ftp window, what do you mean?

>sftp <unixserver
$<password
$get filename
$quit
>ls (to see filename in current directory)

Is this what you're doing?
 
Old 08-01-2004, 03:29 PM   #12
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
No I open up a file transfer window on my XP box using the program open ssh. It is a menu item options that just allows you to tranfer files using ssh by dragging and dropping files.

What is does is one window will display the contents of the unix box and the other window will display the contents of my XP box. The window will allow drap and drop of files.

I am thinking of just running another ftp serever and not using sftp
 
Old 08-01-2004, 03:33 PM   #13
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Before I open up an insecure ftp server, I would try another sftp client. Try PuTTY . It's great, open source and free (as in beer). Never quite understood that one?!! Try using this first, and let me know if it works.
 
Old 08-01-2004, 03:53 PM   #14
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
I CAN conenct to my Linux box from my xp box using putty. I wanted to be able to transfer files back and forth from my XP box and redhat box. I know that sshp come w/ an ftp server which is what I have on my Linux box.

However, psftp DOES NOT work it will just sit there never allowing me to log in.
 
Old 08-01-2004, 04:08 PM   #15
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
actually, when I use psftp which is the secure ftp it prompts me to log in, but it hangs up after I enter the password!!

Example using psftp (putty version of ftp)

open 192.168.XXX.XXX
login as <user_name>
Using username<user_name>
<user_name>@192.168.XXX.XXX's password:

THIS IS where it hangs up, seems like it CANNOT authenticate my password!!

Thanks again fr the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 03:50 AM
[SSH] Issue logging in [SSH & Permissions] MD3 Linux - Networking 11 12-10-2006 10:25 AM
Mac OS X ssh client / linux sshd : ssh hangs/disconnects Apollo77 Linux - Networking 1 05-24-2006 12:53 PM
I turned off SSH, but I cant get it back! How do you start SSH on boot? nmoog Slackware 2 02-08-2004 06:18 PM
ssh issue: /usr/bin/ssh -x -oFallBackToRsh no -l WeNdeL Linux - Software 1 03-04-2003 08:17 PM


All times are GMT -5. The time now is 08:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration