LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2011, 12:41 AM   #1
BuisSse
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Rep: Reputation: Disabled
Squid Refusing Connections for HTTPS websites


Greetings Everyone,

I have setup Squid3+ HAVP + SquidGuard. I have set them up in such a way that Squid3 has 2 listening ports. I used the following tutorial :
http://www.server-side.de/download/p...ple-squid.conf

However when I browse to https websites, the proxy gives me a page stating Proxy Server is refusing Connections.

Thanks for the help.
 
Old 12-21-2011, 11:16 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,331

Rep: Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881Reputation: 3881
Quote:
Originally Posted by BuisSse View Post
Greetings Everyone,
I have setup Squid3+ HAVP + SquidGuard. I have set them up in such a way that Squid3 has 2 listening ports. I used the following tutorial :
http://www.server-side.de/download/p...ple-squid.conf

However when I browse to https websites, the proxy gives me a page stating Proxy Server is refusing Connections.
Thanks for the help.
Did you compile squid with the "--enable-ssl" flag, as in the Squid documentation?
http://www.squid-cache.org/Versions/...ttps_port.html
http://www.squid-cache.org/Doc/config/https_port/
http://www.comfsm.fm/computing/squid/FAQ-1.html

And it's even been covered on this site and solved:
http://www.linuxquestions.org/questi...th-ssl-913585/
 
Old 12-22-2011, 05:54 AM   #3
BuisSse
LQ Newbie
 
Registered: Dec 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hey, Thanks for your help. I recompiled squid3 with --enable-ssl, still facing the same issue, although I have not made any changes to my squid.conf file
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Privoxy refusing connections Badfish Linux - Networking 7 05-29-2007 11:29 PM
Refusing connections? linker1981 Linux - Networking 4 07-19-2006 10:16 AM
Squid problem with https connections thermoponch Linux - Networking 0 11-03-2004 05:41 AM
keep refusing connections tpark Linux - Networking 1 03-04-2004 03:24 AM
Refusing Connections goldfish Linux - Newbie 16 10-09-2003 07:13 PM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration