LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-18-2013, 02:32 AM   #1
sunveer
Member
 
Registered: Jul 2012
Posts: 139

Rep: Reputation: Disabled
Squid Not Working


I have installed squid 3.1 and I am seeing only TCP_Miss in the access.log. Also, do I need to setup nameservers on the client machine along with proxy in order to access internet? Because without doing this I cannot access internet through proxy. I have specified dns_nameservers in squid.conf.

Last edited by sunveer; 10-18-2013 at 03:33 AM.
 
Old 10-18-2013, 10:03 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,916

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Quote:
Originally Posted by sunveer View Post
I have installed squid 3.1 and I am seeing only TCP_Miss in the access.log.
So did you try to look up any solutions? And there are SEVERAL versions of TCP_MISS, each with an error code. Which are you getting? Version/distro of Linux?
Quote:
Also, do I need to setup nameservers on the client machine along with proxy in order to access internet? Because without doing this I cannot access internet through proxy. I have specified dns_nameservers in squid.conf.
If your clients have no way of doing a DNS lookup, how do you think they'll be able to know which network a host is on, to route the traffic correctly?? Since you have an RHCE, that should be an obvious thing.
http://www.linuxquestions.org/questi...al-4175469921/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Squid+DansGuardian not working properly. squid blocking sites that should be linuxlover.chaitanya Linux - Server 13 11-10-2014 11:34 AM
Ubuntu 8.04: Transparent proxy using squid working but block domain not working bleketux Linux - Networking 10 03-16-2009 07:41 AM
Squid 2.6 Reverse Proxy from Squid(3128) to OrginServer(80) Not working rraj Linux - Server 0 06-06-2008 03:29 PM
squid is not working pmember01 Linux - Newbie 7 01-18-2008 12:34 AM
I can't "service squid start" , and chkconfig squid on not working Niceman2005 Linux - Software 0 11-10-2004 09:18 PM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration