LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-18-2002, 11:16 AM   #1
Mel Holt
LQ Newbie
 
Registered: Nov 2002
Posts: 1

Rep: Reputation: 0
Squid/Mandrake 9.0


I'm having problems with Squid in Mandrake 9.0.
When I '/etc/init.d/squid status' I get the message 'squid dead but subsys locked' and, on the line below, 'squid: ERROR: No running copy.
I stop squid and get the expected 'failed' and then restart it. That seems fine but a couple of seconds later I'm back to the 'subsys locked' thing. The same thing happens if I try 'service squid start'. I can't find a squid.pid file anywhere on the system. Any ideas please?
 
Old 01-23-2003, 10:02 PM   #2
jbinhktech
LQ Newbie
 
Registered: Jan 2003
Distribution: Red Hat 7.1
Posts: 1

Rep: Reputation: 0
Question squid dead but subsys locked - squid: ERROR: No running copy

My Squid proxy server is not working. Was there ever any solution provided for this problem?

# /etc/rc.d/init.d/squid restart
Stopping squid: [FAILED]
Starting squid: [ OK ]
# /etc/rc.d/init.d/squid status
squid dead but subsys locked
squid: ERROR: No running copy

I have tried several things from advice on messageboards and FAQs including:

# /etc/rc.d/init.d/squid stop
# rm /var/lock/subsys/squid
# /etc/rc.d/init.d/squid start

...didn't work.

# ps -A

...did not display squid as a running process.

Help. Anyone... please...
 
Old 03-28-2003, 05:03 AM   #3
gran
LQ Newbie
 
Registered: Mar 2003
Posts: 1

Rep: Reputation: 0
I had this problem, and the error was that my computer name contains invalid character like _*"+, try to change it and reboot your computer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
squid-cache & mandrake/10.1: (22) Invalid argument darkportal_4 Linux - Networking 5 07-03-2005 12:04 PM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 03:29 PM
squid module in mandrake 10.1 control center tr3s Mandriva 1 11-20-2004 01:30 AM
Squid load testing software / Squid optimisation? gundelgauk Linux - Networking 2 08-31-2004 08:36 PM
Problem running Squid on Mandrake 9.1 win32sux Mandriva 2 12-30-2003 06:24 PM


All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration