LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2004, 09:08 AM   #1
bugsbunny
Member
 
Registered: Jan 2003
Location: London/UK
Distribution: Slackware 9.1
Posts: 111

Rep: Reputation: 15
Speedtouch modem stopped workinh after reboot


I've got slack 9.1 and a speedtouch 330 (silver) modem. Following numerous tutorials i was able to get it working (for about 3hrs). Then I rebooted the pc. When I got back into linux, and tried to connect (either as root or myself) it doesn't work!

Also I know that by default only root is given the right to the CD drive. I have created a user and i want to use the CD drive but I don't have the permission. I know I have to belong to a group with that right to be able to use it. How do i go about creating such a group?

Thanks
 
Old 04-04-2004, 04:22 PM   #2
bugsbunny
Member
 
Registered: Jan 2003
Location: London/UK
Distribution: Slackware 9.1
Posts: 111

Original Poster
Rep: Reputation: 15
I unistalled an reinstalled the modem again (that is what i am using to post this message).Below are the messages i got during the install:

Software Installation success
/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: init_modules: no such device
/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: Hint: insmod errors can be caused by incorrect module parameters: including invalid IO or IRQ parameters
You may find more information in syslog or the output of dmesg

/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: insmod /lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz failed
/lib/modules/2.4.22/kernel/drivers/usb/host/usb-uhci.o.gz: insmod usb-uhci failed

cp: cannot create regular file '/etc/init.d/speedtouch': no such file in directory

After these messages the modem goes to connect and work!

here is the messages log:

Apr 4 20:31:36 naah -- MARK --
Apr 4 20:40:07 naah kernel: CSLIP: code copyright 1989 Regents of the University of California
Apr 4 20:40:07 naah kernel: PPP generic driver version 2.4.2
Apr 4 20:40:07 naah kernel: N_HDLC line discipline registered.
Apr 4 20:40:07 naah kernel: usb-uhci.c: $Revision: 1.275 $ time 18:40:47 Sep 2 2003
Apr 4 20:40:07 naah kernel: usb-uhci.c: High bandwidth mode enabled
Apr 4 20:40:07 naah kernel: usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
Apr 4 20:40:07 naah modem_run[4377]: modem_run version 1.2 started by root uid 0
Apr 4 20:40:53 naah modem_run[4377]: ADSL synchronization has been obtained
Apr 4 20:40:53 naah modem_run[4377]: ADSL line is up (2272 kbit/s down | 288 kbit/s up)
Apr 4 20:41:03 naah pppd[4387]: pppd 2.4.1 started by root, uid 0
Apr 4 20:41:03 naah pppoa3[4389]: pppoa3 version 1.2 started by root (uid 0)
Apr 4 20:41:03 naah pppoa3[4389]: Control thread ready
Apr 4 20:41:03 naah pppoa3[4391]: host --> pppoa3 --> modem stream ready
Apr 4 20:41:03 naah pppd[4387]: Using interface ppp0
Apr 4 20:41:03 naah pppd[4387]: Connect: ppp0 <--> /dev/pts/2
Apr 4 20:41:03 naah pppoa3[4400]: modem --> pppoa3 --> host stream ready
Apr 4 20:41:07 naah pppd[4387]: local IP address 80.44.208.227
Apr 4 20:41:07 naah pppd[4387]: remote IP address 212.74.111.194
Apr 4 20:41:07 naah pppd[4387]: primary DNS address 80.225.254.178
Apr 4 20:41:07 naah pppd[4387]: secondary DNS address 80.225.254.186
Apr 4 20:51:36 naah -- MARK --


Whats going on! I'll appreciate so help please.

Last edited by bugsbunny; 04-05-2004 at 01:20 PM.
 
Old 04-04-2004, 04:26 PM   #3
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
instead of uninstalling after you reboot you need to insmod the modem module that you are using to get it to work.

thats all.
 
Old 04-04-2004, 04:36 PM   #4
bugsbunny
Member
 
Registered: Jan 2003
Location: London/UK
Distribution: Slackware 9.1
Posts: 111

Original Poster
Rep: Reputation: 15
Thanks but is there no way to use insmod automatically ? and what is the command?

Last edited by bugsbunny; 04-05-2004 at 01:20 PM.
 
Old 04-05-2004, 01:48 PM   #5
bugsbunny
Member
 
Registered: Jan 2003
Location: London/UK
Distribution: Slackware 9.1
Posts: 111

Original Poster
Rep: Reputation: 15
Please heeeelp me somebody.
 
Old 04-07-2004, 02:17 PM   #6
bugsbunny
Member
 
Registered: Jan 2003
Location: London/UK
Distribution: Slackware 9.1
Posts: 111

Original Poster
Rep: Reputation: 15
I still havent managed to get my speed touch modem working on slack 9.1. I thought i should post the result of : pppd call adsl maybe it might help someone to provide the answer. The problem as before is, it connects and works when just after I run speedtouchconf.sh. However after i restart the pc it does not work anymore.

pppd call adsl

sys log:
Apr 7 18:51:46 naah pppoa3[2316]: Error reading usb urb
Apr 7 18:51:46 naah pppoa3[2305]: Woken by a sem_post event -> Exiting
Apr 7 18:51:46 naah kernel: usb-uhci.c: uhci_submit_urb: pipesize for pipe c0038280 is zero
Apr 7 18:51:46 naah pppoa3[2325]: Error reading usb urb
Apr 7 18:51:46 naah pppoa3[2320]: Woken by a sem_post event -> Exiting
Apr 7 18:51:46 naah kernel: usb-uhci.c: uhci_submit_urb: pipesize for pipe c0038280 is zero
Apr 7 18:51:46 naah pppd[2304]: ioctl(PPPIOCGFLAGS): Inappropriate ioctl for device



messages:
Apr 7 18:51:46 naah pppd[2304]: pppd 2.4.1 started by root, uid 0
Apr 7 18:51:46 naah pppoa3[2305]: pppoa3 version 1.2 started by root (uid 0)
Apr 7 18:51:46 naah pppd[2304]: Using interface ppp0
Apr 7 18:51:46 naah pppd[2304]: Connect: ppp0 <--> /dev/pts/2
Apr 7 18:51:46 naah pppoa3[2305]: Control thread ready
Apr 7 18:51:46 naah pppoa3[2315]: host --> pppoa3 --> modem stream ready
Apr 7 18:51:46 naah pppoa3[2316]: modem --> pppoa3 --> host stream ready
Apr 7 18:51:46 naah pppoa3[2305]: Read from usb Canceled
Apr 7 18:51:46 naah pppoa3[2305]: Write to usb Canceled
Apr 7 18:51:46 naah pppoa3[2305]: Exiting
Apr 7 18:51:46 naah pppd[2304]: Modem hangup
Apr 7 18:51:46 naah pppd[2304]: Connection terminated.
Apr 7 18:51:46 naah pppoa3[2320]: pppoa3 version 1.2 started by root (uid 0)
Apr 7 18:51:46 naah pppoa3[2320]: Control thread ready
Apr 7 18:51:46 naah pppoa3[2324]: host --> pppoa3 --> modem stream ready
Apr 7 18:51:46 naah pppoa3[2325]: modem --> pppoa3 --> host stream ready
Apr 7 18:51:46 naah pppoa3[2320]: Read from usb Canceled
Apr 7 18:51:46 naah pppoa3[2320]: Write to usb Canceled
Apr 7 18:51:46 naah pppoa3[2320]: Exiting
Apr 7 18:51:46 naah pppd[2304]: Exit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Iomega REV drive stopped working after reboot pwtct Linux - Hardware 1 05-02-2007 11:40 AM
2.6.10 upgrade - speedtouch 330 adsl - reboot - usbdevfs not supported by kernel lets-eat-gary Fedora 2 01-25-2005 11:17 AM
Azureus stopped working after reboot pragun Linux - Software 3 01-18-2005 06:57 PM
Speedtouch 330 works until reboot adam-red Linux - Hardware 1 11-28-2004 12:46 PM
Sound on A7V880 stopped working after reboot of FC3 Coda Fedora 4 11-17-2004 06:47 PM


All times are GMT -5. The time now is 02:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration