LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-21-2004, 01:13 PM   #1
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Rep: Reputation: 0
speedtouch connection problems with mdk 10


ill start off with saying that i have read almost all the posts here concerning speedtouch usb adsl problems

i am running mdk 10 on sony vaio pcg-z505s

the speedtouch installation was uneventfull , i had the mgmt.o on a floppy .

but when it comes time to connect the two green lights which are on , shut off then 1 of them blinks for like 30 sec

i then get the error connot connect to internet recheck settings (some thing like that)\

any help please iv been scanning this site for almost two days havent found a working solution

thanks in advance
 
Old 04-21-2004, 01:45 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Try the speedtouchconf package http://speedtouchconf.sourceforge.net/ Download the speedtouchconf-20-03-2004.tar.gz into your home folder. As it stands it won't work with a 2.6 kernel but the sed in these commands make a small alteration to it which should make it work.

tar xzf speedtouchconf-20-03-2004.tar.gz

# then you'll need to copy the mgmt.o into the speedtouchconf-20-03-2004 folder and then carry on with these commands.

cd speedtouchconf-20-03-2004
tar xzf speedtouch-1.2-sgp.tar.gz
cp speedtouch-1.2-sgp/src/pppoa3.c{,.backup}
sed 's/ep = -1;/ep = 1;/g' speedtouch-1.2-sgp/src/pppoa3.c.backup > speedtouch-1.2-sgp/src/pppoa3.c
tar czf speedtouch-1.2-sgp.tar.gz speedtouch-1.2-sgp

#Now you'll need to become root

su
password
./speedtouchconf.sh

If it doesn't work, fix what it wants then try again from the last command ./speedtouchconf.sh . It may complain that you need to install bc-1.06, usbutils, pciutils and it doesn't like versions of ppp newer than 2.4.1. Install whatever it asks for off the Mandrake CD's through the Mandrake Control Centre. Good luck.
 
Old 04-21-2004, 04:04 PM   #3
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
allright here we go

************************************************
* *
* speedtouchconf.sh by Steve Parker *
* *
* http://speedtouchconf.sourceforge.net/ *
* based on speedtouch.sourceforge.net project *
* *
************************************************

If you have any problems with this script, mail me
(steve at steve-parker dot org) with the files
/tmp/speedtouch.txt and /var/log/messages for diagnosis.
Using speedtouch-1.2-sgp
Error: Cannot find bc.
microcode is mgmt.o
Using mgmt.o for microcode
./speedtouchconf.sh: line 1: bc: command not found
PPP version 2.4.1 okay.
Linux kernel version 2.6.3 okay.
No USB Bus found!
ERROR:
Some required files are not installed:
bc
Please install these (from your Linux install media,
or the internet) before you can configure and install
the speedtouch software.
Please check the PATH environment variable, and that you are running
as root. Your PATH variable is currently:
/bin:/sbin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin
[root@localhost speedtouchconf-20-03-2004]#

what should i do know ?

please excuse my ignorance i am a nuB
 
Old 04-21-2004, 04:49 PM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Well you should be able to install bc if you open the Mandrake Control Centre> Software Management> RpmDrake Install Software> All Packages, Alphabetical scroll down to bc-1.(numbers)-mdk. Install that and see if you get any further. That "No USB Bus found!" error looks worrying. Hopefully It'll just need a module installing with modprobe usbcore or modprobe usb-uhci or somesuch. We'll see. Good luck.
 
Old 04-21-2004, 05:11 PM   #5
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
this is what shows up

/tmp/speedtouch.txt and /var/log/messages for diagnosis.
Using speedtouch-1.2-sgp
microcode is mgmt.o
Using mgmt.o for microcode
PPP version 2.4.1 okay.
Linux kernel version 2.6.3 okay.
No USB Bus found!
Not ready to install the software at this time. - code 2
[root@localhost speedtouchconf-20-03-2004]#

btw both lights on adsl r on
 
Old 04-21-2004, 05:41 PM   #6
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Modules aside, do you have a /proc/bus/usb ?

and try

mount none /proc/bus/usb -t usbdevfs
 
Old 04-21-2004, 05:54 PM   #7
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
following what u posted, heres what i got.

[root@localhost user]# mount none /proc/bus/usb -t usbdevfs
mount: none already mounted or /proc/bus/usb busy
mount: according to mtab, none is already mounted on /proc/bus/usb
[root@localhost user]#
 
Old 04-21-2004, 06:08 PM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Not to take anything away from the speedtouch.conf method, it was the first one I used, I go by this howTO (if rather more lengthy)

http://cvs.sourceforge.net/viewcvs.p....html?rev=HEAD

No doubt aswell you've noticed on the boards, if you're using a 2.6 kernel there are other alterations you have to make aswell.

If you're using freeserve vpi should be 0 and vci 38
 
Old 04-22-2004, 06:39 AM   #9
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
I wonder if the probem is with modules. The speedtouchconf.sh script adds some entries to /etc/modules.conf but with 2.6 kernels that file is obsolete, it uses a file called /etc/modprobe.conf. Try opening /etc/modprobe.conf with a tex editor (gedit or kate or suchlike) and copy these lines from modules.conf

alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

and try again with the ./speedtouchconf.sh
I've sent away for a copy of Mandrake 10 so I'll be able to have a crack at this myself in a couple of days and I'll report back. As Looking_Lost says, there is another way to get it to work but it involves modiying the kernel source and then recompiling the kernel, which is not easy to do and it is only a temporary solution as the code you need to alter isn't in the 2.6.6 kernel, so we have to hack the driver. I'll be back.
 
Old 04-22-2004, 07:27 AM   #10
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
o.k. checked them out and this is what i got


modules.conf


probeall scsi_hostadapter usb-storage imm ppa
probeall usb-interface usb-uhci
alias eth0 eepro100
alias sound-slot-0 nm256_audio
alias tty-ldisc-3 ppp_async
alias ppp-compress-26 ppp_deflate
alias tty-ldisc-13 n_hdlc
alias ppp-compress-21 bsd_comp
alias speedtch off
alias ppp-compress-24 ppp_deflate
alias tty-ldisc-14 ppp_synctty
alias char-major-108 ppp_generic


modprobe.conf

alias eth0 eepro100
alias sound-slot-0 nm256_audio
alias tty-ldisc-3 ppp_async
alias ppp-compress-26 ppp_deflate
alias tty-ldisc-13 n_hdlc
alias ppp-compress-21 bsd_comp
alias speedtch off
alias ppp-compress-24 ppp_deflate
alias tty-ldisc-14 ppp_synctty
alias char-major-108-* ppp_generic
install scsi_hostadapter /sbin/modprobe usb-storage; /sbin/modprobe imm; /sbin/modprobe ppa; /bin/true
install usb-interface /sbin/modprobe usb-uhci; /bin/true

looks like im missing alias /dev/ppp ppp_generic

im sure its gota b important ;-)

and.. really thanks guys for helping me out

i just hope ill finally get it working
 
Old 04-24-2004, 06:20 AM   #11
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Hello again. My Mandrake 10 CD's came this morning and I couldn't get the speedtouch working with the Mandrake Control Center (though I only tried once and cb_linus in this thread http://www.linuxquestions.org/questi...ght=speedtouch has got a silver speedtouch working) I tried the speedtouchconf script unaltered and it failed with the error
ppp0: error fetching interface information: Device not found
but when I used the instructions I gave above http://www.linuxquestions.org/questi...384#post891384 it worked first time. Your problem with the USB must be something specific to the way Mandrake is configuring your hardware. Do other USB devices work?
 
Old 04-24-2004, 04:18 PM   #12
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
i have tried two usb devices
- usb mouse
- usb floppy drive
and both work without a problem
 
Old 04-28-2004, 04:44 PM   #13
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
i have also tried today a usb netgear wifi 11Mb it works fine
 
Old 04-30-2004, 07:07 AM   #14
Mr Tickle
Member
 
Registered: Jul 2003
Location: England, Derbyshire
Distribution: Dual boot XP pro & MDK 10 official, KDE.
Posts: 69

Rep: Reputation: 15
This is my exact problem with the usb bus. Have you sorted it out cos I'm still stuck
 
Old 05-01-2004, 07:12 PM   #15
pinzerbib
LQ Newbie
 
Registered: Apr 2004
Posts: 10

Original Poster
Rep: Reputation: 0
no im still stuck im living with using windowz for internet connection :-(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[suse 9.1]speedtouch 330 connection problems Sul Linux - Hardware 13 10-18-2004 04:59 PM
Speedtouch 330 in MDK-10 (kernel 2.4.5 or 2.6.3) error RanDomIze-PT Linux - Newbie 5 06-06-2004 11:23 AM
MDK 10 Official + speedtouch usb = 0 internet. Mr Tickle Mandriva 28 05-28-2004 08:47 PM
SpeedTouch USB Connection Problems... Blake Linux - Hardware 1 05-04-2003 10:30 AM
ADSL Configuration for Speedtouch USB in Mdk 8.1 furrie Linux - Networking 4 02-05-2002 04:12 PM


All times are GMT -5. The time now is 07:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration