LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2004, 06:37 PM   #1
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Rep: Reputation: 15
Speedtouch 330 and Suse 9.1 pro help?


hi everyone, need a bit of help.

Iv installed the tar config file and installed it as instructed on sourceforge website to get my silver Speedtouch 330 adsl modem working but iv encountered problems. The driver has installed successfully and iv entered my isp details using yast but this is the the error im getting when connecting;

SuSE Meta pppd (smpppd-ifcfg), Version 1.16 on linux.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin pppoatm.so loaded.
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: connect(0.38): Resource temporarily unavailable
pppd[0]: Failed to open 0.38: Resource temporarily unavailable
Status is: disconnected
pppd[0] died: Serial port open failed (exit code 7)

I got this from Kppn Log.

Please can someone tell me what the hell does that mean? I would greatly appreciate any help as i am quite new to Linux?

Suse is installed on my laptop.

Thank you,

SoulPioneer
 
Old 08-21-2004, 08:55 PM   #2
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Original Poster
Rep: Reputation: 15
Scrap the above. I got that wrong.

I give up. Stupid fucked up shit. http://speedtouchconf.sourceforge.net/ says the following: For the silver modem, you will need the rev4fw microcode - just put this file into the same directory as the main speedtouchconf.sh script.

I have put rev4fw in the directory of speedtouchconf.sh and i get the following error:

No further user interaction is required.
Configuring SpeedTouch Driver...
Software Configuration - SUCCESS
Building SpeedTouch Driver...
Software Build - SUCCESS
Installing SpeedTouch Driver...
Software Installation - SUCCESS
Creating ppp files in //etc/ppp
FATAL: Module usb_uhci not found.

*** Configuration finished. Starting the connection ***

The modem lights should start flashing for approx. 20 seconds...
The modem_run command failed (code 240)
modem_run results:
Unable to locate firmware
If you have a silver modem, make sure you're using rev4fw.zip
http://speedtouchconf.sourceforge.net/rev4fw.zip
FAILED because of modem_run error 240

What the hell does that mean?!

Absolutely fucking ridiculous. Iv spent the last 4 hours getting a measly modem working and using a method which apparently should work.

In all honesty, using Linux has really made me appreciate Windows XP.

Ridiculous.

SoulPioneer
 
Old 08-22-2004, 06:01 AM   #3
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Did you leave the .zip or extract the mgmt.o file out of it?
 
Old 08-22-2004, 09:57 PM   #4
SoulPioneer
Member
 
Registered: Apr 2004
Distribution: SuSE Linux 9.1 Professional
Posts: 47

Original Poster
Rep: Reputation: 15
Okay okay, iv gotten the script to work partially. I have to run the script everytime i restart the machine! This is just way to long. During every script run i choose to start my connection automatically but it just doesn work. This is an error i recieve during linux startup:

Starting ADSL connection: Mount: mount point/proc/bus/usb does not exist: FAILED

Sourceforge FAQ for speedtouch says that to manually start the connection without entering the script everytime, you must type: '/etc/init.d/speedtouch start' but when i enter this i get the following error:

Starting ADSL connection: FATAL: Module usb_uhci not found

Can someone please tell me what the problem is? Why am i getting this message and why do i have to re-run the script everytime?

Thank you,

SoulPioneer
 
Old 08-23-2004, 07:03 PM   #5
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
FYI details of my success without using the speedtouchsonf script can be found here, and me helping someone else with the same FATAL usb error is here.
 
Old 09-07-2004, 03:45 AM   #6
yobe
LQ Newbie
 
Registered: Sep 2004
Location: Mulhouse, France
Distribution: SuSE 9.1 pro
Posts: 1

Rep: Reputation: 0
Hey

I have been through the exact same things as you are (and I am still).

For some reason, I was trying to figure out what was failing in the /etc/init.d/speedtouch script so i added a couple of echo lines, just to check where exactly it fails. Surprisingly it made it work quite good although it still does not auto-connect at start up.

I did not look any further so far, So I still have a bunch of comments printing while typing /etc/init.d/speedtouch start, but who cares so far ?

I solved the stop problem the same way, and I guess the restart is fixable too.

The script is pretty huge so I don't want to copy paste it in here. I can send it to you if I get your e-mail address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedtouch 330 in SuSE snay Linux - Hardware 4 04-08-2005 02:08 PM
speedtouch 330 and suse 9.1 pro andrewtj Linux - Newbie 2 12-06-2004 04:01 AM
speedtouch 330 on SuSe 9.1 CHiel_l Linux - Software 4 08-14-2004 09:58 AM
Anyone got the Speedtouch 330 working with SuSE 9 Pro? DanteDDK Linux - Distributions 0 04-26-2004 02:38 PM
SUSE 8.2 Pro and Alcatel SpeedTouch 330 USB modem nitr8 Linux - Hardware 9 10-29-2003 03:02 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration