LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-12-2014, 11:50 PM   #1
tuanhqit
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Rep: Reputation: Disabled
Spamassasin - Notification email could not be deliveried.


I am trying to use spamassassin. When i test mail
First time : I sent email with subject : XJS*C4JDBQADN1.NSBN3*2IDNEN*GTUBE-STANDARD-ANTI-UBE-TEST-EMAIL*C.34X
Email receive: **spam**XJS*C4JDBQADN1.NSBN3*2IDNEN*GTUBE-STANDARD-ANTI-UBE-TEST-EMAIL*C.34X --> Ok

this is Notification in Gmail:
Code:
This is the mail system at host mail.domain.vn.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<-o@domain.vn> (expanded from <-o>): bad address syntax

<smtpd_tls_wrappermode=yes@domain.vn> (expanded from
    <smtpd_tls_wrappermode=yes>): unknown user: "smtpd_tls_wrappermode=yes"

<smtpd_sasl_auth_enable=yes@domain.vn> (expanded from
    <smtpd_sasl_auth_enable=yes>): unknown user: "smtpd_sasl_auth_enable=yes"

Final-Recipient: rfc822; -o@domain.vn
Original-Recipient: rfc822; -o
Action: failed
Status: 5.1.3
Diagnostic-Code: X-Postfix; bad address syntax

Final-Recipient: rfc822; smtpd_tls_wrappermode=yes@domain.vn
Original-Recipient: rfc822; smtpd_tls_wrappermode=yes
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "smtpd_tls_wrappermode=yes"

Final-Recipient: rfc822; smtpd_sasl_auth_enable=yes@domain.vn
Original-Recipient: rfc822; smtpd_sasl_auth_enable=yes
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "smtpd_sasl_auth_enable=yes"
Second: I sent email with subject : hello
Email receive: Not **spam**
But still appear notification above.
 
Old 08-14-2014, 11:08 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,586

Rep: Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698
Code:
<smtpd_tls_wrappermode=yes@domain.vn> (expanded from
    <smtpd_tls_wrappermode=yes>): unknown user: "smtpd_tls_wrappermode=yes"
Diagnostic-Code: X-Postfix; bad address syntax
It obviously does not recognise <smtpd_tls_wrappermode=yes> as an email address wherever you are sending it.

When I was doing this, I saved off clean and spam emails, addressed to me. then
Code:
cat clean.txt |spamc
cat dirty.txt |127.0.0.1:25
sent it just through spamassassin, or through the smtp port. That was a handy way to test.
 
Old 08-14-2014, 11:26 PM   #3
tuanhqit
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
Code:
<smtpd_tls_wrappermode=yes@domain.vn> (expanded from
    <smtpd_tls_wrappermode=yes>): unknown user: "smtpd_tls_wrappermode=yes"
Diagnostic-Code: X-Postfix; bad address syntax
It obviously does not recognise <smtpd_tls_wrappermode=yes> as an email address wherever you are sending it.

When I was doing this, I saved off clean and spam emails, addressed to me. then
Code:
cat clean.txt |spamc
cat dirty.txt |127.0.0.1:25
sent it just through spamassassin, or through the smtp port. That was a handy way to test.
Hello kid! Thank you for help.
I have a problem. This is error in maillog.
NOQUEUE: reject: RCPT from unknown[14.161.4.44]: 554 5.7.1 <tuantinhtao2909@yahoo.com>: Relay access denied; from=<tuanhqit@sucsongtre.vn> to=<tuantinhtao2909@yahoo.com> proto=ESMTP helo=<AdminHP>
I can receive email but can't sent email.


vi /etc/postfix/master.cf

smtp inet n - n - - smtpd -o content_filter=spamassassin
spamassassin unix - n n - - pipe user=spamfilter argv=/usr/bin/spamc -f -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}
#submission inet n - n - - smtpd
# -o smtpd_tls_security_level=encrypt
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticated,reject
# -o milter_macro_daemon_name=ORIGINATING
smtps inet n - n - - smtpd
#spamassassin unix - n n - - pipe user=spamfilter argv=/usr/bin/spamc -f -e /usr/sbin/sendmail -oi -f ${sender} ${recipient}
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes

I use port 25, 465 both not work. What something wrong. I am trying configure spamassassin. Sorry my english.
 
Old 08-15-2014, 04:19 AM   #4
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,586

Rep: Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698
I got something like that too.

What was going on was that the first upstream smtp mail relay (in my ISP) didn't like my private domain because it did not recognise it. In that case, the upstream mailer saw my hostname as as customer<number-x>. The solution was to tell postfix to announce itself as the same domain as the upstream relay. You can fiddle that in the postscript configs.

If you're a small operator, proceed as above. If you're a big operator, ignore that and sort out something with your relay.
 
Old 08-15-2014, 05:36 AM   #5
tuanhqit
LQ Newbie
 
Registered: Jun 2014
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
I got something like that too.

What was going on was that the first upstream smtp mail relay (in my ISP) didn't like my private domain because it did not recognise it. In that case, the upstream mailer saw my hostname as as customer<number-x>. The solution was to tell postfix to announce itself as the same domain as the upstream relay. You can fiddle that in the postscript configs.

If you're a small operator, proceed as above. If you're a big operator, ignore that and sort out something with your relay.
Please, explain clearly. i am a newbie . When i sent mail by microsoft outlook, port 465. Here, all My maillog.

cat /var/log/maillog
SSL_accept:SSLv3 flush data
Aug 15 15:14:44 ip-172-31-25-193 postfix/smtpd[28384]: Anonymous TLS connection established from unknown[14.161.4.44]: TLSv1 with cipher AES128-SHA (128/128 bits)
Aug 15 15:14:46 ip-172-31-25-193 postfix/smtpd[28384]: NOQUEUE: reject: RCPT from unknown[14.161.4.44]: 554 5.7.1 <tuanhqit@gmail.com>: Relay access denied; from=<hqtuanit@sucsongtre.vn> to=<tuanhqit@gmail.com> proto=ESMTP helo=<AdminHP>
Aug 15 15:14:49 ip-172-31-25-193 postfix/smtpd[28384]: disconnect from unknown[14.161.4.44]
Aug 15 15:15:32 ip-172-31-25-193 dovecot: imap-login: Login: user=<tuanhqit>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=28398, secured
 
Old 08-15-2014, 12:20 PM   #6
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,586

Rep: Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698Reputation: 698
Quote:
Aug 15 15:14:46 ip-172-31-25-193 postfix/smtpd[28384]: NOQUEUE: reject: RCPT from unknown[14.161.4.44]: 554 5.7.1 <tuanhqit@gmail.com>: Relay access denied; from=<hqtuanit@sucsongtre.vn> to=<tuanhqit@gmail.com> proto=ESMTP helo=<AdminHP>
TBH, I am no expert either.
Very interesting. . . Some things wrong

1. You're announcing yourself as 172-31-25-193. You probably mean 172.31.25.33 which is an internal network address that should never be used online. It's IP spoofing. The dashes confuse that. You need NAT to get your own public facing IP in place of it.

2. 14.161.4.44 is part of a block assigned to the Vietnamese Post office in Hanoi. So you are part of the Vietnamese Post office, or you are a spammer using their IP. They have the block, but that IP is not registered from the West.

3. The sucsongtre.vn domain you are using has a registered IP of 54.191.218.187, but you are using 14.161.4.44 which is suspicious to put it mildly.

Either way, you are being taken as a spammer. On the information provided, it is most probable that you are. So no other mail server wants to handle your mail, and they just drop it. You have to be a lot more sophisticated than that to get spam through. You will understand if I unsubscribe from this thread. Goodbye.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Email notification (new email) for Screen status bar? Xeratul Linux - General 1 03-16-2012 06:26 PM
Nagios - email notification - How to receive alert email? kumaran1983 Linux - Newbie 4 10-20-2011 07:12 AM
HOWTO: Email setup on a server Debian 5.0.4/POSTFIX/Courier/Spamassasin/squirrelmail KZeeSoft Linux - Software 1 03-11-2010 03:56 PM
Email notification jeremy LQ Suggestions & Feedback 6 11-07-2002 02:16 PM
email notification elainepearl Linux - General 1 01-14-2002 06:58 AM


All times are GMT -5. The time now is 02:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration