LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-24-2001, 07:02 PM   #1
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Rep: Reputation: 0
Unhappy Soundblaster CD-ROM at 0X230


I just upgraded from RH 6.2 to 7.1 and finally figured out that I needed to give the parms 0x230,1 to sbpcd during install. So it installed, but now whenever I try and mount the CDROM dmesg gives "scanning for soundblaster at 0x340". I have an append statement in lilo ="sbpcd=0x230,Soundblaster" and also tried ="sbpcd=0x230,1" but to no avail. What do I need to do to get sbpcd to look for my cd rom at 0x230? Thanks in advance,
BJ
 
Old 08-25-2001, 02:15 AM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
According to here , the line append = "sbpcd=0x230,SoundBlaster" is what you are supposed to put in your lilo.conf file. Just remember, that after you edit your lilo.conf file to run /sbin/lilo as root.
 
Old 08-25-2001, 03:35 PM   #3
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Original Poster
Rep: Reputation: 0
Talking Tried that, still no luck

Duh... I did update lilo.conf and tried lilo earlier and it couldn't write the boot record. adding boot /dev/hda helped i rebooted
and now dmesg says that it is adding the sbpcd parms. unfortunately, sbpcd is still scanning for 0x340 lasermate, 0x340 soundblaster and then saying 'uniform cd-rom driver unloaded'.. any other thoughts? Thanks.
 
Old 08-26-2001, 12:45 AM   #4
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Try mount -r -t iso9660 /dev/sbpcd /your/mount/point/here. Also, could you post a copy of your fstab file?
 
Old 08-29-2001, 01:43 AM   #5
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Original Poster
Rep: Reputation: 0
tried mount -r ...

mount -r -t iso9660 /dev/cdrom /mnt/cdrom and get:
mount: /dev/sbpcd: unknown device

dmesg still says: sbpcd-0[02] Scanning 0x340 (Lasermate)
sbpcd-0[03] Scanning 0x340 SoundBlaster
sbpcd-0[04] No drive found.
Uniform CD-ROM driver unloaded

/etc/fstab:
/dev/hda5 / ext2 defaults 1 1
/dev/hda1 /boot ext2 defaults 1 2
/dev/hdb2 /usr2 ext2 defaults 1 2
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
none /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/hdb1 swap swap defaults 0 0
/dev/sbpcd /mnt/cdrom iso9660 user,noauto,ro

Thanks in advance,
BJ
 
Old 08-29-2001, 11:41 PM   #6
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Did you run the this command (mount -r -t iso9660 /dev/sbpcd /your/mount/point/here) ? You said that you ran the command mount -r -t iso9660 /dev/cdrom /mnt/cdrom.

I noticed that the last line of your fstab file doesn't have the two numbers that are supposed to be there. Did you leave them off?

One of your error messages says that /dev/sbpcd is an unknown device. Do an ls /dev/sbpcd* and see if sbpcd if listed. If it's not there, you'll have to make one. Could you post a copy of your lilo.conf file?
 
Old 09-03-2001, 11:11 PM   #7
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Original Poster
Rep: Reputation: 0
tried reinstall.. still no luck

thanks for the help. Yes I tried mount -r -t iso9660 /dev/sbpcd /mnt/cdrom and get >mount: /dev/sbpcd: unknown device. I also reinstalled Linux 7.1 and it found my cdrom when I added 0x230,1 as parameters during install, but still can't find it after...

lilo.conf:
-----------------------------------------------
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
default=linux
message=/boot/message
verbose=5

image=/boot/vmlinuz-2.4.2-2
append="sbpcd=0x230,SoundBlaster"
label=linux
read-only
root=/dev/hda5
-----------------------------------------------
fstab:
/dev/hda5 / ext2 defaults 1 1
/dev/hda1 /boot ext2 defaults 1 2
/dev/hdb2 /usr2 ext2 defaults 1 2
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
none /proc proc defaults 0 0
none /dev/pts devpts gid=5,mode=620 0 0
/dev/hdb1 swap swap defaults 0 0
/dev/sbpcd /mnt/cdrom iso9660 user,noauto,ro 0 0
------------------------------------------------

here's what messages in /var/log says:

Sep 3 17:19:01 roxy insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters

Sep 3 17:19:01 roxy insmod: /lib/modules/2.4.2-2/kernel/drivers/cdrom/sbpcd.o: insmod block-major-25 failed

Sep 3 19:44:41 roxy kernel: sbpcd-0 [01]: sbpcd.c v4.63 Andrew J. Kroll <ag784@freenet.buffalo.edu> Wed Jul 26 04:24:10 EDT 2000

Sep 3 19:44:41 roxy kernel: sbpcd-0 [02]: Scanning 0x340 (LaserMate)...

Sep 3 19:45:13 roxy kernel: sbpcd-0 [03]: Scanning 0x340 (SoundBlaster)...

Sep 3 19:45:45 roxy kernel: sbpcd-0 [04]: No drive found.

Sep 3 19:45:45 roxy kernel: Uniform CD-ROM driver unloaded

Sep 3 19:45:45 roxy insmod: /lib/modules/2.4.2-2/kernel/drivers/cdrom/sbpcd.o: init_module: Input/output error

Sep 3 19:45:45 roxy insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters

Sep 3 19:45:45 roxy insmod: /lib/modules/2.4.2-2/kernel/drivers/cdrom/sbpcd.o: insmod block-major-25 failed


Any ideas? Thanks.
 
Old 09-05-2001, 04:37 AM   #8
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
It could be that there is a problem with your kernel. I was searching the web and I found references to problems in 2.4.2 kernels concerning sbpcd. One said that if sbpcd was compiled into the kernel, it worked. But if insmod was used, sbpcd would ignore any parameters that were passed to it.

Your version appears to be ignoring parameters that are passed to it.

When I ran sbpcd on my system, it first scanned for the lasermate on 0x340. Then it scans for the soundblaster on 0x230. If I pass the parameter 0x230,1 to it, scans for soundblaster first on 0x230 then it scans again for the soundblaster on 0x230. I tried again with the parameter 0x340,1 and it scans for soundblaster on 0x340 then it scans for soundblaster on 0x230. So, on my system it appears to work.

So, it could be your kernel.

As to why it worked on the install, the install probably used a different kernel.
 
Old 09-05-2001, 01:04 PM   #9
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Original Poster
Rep: Reputation: 0
I'll give it a try

I was playing around and used insmod once to see what would happen.. would that change my kernel? When you run sbpcd do you just execute it from a linux terminal window? When I look in /proc/devices sbpcd doesn't show up (which was one of the hints from the CDROM HOWTO), if that's true do I need to rebuild the kernel? Also, how can I get the source on the computer from the CDROM if I can't access the CDROM? (wow-I know a lot of questions here. thanks for helping me, linuxcool...) can I copy the install kernel over my existing kernel...
 
Old 09-06-2001, 03:43 AM   #10
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
OK, bjklingenberg, I'm running out of ideas.

The command insmod doesn't change your kernel, it just links a module to the kernel so that the kernel can use it. When you reboot your computer the module won't be available to the kernel until insmod is run again. You can have the module installed when you boot up by editing the /etc/modules.conf or the /etc/conf.modules file and add a line or lines to it.

Yes, you can run insmod from a terminal window but it must be a text screen and you must be root. No graphical interface like gnome or kde. I tried to run it in kde and after waiting a while it told me it was busy and terminated.

You can try running this command:

insmod /lib/modules/2.4.2-2/kernel/drivers/cdrom/sbpcd.o sbpcd=0x230,1

Use the number ' 1 '. Don't use the string ' SoundBlaster '. If the module is already installed, it will tell you it is.

Could you post a copy of your /etc/modules.conf or /etc/conf.modules file. I don't know which one you have.

You might be able to download the source code for the kernel.

As for the install kernel, I don't know if it would work with your install. If you were able to get the install kernel, you wouldn't copy it over your current kernel. You would copy it into your /boot directory and add some lines to your lilo.conf file to let you boot from either one.

Well, that's enough for now.

Last edited by linuxcool; 09-06-2001 at 03:47 AM.
 
Old 09-07-2001, 02:28 PM   #11
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Original Poster
Rep: Reputation: 0
still trying

thanks again for trying to help. When I tried
insmod /lib/modules/2.4.2-2/kernel/drivers/cdrom/sbpcd.o sbpcd=0x230,1
I get 3 messages about unresolved symbols: register_cdrom_Re92ea998, unregister_cdrom_R010c2aac and cdrom_fops_R4eb9a092

here's my modules.conf:
alias cdrom sbpcd
alias parport_lowlevel parport_pc
alias eth0 ne
---------------------------

I've also tried adding
options sbpcd sbpcd=0x230,1
in different flavors to modules.conf with no luck.

----------------------------
when I do a modprobe sbpcd, i get the following:
----------------------------
sbpcd.o: init_module: Input/loutput error
Hint: insmod errors can be caused by incorrectx modules parameters, including inavlid IO or IRQ parameters
/lib/modules.../sbpcd.o: insmod /lib/modules.../sbpcd.o failed
/lib/modules.../sbpcd.o: insmod spbcd failed
-----------------------------
if i could ever get sbpcd to take the parameters it seems like i'd be ok...
thanks in advance,
BJ
 
Old 09-07-2001, 02:31 PM   #12
bjklingenberg
LQ Newbie
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 10

Original Poster
Rep: Reputation: 0
Cool Success!

I just tried one last thing: I added
options sbpcd sbpcd='0x230,1'
to modules.conf. That did it!

Single quote vs. double quotes!

Still don't know why the append= isn't working maybe I'll play with that. Thanks for all your suggestions - the modules.conf thread is what I needed.

BJ
 
Old 09-07-2001, 06:20 PM   #13
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Great!!! Glad that you got it working.

That's why I wanted you to post a copy of your modules.conf file. I wanted to see if the options line was in there and if it was in there, was it OK.

As for the kernel not accepting appends, I believe it is a bug in the kernel. I'm not certain if it applies to all appends or just ones passed to sbpcd.

Oh well. Have fun.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing a DVD-ROM CD/RW-ROM in MandrakeLInux 10.1 DesyphER Linux - Software 1 02-14-2005 03:37 AM
permission denied! floppy cd-rom dvd-rom HELP! OMEGA-DOOM Linux - Software 17 10-15-2004 06:40 PM
DVD-ROM/CD-ROM unable to recognize debain boot CD gottfried Linux - Newbie 2 01-20-2004 01:39 PM
how to add cd-rom, dvd-rom, floppy, hard disk icons on gnome desktop? spyghost Linux - Software 6 09-21-2003 06:44 PM
DVD-ROM not detected CD-RW mistaken as CD-ROM Device DarkXtar Slackware 21 06-02-2003 08:58 PM


All times are GMT -5. The time now is 10:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration