LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2004, 01:19 PM   #1
Sovetskeey
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora Core 6
Posts: 27

Rep: Reputation: 15
Sound trouble on Fedora Core 2


Apparently Fedora thinks that my sound card is reminiscent of the ancient SB Pro and will only play one sound at a time. This includes music... If I'm using XMMS and somebody messages me on Gaim, the song finishes and then it plays all the sounds that would have been played had the music not been running...
I'm using the onboard sound card on my Asus A7N8X-X motherboard. It's on the nForce2 chipset with that AC'97 audio decoder.
Can anyone help me out with this problem?
http://members.shaw.ca/psg1_sniper/Screenshot.png

Last edited by Sovetskeey; 09-07-2004 at 01:30 PM.
 
Old 09-07-2004, 08:54 PM   #2
Sovetskeey
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora Core 6
Posts: 27

Original Poster
Rep: Reputation: 15
I hate to bump the thread but it's a rather annoying problem... Imagine only hearing one sound at a time... It's awful!
 
Old 09-07-2004, 11:35 PM   #3
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Are you using the ALSA libraries for sound? If so, you may need to reconfigure apps that use sound to use 'aplay'. I have had this problem in the past (and it's quite annoying, I agree) and I ended up solving it by making sure all apps that require sound use 'aplay %s' if possible. This should help with things like Gaim, XMMS, etc. Some apps can't be configured and as such will hog the sound channel.
 
Old 09-08-2004, 12:16 AM   #4
Sovetskeey
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora Core 6
Posts: 27

Original Poster
Rep: Reputation: 15

Where can I set this "aplay %s"? In particular I really only need to set it for Gaim, XMMS and Teamspeak.
Thank you in advance .
Edit: Found it in Gaim but didn't seem to have any effect.

Last edited by Sovetskeey; 09-08-2004 at 12:25 AM.
 
Old 09-08-2004, 01:47 AM   #5
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
There is this "dmix" thing to play multiple sound at a time (for Alsa). This is a known problem though with linux. But I don't use it since the sound comes out weird.
 
Old 09-08-2004, 06:46 AM   #6
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Yes I'm afraid this is a long standing problem with Linux on systems that don't support hardware mixing. I've reported it to Bill Nottingham and he's marked it as a FC3 blocker.

One quick solution is to do something like:

cp /usr/share/alsa/alsa.conf /etc/alsa.conf

now set the ALSA device in XMMS to be "dmix" not "default". Now in gaim tell it to use the following command:

aplay -D dmix %s

now they should all be able to play at once .... dmix is a rather unusual technology and is still getting the bugs worked out, you have been warned.

Hopefully FC3 will have this configured by default.
 
Old 09-08-2004, 11:01 PM   #7
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
As for me, to enable dmix, I made this ".asoundrc" file in home directory.

The content:

Code:
pcm.ossmix {
    type dmix
    ipc_key 1021          # must be unique!
    slave {
        pcm "hw:0,0"
        period_time 0
        period_size 1024  # must be power of 2
        buffer_size 8192  # dito. It
        #format "S32_LE"
        #periods 128      # dito.
        rate 48000
    }
Then in XMMS, manually put "pcm.ossmix" in Audio Device part. Then try playing some .wav file at the same time with aplay.
 
Old 09-09-2004, 12:56 AM   #8
Sovetskeey
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora Core 6
Posts: 27

Original Poster
Rep: Reputation: 15
In one eye and out the other (ears don't exactly work too well over internet forums).
 
Old 09-09-2004, 07:04 AM   #9
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Try setting XMMS to use the "eSound output plugin" and then change the command used to play software in gaim to "esdplay %s" then. It's a slightly simpler solution.

Hopefully FC3 will have this bug nailed.
 
Old 09-09-2004, 05:10 PM   #10
Sovetskeey
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora Core 6
Posts: 27

Original Poster
Rep: Reputation: 15
Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you!
It works! You're a God mhearn .

Now, here's the screen on TeamSpeak where I can set it... "esdplay %s" doesn't work in here though... Any idea what to put to make Teamspeak work like Gaim and XMMS?
http://members.shaw.ca/psg1_sniper/Soundsettings.png

Last edited by Sovetskeey; 09-09-2004 at 05:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble getting fedora core 4 to run evan3107 Linux - Laptop and Netbook 3 10-16-2005 10:46 AM
Having trouble with connectivity in Fedora Core 4 gonzo22412 Linux - Networking 1 08-07-2005 09:18 AM
trouble with fedora core 3...please help! dabeaver68 Linux - Software 4 01-04-2005 02:30 PM
trouble on fedora core 2 c++ and c standby01 Programming 3 08-12-2004 07:34 PM
Trouble with login with X in Fedora Core EgosZ Linux - Newbie 1 06-28-2004 02:04 AM


All times are GMT -5. The time now is 06:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration