LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-15-2005, 04:38 AM   #1
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Rep: Reputation: 15
sound starts up as mute...


hallo`
i'm using debian sid 2.6.11...
and gnome

the sound is alway muted @startup?!
how do i change it?

thanx seaking
 
Old 10-15-2005, 06:16 AM   #2
Zeistler
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 108

Rep: Reputation: 15
Open a terminal
login as root - su root
Store the sound settings - alsactl store
 
Old 10-15-2005, 06:34 AM   #3
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Original Poster
Rep: Reputation: 15
Code:
root@seaking:~# alsaalsactl store
bash: alsaalsactl: command not found
 
Old 10-16-2005, 06:03 AM   #4
Zeistler
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 108

Rep: Reputation: 15
alsactl store not alsaalsactl store
 
Old 10-16-2005, 12:20 PM   #5
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Original Poster
Rep: Reputation: 15
sorry... but same
 
Old 10-16-2005, 03:23 PM   #6
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Rep: Reputation: 55
Quote:
Originally posted by seaking
sorry... but same
By default, all ALSA levels are muted, so you need to unmute them and then store those settings.
The steps you take are the following:

1) You load the sound modules (i guess you already have done that)
2) Run "alsamixer", unmute the levels and set them as loud as you want. Exit alsamixer.
3) Run "alsactl store" as Zeistler mentioned.

Then the debian initscripts (/etc/init.d/alsa if i remember correctly) will restore the levels every time you boot, so sound
will work ok.

alsactl resides normally in /usr/sbin

In order to use it you must have the package "alsa-utils" installed.
If you don't have it installed then install it with apt-get.
 
Old 10-16-2005, 04:59 PM   #7
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Original Poster
Rep: Reputation: 15
ok thats wierd...
i have alsa...
but all of ur command do not work?!
i tried man alsa but gurnisht
 
Old 10-17-2005, 02:03 AM   #8
Zeistler
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 108

Rep: Reputation: 15
If you use KDE there is a program called kmix which works pretty much like the sound agent in windows.
 
Old 10-17-2005, 02:53 AM   #9
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Original Poster
Rep: Reputation: 15
no ... i'm working with gnome.. it has volume controle but i cant make it save it...
althou i configured it to save session setting b4 loging out.
may b i can try to set it on the config file?
 
Old 10-17-2005, 12:21 PM   #10
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Rep: Reputation: 55
write "dpkg -l |grep alsa" to see if you have the package installed.
If you have it installed then it isn't prossible not to have the command.
 
Old 10-17-2005, 05:03 PM   #11
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Original Poster
Rep: Reputation: 15
[CODE] dpkg -l |grep alsa
ii alsa-base 1.0.9b-4 ALSA driver configuration files
[CODE]
this is the output
 
Old 10-18-2005, 07:31 AM   #12
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Rep: Reputation: 55
Quote:
Originally posted by seaking
[CODE] dpkg -l |grep alsa
ii alsa-base 1.0.9b-4 ALSA driver configuration files
[CODE]
this is the output
Ok. This means you have the "alsa-base" package which has the base files of ALSA (pretty obvious )
As i already said in my previous post "alsamixer" and "alsactl" are included in the package "alsa-utils" which you probably don't
have or else it would show in dpkg.

If you have correctly set up your apt sources you just run "apt-get install alsa-utils"
and you will then have the utils.

Then do the steps me and Zeistler described.
 
Old 10-18-2005, 07:54 AM   #13
seaking
LQ Newbie
 
Registered: Oct 2005
Location: center
Distribution: DEBIAN sid
Posts: 21

Original Poster
Rep: Reputation: 15
worked thanx!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Inspiron 9200 Volume, Play, Mute Quick Buttons and Sound with Suse 9.3 elliotfuller Linux - Hardware 1 06-08-2005 10:38 PM
Es1869 Sound Card: Mute gani Slackware 15 09-26-2004 10:14 PM
mute sound alsa mixer - used to work TroelsSmit Linux - Newbie 4 09-02-2004 12:39 PM
Mute KDE startup sound? prompt Linux - Software 2 06-04-2004 03:33 PM
Why is this sound card only 1/2 mute? ONEderer Linux - General 0 01-24-2004 09:07 PM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration