LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2009, 05:20 AM   #1
Whitey_22
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Rep: Reputation: 0
Sound Problems on OpenSuSE with GNOME Desktop


Hi everyone,

I'm having some annoying problems with my sound. I have sound, but only from 1 source at a time. For example, I can get sound from Spotify through Wine. But if that's running (even paused) then I don't get sound from Youtube, etc. Simply shutting down one application does not seem to give others access to the sound card. Surely it's possible to set up my sound card so it can be accessed from more than one application at a time?

I am also having problems running MP3 and AAC audio files. They just don't work at all.

Everything else is running great, if I can sort these sound problems I'll have a system running perfectly for me.
 
Old 08-27-2009, 05:27 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Are you using pulse audio. You can adjust applications individually using the padevchooser program. Your program in wine might use OSS or SDL instead, but I can play Civilization & listen to amarok at the same time.

In YaST2's inst_sources module you can add the packman repo. It's packages are built enabling non free codecs.
 
Old 08-27-2009, 05:35 AM   #3
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Looks like your running the original OSS, try installing ALSA or OSSv4.
 
Old 08-27-2009, 05:43 AM   #4
Whitey_22
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the reply. I am using Pulse Audio. I can set Wine to use OSS or ALSA drivers, I get sound no problem from either.

But when I use the Pulse Audio Device Chooser, I get only one output called Mono and moving the bar does change the volume I hear. I can however change the volume using the Volume Control applet and selecting the HDA Intel (ALSA Mixer) option.

Now that I have sound coming from Spotify I won't get sound from Youtube or any other flash sites, which is the main problem I'm having. But it may be related to my Pulse Audio which does not seem to be operating as you expected.
 
Old 08-27-2009, 05:47 AM   #5
Whitey_22
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mushroomboy View Post
Looks like your running the original OSS, try installing ALSA or OSSv4.
I have ALSA. When I open ALSA mixer I only have one bar called Master though. Changing this does nothing to the volume I hear. There used to be 5 or 6 bars in there and they affected the volume I could hear.
 
Old 08-27-2009, 05:50 AM   #6
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by Whitey_22 View Post
Thanks for the reply. I am using Pulse Audio. I can set Wine to use OSS or ALSA drivers, I get sound no problem from either.

But when I use the Pulse Audio Device Chooser, I get only one output called Mono and moving the bar does change the volume I hear. I can however change the volume using the Volume Control applet and selecting the HDA Intel (ALSA Mixer) option.

Now that I have sound coming from Spotify I won't get sound from Youtube or any other flash sites, which is the main problem I'm having. But it may be related to my Pulse Audio which does not seem to be operating as you expected.
try to get rid of pulse audio and reboot the system. Don't get rid of ALSA just pulse and see if you can still get sound. Pulse has problems and I hate it with a passion, I've herd of to many problems with it.
 
Old 08-27-2009, 05:56 AM   #7
Whitey_22
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I'm pretty new to Linux, so is it safe just to go the Software Manager and remove everything under the "Installed" tab that is returned when I search "pulse audio" and then do a restart and see if the sound's still going?
 
Old 08-27-2009, 08:07 AM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
You don''t need to uninstall pulse audio. You can deselect it in the YaST2 sound setup. However, for what you want, you need pulse audio.
You may have found the wrong mixer control. There are different ones. Look on the Devices tab. Expand the "sinks" tree list if it isn't. You will see lines with numbers like #335 and #324. Double click on one. It will say what the client is. There will also be a volume control. You will be able to adjust the volume on the program itself as well.
If an audio source is too low, you can use these padevchooser volume controls to bring one to over 100%. Otherwise selecting pulse when you can, otherwise alsa should work the way you want.

Take a look at the attached picture. There are three alsa clients, each which can have the volume independently adjusted.
Attached Thumbnails
Click image for larger version

Name:	pulse.png
Views:	8
Size:	109.2 KB
ID:	1331  

Last edited by jschiwal; 08-27-2009 at 08:23 AM.
 
Old 08-27-2009, 08:26 AM   #9
Whitey_22
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
You don''t need to uninstall pulse audio. You can deselect it in the YaST2 sound setup. However, for what you want, you need pulse audio.
You may have found the wrong mixer control. There are different ones. Look on the Devices tab. Expand the "sinks" tree list if it isn't. You will see lines with numbers like #335 and #324. Double click on one. It will say what the client is. There will also be a volume control. You will be able to adjust the volume on the program itself as well.
If an audio source is too low, you can use these padevchooser volume controls to bring one to over 100%. Otherwise selecting pulse when you can, otherwise alsa should work the way you want.

Take a look at the attached picture. There are three alsa clients, each which can have the volume independently adjusted.
I don't have any clients in that Pulse Audio Manager. I only have the "combined" tree under "sinks". I definitely have ALSA installed, not sure why it's not showing up there.

Last edited by Whitey_22; 08-27-2009 at 08:27 AM.
 
Old 08-27-2009, 03:19 PM   #10
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,137

Rep: Reputation: 65
Quote:
Originally Posted by mushroomboy View Post
try to get rid of pulse audio and reboot the system. Don't get rid of ALSA just pulse and see if you can still get sound. Pulse has problems and I hate it with a passion, I've herd of to many problems with it.
I had two systems running OpenSUSE 11.0. Nearly identical hardware though one had more memory. The main difference as far as Pulse should have been concerned was that they each had different sound cards. Both were working fine using esound and ALSA. One system runs Pulse without any problems (as far as I can see). The other system just flat refused to produce any sound except from the ALSA test utility. After wasting several afternoons trying to figure out why it would produce any sound I finally wound up removing Pulse and installing esound. Only then would sound work as before.

--
RT
 
Old 08-27-2009, 03:46 PM   #11
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by jschiwal View Post
You don''t need to uninstall pulse audio. You can deselect it in the YaST2 sound setup. However, for what you want, you need pulse audio.
You may have found the wrong mixer control. There are different ones. Look on the Devices tab. Expand the "sinks" tree list if it isn't. You will see lines with numbers like #335 and #324. Double click on one. It will say what the client is. There will also be a volume control. You will be able to adjust the volume on the program itself as well.
If an audio source is too low, you can use these padevchooser volume controls to bring one to over 100%. Otherwise selecting pulse when you can, otherwise alsa should work the way you want.

Take a look at the attached picture. There are three alsa clients, each which can have the volume independently adjusted.
pulse audio has shown problems of locking the audio for one program. If one program uses pulseaudio it will lock alsa to that program and any program that doesn't interface with pulse won't work. There are other known glitches in that I have seen/herd of. I always say to try and not use pulse whenever possible, why? Why use a sound server when the program can directly interface with ALSA? Yeah you loose the ability for controlling audio levels, and personally I can live with that. Pulse HAS known problems...

If you want to test this out, kill all the pulse audio processes that are running and test your sound. If you get sound from multiple programs... I rest my case.

https://bugs.launchpad.net/ubuntu/+s...io/+bug/237375

Code:
Ubuntu 8.04 LTS now uses PulseAudio as default sound server. Then I understand when I am playing audio with totem, PulseAudio is working for it.
Well, the problem is that PulseAudio locks the audio card, and does not allow to Alsa play sounds. For example, if while i am playing audio with totem, I run command "aplay sound.wav", aplay cannot play the sound. I obtain this error:

ALSA lib pcm_dmix.c:996:(snd_pcm_dmix_open) unable to open slave
aplay: main:546: error to open audio: Device or resource busy.

Then many applications that uses Alsa (or aplay) by default cannot play their sounds.
It is needed a library to can share sound between both: PulseAudio and Alsa, as previous Ubuntu versions had, in previous versions, this work used to be done by library "libesd-alsa0", now it is needed a similar library for PulseAudio in place of ESD.
I'm also guessing that other systems might suffer the same problems, even differen't distro's. I've seen countless problems with pulse, even wine says it's unsupported though they have a plugin for it.... Why? Because there is no need for another sound server, that's why OSSv4 built the mixing right into the sound. ALSA should do the same and we should eliminate pulse, it's unessicary bulk.

Basically... if "Program > ALSA" Then why would you have "Program > PULSE > ALSA"???? More latency and more room for error.
 
Old 08-27-2009, 08:31 PM   #12
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Rerunning both "alsaconf" and YaST2's sound module usually fixes sound problems. If you have it disabled in in the YaST2 sound configuration, and the server doesn't start, that might cause the symptoms you are seeing. Alsaconf often needs to be rerun after a kernel update. You could also run `alsamixer' to check that something isn't muted. This may also happen after a kernel, or alsa update.

If the problem persists, you could kill the pulseaudio server and restart it with "pulseaudio --start" in the run dialog. If the pulseaudio server was running before you did this, and this fixes the problem, then yes, it would be due to pulse audio. If that doesn't solve the problem, it may be caused by something else. I'm wondering if the pulseaudio server wasn't running before an application got a lock on the /dev/dsp device for itself.

Yes, using pulseaudio does add latency. It has improved greatly since SuSE 11.0, and I prefer it now. Ubuntu 8.04's pulse configuration may not be the fairest example to use as typical. Whether you use it or not is up to you. I find that the extra layer Program -> Alsalib -> pulse -> alsa drivers -> hardware helps prevent a poorly written program from locking out sound for the other programs.

http://upload.wikimedia.org/wikipedi...io-diagram.svg

Last edited by jschiwal; 08-27-2009 at 09:32 PM.
 
Old 08-27-2009, 08:44 PM   #13
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by Whitey_22 View Post
Hi everyone,

I'm having some annoying problems with my sound. I have sound, but only from 1 source at a time. For example, I can get sound from Spotify through Wine. But if that's running (even paused) then I don't get sound from Youtube, etc. Simply shutting down one application does not seem to give others access to the sound card. Surely it's possible to set up my sound card so it can be accessed from more than one application at a time?

I am also having problems running MP3 and AAC audio files. They just don't work at all.

Everything else is running great, if I can sort these sound problems I'll have a system running perfectly for me.
No, the person wants sound from multiple applications, I did read the post.

I'll re-state pulseaudio has known problems controlling ALSA. And again I state why use a sound server if you can directly output to ALSA. esound is a solution.... but I would say the best solution is to remove a sound server, since it's something that isn't really needed anymore. Yes it's a luxury but sometimes just having sound from multiple sources is worth more.

Last edited by mushroomboy; 08-27-2009 at 08:45 PM.
 
Old 08-28-2009, 05:01 AM   #14
Whitey_22
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I've found that if I do a "Top" command in a terminal and kill the pulse audio process that I can then get sound through Wine again. Once Wine is running I can't get sound from Youtube though. Wine does not seem to be using Pulse, the process does not appear when Wine is playing sound, but it seems to block Pulse from using my sound card.

The Top command and killing the process is a workaround that I could live with, it saves resetting the computer, but it would be much better if the sound would just work the way it's supposed to.

Also, MP3 files still won't play at all. I have all the plugins, there is no obvious reason why they won't play.
 
Old 08-28-2009, 10:24 AM   #15
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Wine DOES not work with pulse audio.... Infact it's even stated on the WINE websties...

http://appdb.winehq.org/objectManage...rsion&iId=3731

Code:
For Ubuntu 8.04 - kill/disable pulseaudio. It is not compatible with Wine.
I think it's on some of the other pages, I just happen to play CSS.

[EDIT]

Also if you want to venture into some new ideas:
http://www.4front-tech.com/wiki/inde...v4_from_source
OSSv4 is by far better than ALSA, and some people are reporting some very good luck with how well it runs. =)

Last edited by mushroomboy; 08-28-2009 at 10:31 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Perfect Desktop - OpenSUSE 11.1 (GNOME) LXer Syndicated Linux News 0 12-22-2008 09:40 AM
LXer: The Perfect Desktop - OpenSUSE 11 (GNOME) LXer Syndicated Linux News 0 06-29-2008 07:51 AM
LXer: The Perfect Desktop - OpenSUSE 10.3 (GNOME) LXer Syndicated Linux News 0 10-09-2007 03:20 PM
openSuSE 10.0 + Gnome 2.12 desktop... NO TERMINAL ON THE CONTEXT MENU! hamstar Linux - Software 1 12-08-2005 05:35 AM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration