LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-24-2008, 08:25 PM   #1
NickViper1024
Member
 
Registered: Sep 2008
Posts: 45

Rep: Reputation: 15
Sound Problem on mid-range nVidia Mobo


Hey guys,

I've tried several flavors of Linux now over the past couple days and I'm running into a consistent problem: My sound doesn't work.

The funny part is that when I go to Control Panel->Sounds to see why I'm not getting any audio out of any applications, the sound works when I go to hit the test buttons. I know this sounds generic, but it's basically the same story with every Linux/GUI I've tried thus far. Right now I'm on Ubunto (which I'm loving) but I have to have my sound!

I think the problem may be related to me using a USB headset for sound input/output. Among the many device options I have are USB headset, OSS, ALSA, and PulseAudio. When hitting the test buttons next to each setting, only USB Headset option works. But anywhere outside this window, sound does not work. I'm not even sure how to operate the Default Mixer Tracks at the bottom of the window.

I have not tested my sound output jacks on my PC for sound, because I have no speakers. Only this USB headset. Please help!
 
Old 09-25-2008, 03:15 PM   #2
goncalopp
Member
 
Registered: Jun 2008
Posts: 47

Rep: Reputation: Disabled
Most applications on linux use ALSA.
I'm guessing a bit here, but probably alsa has configured your soundcard to be the default output, instead of the headset.
Try this:
get to the console and type "asoundconf list". It should give you the list of devices recognized by alsa, so if you're lucky, it should list both the internal soundcard and the headset.
If it does list the headset, all you probably need to do is
"asoundconf set-default-card [headset name]"

Hope it helps
 
Old 09-25-2008, 10:36 PM   #3
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 795

Rep: Reputation: 119Reputation: 119
it could also be a permissions problem
is your user a member of the audio group ?
check your /etc/group file
look for the audio group and your user name in this group
if not add it to the group
 
Old 09-26-2008, 07:22 PM   #4
NickViper1024
Member
 
Registered: Sep 2008
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by goncalopp View Post
Most applications on linux use ALSA.
I'm guessing a bit here, but probably alsa has configured your soundcard to be the default output, instead of the headset.
Try this:
get to the console and type "asoundconf list". It should give you the list of devices recognized by alsa, so if you're lucky, it should list both the internal soundcard and the headset.
If it does list the headset, all you probably need to do is
"asoundconf set-default-card [headset name]"

Hope it helps
Thanks for the suggestions! I tried the above and I'm making progress, however I'm not quite there yet. I still don't have sound, but setting ALSA's default to my Headset allowed me to change all my Sound options (under System->Preferences->Sound) to ALSA and get sound out of one ear. Bear in mind that this is STRICTLY for the test sound buttons. Sound from other applications (and the sound play buttons on the 2nd tab: Sounds) still don't work at all.

I also verified that my username is part of the audio group. Thanks for that suggestion as well!
 
Old 09-26-2008, 10:53 PM   #5
NickViper1024
Member
 
Registered: Sep 2008
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by NickViper1024 View Post
Thanks for the suggestions! I tried the above and I'm making progress, however I'm not quite there yet. I still don't have sound, but setting ALSA's default to my Headset allowed me to change all my Sound options (under System->Preferences->Sound) to ALSA and get sound out of one ear. Bear in mind that this is STRICTLY for the test sound buttons. Sound from other applications (and the sound play buttons on the 2nd tab: Sounds) still don't work at all.

I also verified that my username is part of the audio group. Thanks for that suggestion as well!
Ok I'm not sure what I did but I got sound to work in one ear on any application that is set to ALSA (but not the other ear.) I've looked at System->Preferences->Sound and the individual soudn configs for each application (right now I'm tinkering with Amarok) and I don't see anything in either that leads me to think I can change how the left/right channels of audio are controlled. Anyone have any ideas?
 
Old 09-27-2008, 10:40 AM   #6
goncalopp
Member
 
Registered: Jun 2008
Posts: 47

Rep: Reputation: Disabled
Try to install a mixer application and check your left/right channels levels. Gamix is quite good in my opinion, you can get it with synaptic/apt-get
 
Old 09-27-2008, 12:35 PM   #7
NickViper1024
Member
 
Registered: Sep 2008
Posts: 45

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by goncalopp View Post
Try to install a mixer application and check your left/right channels levels. Gamix is quite good in my opinion, you can get it with synaptic/apt-get
I think the problem has been solved, thanks to all of you!

For whatever reasons, my settings weren't saving through reboots. If I use "asoundconf set-default-card [headset]" , sound starts piping through one ear. Then using gamix to adjust my left/right channels works beautifully.

The problem is that with each reboot, asoundconf would forget to pipe sound through the USB headset. And everytime I reboot, my left/right channels would go back to 0/100%. I don't know what's doing this, but at least this knowledge allows me to enjoy sound my music in Amarok!

It is worth noting that I still can't hear "event sounds" configured through System->Preferences->Sound but I'm not sweating over it. If you have any suggestions, I'm all ears of course! I want to learn as much about Linux problems as I possibly can.
 
Old 09-28-2008, 12:13 AM   #8
NickViper1024
Member
 
Registered: Sep 2008
Posts: 45

Original Poster
Rep: Reputation: 15
Where can I find the config files for asoundconf ? Everytime I reboot, my settings revert back to my mobo sound device. I also can't figure out where my left/right channels are defaulting to 0%/100% either.
 
Old 09-28-2008, 10:05 AM   #9
goncalopp
Member
 
Registered: Jun 2008
Posts: 47

Rep: Reputation: Disabled
From the asoundconf manual:

Code:
asoundconf configures the ALSA library for the user.  It does  this  by
reading the values of parameters from and writing the values of parame‐
ters to the special file .asoundrc.asoundconf in the userís home direc‐
tory.  The .asoundrc.asoundconf file should not be edited by hand!
Code:
(As of this writing the Ubuntu developers
have  plans  to  use  asoundconf  for  setting  parameters  listed   in
/usr/share/alsa/alsa.conf under the defaults section
I've never messed too much with alsa, but you probably can find some info on the manuals.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Linux expanding into mid-range phones LXer Syndicated Linux News 0 04-23-2008 05:50 PM
nVidia MoBo sound drivers? lewismetoo Linux - Desktop 3 10-07-2006 08:57 PM
LXer: PGP Corporation Announces New Mainframe and Mid-Range Encryption Solutions for IBM Platforms LXer Syndicated Linux News 0 02-13-2006 11:46 PM
LXer: <em>LXer Feature:</em> Interview with IBM: DB2 in the Mid-Range Market LXer Syndicated Linux News 0 01-11-2006 10:46 AM
LXer: <em>LXer Feature</em>Interview with IBM: DB2 in the Mid-Range Market LXer Syndicated Linux News 0 01-11-2006 09:46 AM


All times are GMT -5. The time now is 04:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration