LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   sound problem in slackware 10.1 (http://www.linuxquestions.org/questions/linux-newbie-8/sound-problem-in-slackware-10-1-a-352765/)

b0nd 08-13-2005 02:53 AM

sound problem in slackware 10.1
 
Hello there,
i just installed slackware 10.1 on my system
have XP and Redhat 9 on the same system too.
......
the problem is that there is no sound in slackware, neither at the boot time
nor during playing the songs...
moreover its not giving any error about that..
What should i do???

regards !!!

Nylex 08-13-2005 02:58 AM

Maybe the sound is muted or something. Open a terminal and type "alsamixer". Then just raise the volume of everything (I guess). You can do that with the up arrow key. Use the left and right arrow keys to go between items. If they have "[Off]" by them, press m to turn them on. Read the man page for more info.

b0nd 08-13-2005 03:10 AM

Thnx for replying ...
i've already checked all that things.....problem is somewhere else....

regards

masand 08-13-2005 04:01 AM

hi there

in ur XMMS player
go to preferences and choose O/P as Alsa

also try running alsaconf as well

regards

SlackerLX 08-13-2005 04:18 AM

$su -
$alsamixer
Configure bars with arrows, enable or disable service with "m" key.
When done ESC
#alsactl store
P.S. If you have 5.1 speaker system, be sure that LFE channels bars are all way down and [off]. LFE channel is to generate 5.1 emulation matrix on 4 speaker systems.
;)

P.S.S. Please, KEEP IN MIND THAT SOUND WON'T WORK AFTER THAT PROCEDURE IMMEDIATELY!
REBOOT NEEDED!!

Nylex 08-13-2005 04:21 AM

He said he already checked the volume :rolleyes:.

SlackerLX 08-13-2005 04:30 AM

Patience is a virtue my friend. There is no emotion.;)
I saw only first message. If you reply to people you must be tolerant :D

fast_rizwaan 08-13-2005 01:27 PM

sound card is not configured
 
As you've said that you've just installed slackware 10.1. I suspect that you did not run:

1. "alsaconf" to setup your sound card
2. "alsamixer" to set the default volumes
3. "alsactl store" to save the volume settings

Make sure that your "VOLUME" and "PCM" are enabled!!!

most applications would use NULL sound device, if they could not output sound to a hardware device.

also check out some stupid mistakes which even Super Computer users would do:

1. check jack connection at sound card is properly inserted to the "SPEAKER out" or "LINE OUT"
2. check power supply
3. check speaker volume (not alsa but physical device's knob)
4. are you ears closed ? ;)

b0nd 08-14-2005 03:11 AM

Hello all,
thanks all of u for replying.
i must admit my mistake that i didn't run alsamixer....
..........
actually i never heard about it !!! moreover when i had slackware 10.0 i never faced such a problem ( althoug i faced but it get ok through kmixer settings only) so i tried kmixer settings here also in slackware 10.1 but it didn't work, so by ignorance of such settings i said that i've already checked the volume settings..............sorry for that.

thanks to all of you for your guidance.


All times are GMT -5. The time now is 01:05 PM.