LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2010, 04:15 PM   #1
gopinath1983
LQ Newbie
 
Registered: Nov 2010
Posts: 2

Rep: Reputation: 0
sound not working in rhel5


Hello
i m using RHEL5 ......but only prob i m facing is that there is no
sound in my system.

[root@localhost ~]# /sbin/lsmod
Module Size Used by
deflate 7873 0
zlib_deflate 21977 1 deflate
af_key 40785 0
autofs4 24517 2
hidp 23105 2
rfcomm 42457 0
l2cap 29505 10 hidp,rfcomm
bluetooth 53797 5 hidp,rfcomm,l2cap
sunrpc 144893 1
iscsi_tcp 26689 0
ib_iser 34453 0
libiscsi 30401 2 iscsi_tcp,ib_iser
scsi_transport_iscsi 31689 4 iscsi_tcp,ib_iser,libiscsi
ib_srp 32729 0
ib_sdp 51593 0
ib_ipoib 74345 0
rdma_ucm 16449 0
ib_ucm 19653 0
ib_uverbs 34921 2 rdma_ucm,ib_ucm
ib_umad 19049 0
rdma_cm 34293 3 ib_iser,ib_sdp,rdma_ucm
ib_cm 34861 4 ib_srp,ib_ipoib,ib_ucm,rdma_cm
iw_cm 13125 1 rdma_cm
ib_addr 11845 1 rdma_cm
ib_sa 38581 4 ib_srp,ib_ipoib,rdma_cm,ib_cm
ib_mad 37717 3 ib_umad,ib_cm,ib_sa
ib_core 54465 13 ib_iser,ib_srp,ib_sdp,ib_ipoib,rdma_ucm,ib_ucm,ib_uverbs,ib_umad,rdma_cm,ib_cm,iw_cm,ib_sa,ib_mad
ipv6 258273 21 ib_ipoib
xfrm_nalgo 13765 1 ipv6
crypto_api 11969 1 xfrm_nalgo
dm_mirror 29253 0
dm_multipath 22089 0
dm_mod 61661 2 dm_mirror,dm_multipath
video 21193 0
sbs 18533 0
backlight 10049 1 video
i2c_ec 9025 1 sbs
button 10705 0
battery 13637 0
asus_acpi 19288 0
ac 9157 0
lp 15849 0
snd_hda_intel 24793 1
snd_hda_codec 210881 1 snd_hda_intel
snd_seq_dummy 7877 0
snd_seq_oss 32577 0
snd_seq_midi_event 11073 1 snd_seq_oss
snd_seq 49585 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 11725 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 42945 0
snd_mixer_oss 19009 1 snd_pcm_oss
snd_pcm 72005 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
sg 36189 0
snd_timer 24517 2 snd_seq,snd_pcm
k8_edac 18177 0
floppy 57125 0
pcspkr 7105 0
snd 52421 11 snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer
edac_mc 26257 1 k8_edac
parport_pc 29157 1
forcedeth 47433 0
ide_cd 40033 0
soundcore 11553 1 snd
serio_raw 10693 0
parport 37513 2 lp,parport_pc
i2c_nforce2 10945 0
snd_page_alloc 14281 2 snd_hda_intel,snd_pcm
cdrom 36705 1 ide_cd
k8temp 9537 0
i2c_core 23745 2 i2c_ec,i2c_nforce2
hwmon 7365 1 k8temp
sata_nv 28617 6
libata 143997 1 sata_nv
sd_mod 24897 7
scsi_mod 134605 8 iscsi_tcp,ib_iser,libiscsi,scsi_transport_iscsi,ib_srp,sg,libata,sd_mod
ext3 123593 5
jbd 56553 1 ext3
uhci_hcd 25421 0
ohci_hcd 23261 0
ehci_hcd 33357 0


[root@localhost ~]# /sbin/lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:05.0 VGA compatible controller: nVidia Corporation C51PV [GeForce 6150] (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
 
Old 11-16-2010, 05:17 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hello gopinath1983 and welcome to LQ,

it looks like there are modules for the sound loaded. Please execute "lspci -v" and look into the section about the audiodevice, the last line of this section will show the module which is loaded for the device. If its loaded, you may (as root) execute "alsaconf" to configure your audiodevice. Afterwards as a normal user you may execute "alsamixer".
If the apropriate module is not loaded please post again and we'll look further.

Markus
 
Old 11-16-2010, 05:28 PM   #3
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 2,629

Rep: Reputation: 458Reputation: 458Reputation: 458Reputation: 458Reputation: 458
With Intel HDA sound chips, sometimes you have to open, as said by markush above, alsamixer and disable external amplifier, or simply external, unmute internal, if it's not already on.
 
Old 11-18-2010, 12:58 PM   #4
gopinath1983
LQ Newbie
 
Registered: Nov 2010
Posts: 2

Original Poster
Rep: Reputation: 0
still problem sir

i execute lspci -v

00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2) (prog-if 01 [Subtractive decode])
Flags: bus master, 66MHz, fast devsel, latency 0
Bus: primary=00, secondary=04, subordinate=04, sec-latency=128
I/O behind bridge: 00009000-00009fff
Memory behind bridge: fdb00000-fdbfffff
Prefetchable memory behind bridge: fda00000-fdafffff
Capabilities: [b8] #0d [0000]
Capabilities: [8c] HyperTransport: MSI Mapping
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
Subsystem: ASUSTeK Computer Inc. Unknown device 81cb
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17
Memory at fe024000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [44] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
Capabilities: [6c] HyperTransport: MSI Mapping
 
Old 11-18-2010, 03:28 PM   #5
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Well, this is not the information I expected. Did you execute alsaconf? did you execute alsamixer?
If yes and it did not work, please post the output of the errormessages. Otherwise please a screenshot of your alsamixer in the terminal.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 is not working in RHEL5 gohappy Linux - Networking 3 09-10-2010 12:48 AM
sound card not working on acer extensa 5630EZ with RHEL5 kabazzi Linux - Laptop and Netbook 3 04-22-2010 06:43 AM
./setup_install_server not working on RHEL5 deci007 Solaris / OpenSolaris 3 11-23-2009 04:00 AM
multicasting is not working on RHEL5 kumarnine Linux - Networking 1 06-09-2009 08:39 AM
rhel5 yum not working spikesnet Red Hat 3 08-01-2007 07:33 AM


All times are GMT -5. The time now is 02:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration