LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 05-27-2008, 11:23 AM   #1
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,471

Rep: Reputation: Disabled
sound not working in games in cedegar- Debian amd64


Hello All!
I have no sound when playing games in cedegar,despite passing the the sound self tests in cedegar.Sound works just fine on the system otherwise just not in games.My system specs are as follows:

cpu: AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
cpu_ghz: 2.61
memory: 3958
videocard_manufacturer: NVIDIA Corporation
videocard_type: GeForce 8800 GTS/PCI/SSE2
videocard_ram: 1024
agp_aperture_size: 512
videocard_driver_version: 2.1.2 NVIDIA 169.12
soundcard: HDA NVidia at 0xfe020000 irq
soundcard_driver: ALSA Version 1.0.13
machine_bitness: 64
kernel: 2.6.18-6-amd64
x_version: Xorg Version 7.1.1
distro: Debian 4.0
GUI version: 6.0.2
Motherboard:Asus M2N32SLI

After much googling the only suggestion seems to be kill the KDE arts sound server which i have tried to no avail.
I really want to get this sorted as i can then stop using windows completely!.Any ideas would be gratefully appreciated.

The Trooper.
 
Old 05-27-2008, 03:52 PM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,471

Original Poster
Rep: Reputation: Disabled
Good news! sorted the sound problem,the solution was as follows:


"Check your hardware setup. In Cedega go to: Edit -> System/Hardware Information and check to see what version of ALSA you are using. As long as you have an ALSA newer than 10.9rc2 then all you need to do is:
Start cedega and then go into:

1. Edit ->Global Options -> Audio

2. Select ALSA

3. In both the PCM Devcie and CTL Device boxes put in the value:
plug:dmix"

Then i had working sound!
Found this info at the following link:

http://www.cedega.com/theden/?p=13

Hope this may help someone else in the future.

Regards
The Trooper.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound in Debian ETCH with amd64 nvidia sound card pietruszewski Debian 20 04-27-2008 03:48 AM
Debian Etch_No Sound in Games (Doom3) Krucifixation Debian 21 04-25-2007 11:20 PM
Debian-amd64: dhcp-client stopped working hungrigerhaifisch Debian 5 06-27-2006 07:34 AM
Sound not working on games only Rnastyracer Linux - Hardware 1 10-18-2004 02:53 PM
/dev/dsp busy? sound not working, games crash Pathian Linux - General 2 11-26-2003 02:30 PM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration