LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2003, 04:12 PM   #1
loran
Member
 
Registered: Jan 2003
Posts: 121

Rep: Reputation: 15
Sound Issues


Ok, I fixed my sound problem in root by adding my soundcard to my rc.modules file. Problem is, this didn't help my user profile though. Why?
 
Old 03-17-2003, 05:29 PM   #2
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
You need to chmod your /dev/dsp and /dev/mixer files so that your user profile has permission to use it. Hope this helps.
 
Old 03-17-2003, 07:39 PM   #3
loran
Member
 
Registered: Jan 2003
Posts: 121

Original Poster
Rep: Reputation: 15
ok, under my user name I typed chmod /dev/dsp. It says "too few arguements". Am I doing it wrong?
 
Old 03-17-2003, 08:59 PM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
You need to change the mod to something, chmod needs some appending. Maybe:
chmod 755 /dev/dsp
However, I suggest looking into something like:

Create a group. This group will own certain devices. Chown your devices such as /dev/dsp to this group. Give read permissions to the group with chmod, then add your users to this group. Long, drawn out, and will take some research, but this is slightly more secure and will teach you a thing or 2 on the way.

Otherwise, just:
chmod 755 /dev/dsp

Cool
 
Old 03-17-2003, 09:23 PM   #5
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by MasterC
You need to change the mod to something, chmod needs some appending. Maybe:
chmod 755 /dev/dsp
However, I suggest looking into something like:

Create a group. This group will own certain devices. Chown your devices such as /dev/dsp to this group. Give read permissions to the group with chmod, then add your users to this group. Long, drawn out, and will take some research, but this is slightly more secure and will teach you a thing or 2 on the way.

Otherwise, just:
chmod 755 /dev/dsp

Cool
I should've been more specific.

Oh yeah, another really good place to look up topics for these two commands, loran, other than man chmod and man chown is O'Reilly's Alphabetical Directory of Linux Commands.

chmod
chown

This site, to me, is helpful as well. I hope this helps.
 
Old 03-17-2003, 09:42 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Nah, the man page was really the best way to answer this one. However, if someone cannot read the man page very well, or if they choose not to for whatever reason, an example always helps

Cool
 
Old 03-17-2003, 11:48 PM   #7
loran
Member
 
Registered: Jan 2003
Posts: 121

Original Poster
Rep: Reputation: 15
ok, here's the nitty-gritty...
the console comes up, right?
bash-2.05a$
I enter "chmod 755 /dev/dsp"
it tells me "chmod: changing permissions of '/dev/dsp/: Operation not permitted"
I go "OK, duh, let's try super user mode"
I enter "chmod 755 /dev/dsp"
and nothin' happens at all!

Here's the question...What the heck am I doing wrong?
 
Old 03-18-2003, 12:18 AM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Nothing happens at all is a bit incorrect. No errors were returned means that chmod was completed successfully, just as is the case in alot of things in linux. BIgJohn once put it well:
"No news is good news when it comes to Linux"
Meaning if you don't get an error message, this usually means everything worked out good.



Cool
 
Old 03-18-2003, 12:29 AM   #9
loran
Member
 
Registered: Jan 2003
Posts: 121

Original Poster
Rep: Reputation: 15
ok, but still no sound for my user, just root...
 
Old 03-18-2003, 12:40 AM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
So check out man chmod and see if you need to give it different permissions Maybe 55 isn't what you want, and more importantly, do you know what 55 does? Your hint is:
owner,group,world

From there, hopefully the man page will help, if not, I'll be glad to. Also, check your volume levels. More importantly, could you give us a better idea of what's going on, your original post is too vague for us to really help other than with generic, vague answers. As much detail as possible when asking a question is usually the best way to go, that way you get to the root of your problem faster.

Cool
 
Old 03-18-2003, 05:41 AM   #11
Sparky
Member
 
Registered: Feb 2003
Location: Denver
Posts: 68

Rep: Reputation: 15
I had the same problem with Slackware 8 so I don't know if this helps but it helped me. This is a direct quote from a book I have on Slackware 7.x; "Install, Configure, and Customize Slackware Linux", by Joe "Zonker" Brockmeier, Jacek Artymiak, et al., Prima Tech Publishing (c)2000:

...You might discover that normal users are not able to play sounds due to permission problems on the device entries. Because you are setting up the device driver, you might as well address this now. Take a look at the device entries in Figure 7.7.

Fig. 7.7

kitzbuhel:~>ls -l /dev/audio* /dev/dsp* /dev/mixer* /dev/midi* /dev/sequ*
crw-rw-r-- 1 root sys 14, 4 Jul 18 1994 /dev/audio
crw-rw-rw- 1 root sys 14, 20 Jul 18 1994 /dev/audio1
crw-rw-rw- 1 root sys 14, 3 Jul 18 1994 /dev/dsp
crw-rw-rw- 1 root sys 14, 19 Jul 18 1994 /dev/dsp1
crw-rw-rw- 1 root sys 14, 2 Jul 18 1994 /dev/midi
crw-rw-rw- 1 root sys 14, 0 Jul 18 1994 /dev/mixer
crw-rw-rw- 1 root sys 14, 16 Jul 18 1994 /dev/mixer1
crw-rw-rw- 1 root sys 14, 1 Jul 18 1994 /dev/sequencer

The left column shows the permissions of who might use these devices. Make sure they show crw-rw-rw. If not, only the root user can use the sound card. To change this, issue the command

chmod 0666 /dev/audio* /dev/dsp* /dev/mixer* /dev/midi*

This allows anyone logged on to the system to use the sound card. Although this should not pose a problem to the standalone system, it might to the networked workstation. Others can log in to your system remotely and start playing or recording sound through your sound card. One way to limit who has use of the sound card would be to issue these commands:

chown (your_prefered_userid) /dev/audio* /dev/dsp* /dev/mixer* /dev/midi*

chmod 0600 /dev/audio* /dev/dsp* /dev/mixer* /dev/midi*

This first command sets ownership of the device file entries to your specified user account. The second command sets them such that only your user has access to them...


(Me again)
If you're an old MS-DOS user, you may notice a similarity between these suggested commands and the DOS attrib utility (the file attribute setting utility/command). Linux/Unix is a multiuser OS which is a huge difference from MS-DOS. Therefore, attributes for files in Linux are much more complex although still simple to remember if you do your homework and learn the "trick" to knowing what number to use when setting file attributes. There are many great resources if the chmod or chown utility/command is giving you problems (including the man pages that you probably already have installed). I'll stop since I may be way off track by now. Hopefully, that does it for you or at least helps. L8R...
 
Old 03-18-2003, 11:24 AM   #12
loran
Member
 
Registered: Jan 2003
Posts: 121

Original Poster
Rep: Reputation: 15
hey, alright. 0666 works MUCH, MUCH better! I can hear my Linkin Park now.
"Crawling in my skin..."
Thanks again. you guys are the greatest.
 
Old 03-18-2003, 04:19 PM   #13
Sparky
Member
 
Registered: Feb 2003
Location: Denver
Posts: 68

Rep: Reputation: 15
Glad it helped (one newbie to another)...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-30-2005 11:35 PM
Please help with sound issues/other issues PyroDrake Linux - Hardware 1 11-21-2005 03:41 PM
More then one Sound Stream (Sound issues?) Kamikazee Linux - Hardware 2 07-06-2005 12:02 AM
Sound Issues - Only one program can use sound at a time MrPeaches Fedora 1 04-23-2005 03:05 AM
Sound issues + Mouse wheel issues matt3333 Slackware 2 10-12-2003 03:09 PM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration