LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2005, 01:53 PM   #1
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Rep: Reputation: 15
Sound issues


I did a search and couldnt find any answers for me, XMMS runs mp3's and such fine but there is no sound, when i try changing the output to Alsa or anything else, it complains and suggests i check to make sure i have teh correct output method. Any idea's on how i can fix this? I am a noob, its been over a yr since i have played around on Linux, so i am outa practice. Running Slack 9.1 btw
 
Old 02-15-2005, 02:29 PM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Are you using ALSA? Do you have the right modules in your kernel (show "lsmod" if you don't know for sure), which audio card do you have?
 
Old 02-15-2005, 07:41 PM   #3
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
first, is your kernel compiled so as to suport ALSA modules?
if not, you'll have a little more work.. some minutes of configuration and recompilation of the kernel...

is ALSA able to detect your sound card?
try running "alsaconf" to see if it detects automatically
try running "alsamixer" to take a look at the mixer options (volumes in general)
if the volumes seem to be the problem and changing them solves the problem,
run "alsactl store" to store your settings for next boots..

Last edited by JoannesX; 02-15-2005 at 07:42 PM.
 
Old 02-15-2005, 10:52 PM   #4
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
not tryin to sound stupid...<g> but where is Alsa usually found? i looked around and couldnt find it. and it has been a long time that i forgot the command to show me where a file is...lol
 
Old 02-16-2005, 03:20 AM   #5
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
Usually alsa goes in /usr/bin. To find files use 'locate' or 'find' or 'whereis' commands.
For the moment type alsaconf at the command prompt and see what happens. If it says 'not found' most likely it's not installed.
 
Old 02-16-2005, 07:37 AM   #6
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Quote:
Originally posted by JoannesX
first, is your kernel compiled so as to suport ALSA modules?
if not, you'll have a little more work.. some minutes of configuration and recompilation of the kernel...
You'll only need modular sound enabled. You can do without the rest of alsa in there.
 
Old 02-16-2005, 08:25 AM   #7
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
ahn if you want a deep search, if you want to sweep your system after ALSA use this combination..

find / | grep -i alsa

it'll find also alsamixer, alsaconf, or wherever alsa is written
 
Old 02-16-2005, 01:34 PM   #8
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
i did the command alsaconf and it said command not found, but when i installed slack i did full and i am sure i saw alsa installed....=/
 
Old 02-16-2005, 02:17 PM   #9
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
ok I logged on root and got the alsaconf to work, but still no sound....on root or normal user
 
Old 02-16-2005, 02:22 PM   #10
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
run alsamixer, the channels are muted by default. when you are done adjusting the mixer, run (as root) :

alsactl store

to store your settings so they can be reapplied at boot time.
 
Old 02-16-2005, 02:35 PM   #11
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
ok thx, how do i change the speaker from off to on?
 
Old 02-16-2005, 02:39 PM   #12
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
do you mean unmute the channel? press m to unmute channels (while they are highlighted)
 
Old 02-16-2005, 02:41 PM   #13
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
that worked...=P it had my speaker turned off.
 
Old 02-16-2005, 02:42 PM   #14
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
it is still not playing any sound tho...=/
 
Old 02-16-2005, 02:47 PM   #15
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
are you using a sound manager ( like arts or esd - if your running kde or gnome it's probably a yes) and do you get sound from anything else like gxine (if you installed it)?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-31-2005 12:35 AM
Please help with sound issues/other issues PyroDrake Linux - Hardware 1 11-21-2005 04:41 PM
More then one Sound Stream (Sound issues?) Kamikazee Linux - Hardware 2 07-06-2005 01:02 AM
Sound Issues - Only one program can use sound at a time MrPeaches Fedora 1 04-23-2005 04:05 AM
Sound issues + Mouse wheel issues matt3333 Slackware 2 10-12-2003 04:09 PM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration