LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2004, 05:09 PM   #1
OldHat
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
Unhappy Sound issues


Hi all,

After several (very short visits) to the Linux world (always hampered by not being able to get any version of Linux online with a USB ADSL modem), I have finally got Mandrake Linux 10 Pro up and running, dual booting and connected to the internet. Slowly but surely, I am getting things working - although the internet, despite be available from a router on the LAN port (how simple should it be?) took some sorting.

My soundcard, however, has me stumped. Although the hardware config tool shows both my soundards (VIA onboard and a soundblaster live PCI card) and they both appeared to be picked up on install, neither works. A small icon in the taskbar shows a speaker and a red line through it, which when clicked upon says:-

"Couldn't open mixer device dev/sound/mixer"

In fact, the dev folder shows no sound or mixer folder(s). As an all but complete linux noob, I have nowhere to turn, and without sound, this is going to be another install of Linux that gets wiped and the partition turned over to Windoze again, where it can safely be used to store worms, viruses, tojan horses, etc, for anyone who cares to sidestep Windows "security". Help me, and don't make me turn back to the dark side again?

So you know just how low to aim with your replies, this is the first version of linux I have running after 5 days of trying with Mandrake, Red Hat (Fedora) and Suse. This is the only one I could get online. Linux is making my ears bleed out of sheer confusion (why can't I simply switch one of the soundcards off, why does "Gnomemeeting /dev/v4l/video0" appear on my desktop at every boot, even though I delete it, why does the config tool appear immediately at boot every time, why can I not login as root... I think you get the idea).

Any help would be gratefully received, as I genuinely am sick of windows (and I'm bloody good with it, being the guy that everyone turns to to fix their windows issues), and am more than PC literate and determined to discover how Linux can serve me (rather than it enslaving me, as it does now).

Thank you for your patience and help...
Peter
 
Old 10-16-2004, 06:42 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi OldHat, welcome to lq. The first thing I'd do is decide which card I wanted to use. If it's the onbard, pull the other card out, if it's the pci card, enter the bios and disable the onbard. You've got a much better chance of configuring one card properly, than two. Once this is all decided and done, open a terminal (it's the icon that looks like a tv with a seashell on it) and su - to the superuser, from there try the command.

alsaconf

If this works you should be able to configure your card. The next step, and since your cards have been identified by the system, you may want to try this before anything.

alsamixer

Unmute, and set your default volumes. Next up.

alsactl store

This should save your settings across a reboot. Hope something here helps.
good luck.
 
Old 10-17-2004, 01:24 PM   #3
OldHat
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Firstly, thanks for the help thus far. Much appreciated.

I have disabled the onboard sound in the BIOS (slap forehead for not doing this from the off). Good suggestion.

I have used alsaconf, etc as you suggested, which ran without error, but sadly this has not changed the situation, except that I have dev/sound dir (which I think is new), and has 3 files (dsp, audio, mixer), and dev/snd with the same files in. However, the taskbar icon still has its red line through it, and any attempt to alter prefs or volumes results in

"Couldn't open mixer device dev/sound/mixer"

Could it be that the kernel does not have sound support? How stupid would this be, given that Mandrake detected both sound cards on install? More to the point, how can I check and/or fix this problem?

I'm very grateful for help... solve this, and I have only got to sort wifi printing to an IP port, and all will be good with my install...


Pete

Last edited by OldHat; 10-17-2004 at 01:29 PM.
 
Old 10-17-2004, 01:52 PM   #4
mary
Member
 
Registered: Sep 2003
Distribution: Gentoo
Posts: 135

Rep: Reputation: 15
Both of those sound devices seem like they should work, especially since they were autodetected. I never had problems with Mandrake's sound but I haven't used it since 9.2...

Maybe it is a permissions problem... I find that most sound problems I have had (and have seen others having) have been due to permissions.

Here is a script that checks sound devices in /dev and their permissions. Save it to your computer, open a terminal, and:

Code:
su - root
Then, change to wherever you put the file:

Code:
cd (directory where you put snddevices)
Change permissions of the file to make it executable:

Code:
chmod a+x snddevices
then run it:

Code:
./snddevices
Does that solve your problem?

If it still doesn't work, go to this page and follow the directions to run the debugging script. Let us know what it says...

Mary

Last edited by mary; 10-17-2004 at 01:56 PM.
 
Old 10-17-2004, 03:29 PM   #5
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Did you try alsamixer from a terminal? What were the results?
good luck.
 
Old 10-18-2004, 11:59 AM   #6
OldHat
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
OK folks,

Alsaconf, alsamixer and store commands ran OK. Conf found the card, mixer gave me option to adjust volumes, and all was OK. Still no sound after reboot, same error as before.

Mary (welcome to own personal hell, thanks for jumping in), I got the script and ran it as root, which started off OK, but then seemed to run into a stack of permission problems... now my "snd" dir has 118 files in, all owned by root and with permissions only for root. Bit confused there.

My "sound" dir has 18 files in it, which are owned by me, and can be read/written/executed by everyone.

Note that these aren't typos.... I have two dirs, one "dev/snd" and one "dev/sound", contents and permissions described above. Still no sound though, and still that error message.

Thanks for your help thus far...

Pete
 
Old 10-18-2004, 12:37 PM   #7
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Quote:
Alsaconf, alsamixer and store commands ran OK. Conf found the card, mixer gave me option to adjust volumes, and all was OK. Still no sound after reboot, same error as before.
After reboot try alsctl restore. If that works, then try adding it to your startup scripts.
good luck.
 
Old 10-18-2004, 12:43 PM   #8
mary
Member
 
Registered: Sep 2003
Distribution: Gentoo
Posts: 135

Rep: Reputation: 15
It's permissions for sure then, if alsamixer works fine as root.

Weird that the script doesn't run okay? Snddevices usually fixes all the permission problems...

Try "chmod -R 777 /dev/snd" and "chmod -R 777 /dev/sound"
possibly doing that for /dev/dsp /dev/audio /dev/mixer /dev/midi and whatever else you have that is sound related.

Maybe it's not the best idea to make the stuff rwx to everyone, but I think it would fix your problem.

It's odd, I just looked at my permissons, all my sound stuff is owned by me (normal user) and perms are rw for me only. Strange!

I dunno, if that doesn't work, try using a different version of snddevices:
Use alsactrl -v to find out your version of alsa and then go to the alsa site and grab the corresponding alsa-driver package. The snddevices script should be there.. just run it the same way.
 
Old 10-18-2004, 12:48 PM   #9
OldHat
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
REEEEESULT!

Thank you both soooo much. Alsamioxer has populated the directories (there were empty), and by going through all the permissions and making sure I can read the files, sound is available. I so very grateful, and think that I can probably make linux my first choice operating system now... for the first time since trying to switch many years back.

So... who's up for some printing to IP addresses over WiFi type fun?

Thanks again.
Pete
 
Old 10-18-2004, 12:56 PM   #10
mary
Member
 
Registered: Sep 2003
Distribution: Gentoo
Posts: 135

Rep: Reputation: 15
Yay! Glad you got it working, those sound issues can be *really* frustrating.
 
Old 10-19-2004, 07:20 AM   #11
OldHat
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
I think Linux is taking the **** out of me. Switching over to KDE desktop yesterday evening, the system hung. It then wouldn't reboot, so I'm going through the above again. Should be OK to sort this time round, though. Sigh.

Peter
 
Old 10-20-2004, 04:34 AM   #12
mr_fubar2818
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10.1
Posts: 2

Rep: Reputation: 0
Hi everyone! I was hoping I could jump in on this post, as I am having the exact same problems as OldHat. I have been trying the suggestions that have been posted, and the big difference I've noticed between my results and OldHat's is that when i run alsamixer i get the following error:

alsamixer: function snd_ctl_open failed for default: No such device

I ran alsaconf and everything went ok, it detected my SB Live! card, installed the snd-emu10k1 driver, and then ran alsa start and everything was ok there as well.

When i try to run an audio program, like xmms or amarok, i get an error that says:

device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device

i checked my /dev folder, and sure enough, there is no dsp device in there. i have the /snd folder, which i set permissions to everyone (as noted in this post), but no luck. there is a dsp0 device, and i tried making a link and renaming it dsp, but that didn't work either (im kinda new to linux as well, so i dont know if that would even do anything or not)

If you have any suggestions, please let me know! I have gotten used to linux and use it more than windows now, but i hate not having sound! thanks in advance!
 
Old 10-20-2004, 09:19 AM   #13
OldHat
LQ Newbie
 
Registered: Oct 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Having re-installed Linux, and gone through the above again, my sound is back, but I'm not convinced the sound system is "tidy", but I'm not going to tinker again.

To mr_fubar2818 - I'm using Mandrake 10.0. I thought 10.1 wasn't polished yet? Have you tried 10.0 instead? I know this is something of a lame suggestion, but anything that helps, huh? Oh, and make sure you login is as root when doing all this - easy to forget as a noob (I kept forgetting and then wondering why I, as the guy who installed the OS, didn't have permission to do stuff. Duh).

Pete
 
Old 10-20-2004, 12:19 PM   #14
mary
Member
 
Registered: Sep 2003
Distribution: Gentoo
Posts: 135

Rep: Reputation: 15
Try the snddevices script I posted earlier on the page.
 
Old 10-20-2004, 05:10 PM   #15
mr_fubar2818
LQ Newbie
 
Registered: Oct 2004
Distribution: Mandrake 10.1
Posts: 2

Rep: Reputation: 0
Thanks for the suggestions everyone. OldHat, I did try using 10.0 and was having problems with it as well (i noticed that alsa was updated to 1.0.6 in 10.1, and i thought that would fix the problem i was having, which is why i installed 10.1). I haven't been logging into X as root, just the console, and necessary folders in konqueror. I have changed all of the ownerships of the sound folders from root to my user id, so maybe i'll try doing the whole process under root.

mary, i ran the script and everything ran ok, except for one error that said it couldn't delete the /dev/snd directory (which may be good because I dont know if i want to get rid of that anyways). im not on my linux box right now, but i can post the outcome of the script later if that would help.

i just think this is weird, because for a while i was using suse 9.1 personal and the sound worked just fine (ironically, it was about the only thing that worked in suse). i'm pretty sure suse 9.1 has kernel 2.6.7, and was using alsa 1.0.3, so i would assume the newer kernel and alsa 1.0.6 would work just fine, but obviously its not; maybe its just something with how mandrake manages hardware or drivers or something like that (i have no idea, im kinda new to linux). i have been having this sound problem with mandrake since 9.2 (worked fine in 9.1), and i haven't been able to figure it out yet.

Anyways, thanks again for everyones help on this! I would greatly appreciate any further help on this
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-31-2005 12:35 AM
Please help with sound issues/other issues PyroDrake Linux - Hardware 1 11-21-2005 04:41 PM
More then one Sound Stream (Sound issues?) Kamikazee Linux - Hardware 2 07-06-2005 01:02 AM
Sound Issues - Only one program can use sound at a time MrPeaches Fedora 1 04-23-2005 04:05 AM
Sound issues + Mouse wheel issues matt3333 Slackware 2 10-12-2003 04:09 PM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration