LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-12-2005, 07:06 PM   #1
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Rep: Reputation: 15
Sound issue using Debian 3.1 on Intel P4 Chipset 82865G


I am installing Linux Debian 3.1 (testing) on a Dell computer with Intel Pentium 4 chipset 82865G with on-board audio controller ADI 1980 (and no other sound card in the system). With help from this forum, I got X working. Now I am trying to figure out why I don't have any sound. Sound worked under WindowsXP the one time I booted it, but (hurrah!) there is no M$ on the computer now. Using modconf, it appears that the correct AC97 audio is enabled. My user name is in the audio group. I have read through some threads on this topic and I suspect I am overlooking something really basic. I have tried to provide as much information below as I can. I apologize in advance if it is not the right information. If what I need to do is to install the ALSA driver, I would appreciate some instructions in how to do that using my Debian 3.1 CDs and the apt-get command, if that is appropriate. In any case, any step-by-step instruction will be appreciated by this Linux novice! Thx.

Here is the background information:

Running commands:
# alsamixer
# alsaconfig
# sndconfig
all return "command not found"

Command # modprobe snd_intel8x0 yields no output.

Output of command # lsmod | grep snd is:
snd_intel8x0 33068 0
snd_ac97_codec 59268 1 snd_intel8x0
snd_pcm 85384 1 snd_intel8x0
snd_timer 23172 1 snd_pcm
snd_page_alloc 11144 2 snd_intel8x0,snd_pcm
gameport 4736 1 snd_intel8x0
snd_mpu401_uart 7296 1 snd_intel8x0
snd_rawmidi 23204 1 snd_mpu401_uart
snd_seq_device 7944 1 snd_rawmidi
snd 50660 7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 9824 4 snd,i810_audio


Output of lspci command is:
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
0000:01:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 02)

The last part of the output of dmesg:
e100: Intel(R) PRO/100 Network Driver, 3.0.18
e100: Copyright(c) 1999-2004 Intel Corporation
ACPI: PCI interrupt 0000:01:08.0[A] -> GSI 20 (level, low) -> IRQ 209
e100: eth0: e100_probe: addr 0xfeaff000, irq 209, MAC addr 00:0C:F1:82:CA:C6
ICH5: IDE controller at PCI slot 0000:00:1f.1
ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 185
ICH5: chipset revision 2
ICH5: not 100% native mode: will probe irqs later
ICH5: port 0x0170 already claimed by ide1
ICH5: neither IDE port enabled (BIOS)
Intel 810 + AC97 Audio, version 1.01, 15:18:15 Jan 8 2005
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 17 (level, low) -> IRQ 201
PCI: Setting latency timer of device 0000:00:1f.5 to 64
i810: Intel ICH5 found at IO 0xedc0 and 0xee00, MEM 0xfeb7fa00 and 0xfeb7f900, IRQ 201
i810: Intel ICH5 mmio at 0xf8a1aa00 and 0xf8a1c900
i810_audio: Primary codec has ID 2
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 2
ac97_codec: AC97 Audio codec, id: ADS112 (Unknown)
i810_audio: AC'97 codec 2 supports AMAP, total channels = 6
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
ACPI: PCI interrupt 0000:00:1d.0[A] -> GSI 16 (level, low) -> IRQ 169
uhci_hcd 0000:00:1d.0: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: irq 169, io base 0000ff80
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.1[B] -> GSI 19 (level, low) -> IRQ 177
uhci_hcd 0000:00:1d.1: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: irq 177, io base 0000ff60
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 185
uhci_hcd 0000:00:1d.2: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: irq 185, io base 0000ff40
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.3[A] -> GSI 16 (level, low) -> IRQ 169
uhci_hcd 0000:00:1d.3: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4
PCI: Setting latency timer of device 0000:00:1d.3 to 64
uhci_hcd 0000:00:1d.3: irq 169, io base 0000ff20
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 3-1: new low speed USB device using address 2
ACPI: PCI interrupt 0000:00:1d.7[D] -> GSI 23 (level, low) -> IRQ 193
ehci_hcd 0000:00:1d.7: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: irq 193, pci mem f8a3e800
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
PCI: cache line size of 128 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: USB 2.0 enabled, EHCI 1.00, driver 2004-May-10
usb 3-1: unable to read config index 0 descriptor/all
usb 3-1: can't read configurations, error -84
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 8 ports detected
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, using FIFO [PCSPP,TRISTATE,COMPAT,ECP]
inserting floppy driver for 2.6.8-2-386
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
usb 3-1: new low speed USB device using address 4
usb 4-2: new full speed USB device using address 2
usbcore: registered new driver hiddev
input: PC Speaker
input: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:1d.2-1
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
ts: Compaq touchscreen protocol output
Real Time Clock Driver v1.12
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 1 proto 2 vid 0x03F0 pid 0x2611
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel 865 Chipset.
agpgart: Maximum main memory to use for agp memory: 816M
agpgart: Detected 8060K stolen memory.
agpgart: AGP aperture is 128M @ 0xe8000000
hw_random hardware driver 1.0.0 loaded
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: acpi_pciehprm:\_SB_.PCI0 evaluate _BBN fail=0x5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x5
shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg> and others
e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
NET: Registered protocol family 17
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02ca840(lo)
IPv6 over IPv4 tunneling driver
lp0: using parport0 (interrupt-driven).
NET: Registered protocol family 5
eth0: no IPv6 routers present
drivers/usb/input/hid-input.c: event field not found
END OF POST
 
Old 03-13-2005, 05:07 PM   #2
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
Additional information on the same problem . . .

In addition to the information I provided in my initial post yesterday, I have continue to work this issue. When I run cat /dev/sndstat the output reads:
QUOTE
Sound Driver:3.8.1a-980706 (ALSA v1.0.4 emulation code)
Kernel: Linux bighawk 2.6.8-2-386 #1 Sat Jan 8 14:46:01 EST 2005 i686
Config options: 0
Installed drivers:
Type 10: ALSA emulation
Card config:
Intel ICH5 at 0xfeb7fa00, irq 201
Audio devices: NOT ENABLED IN CONFIG
Synth devices: NOT ENABLED IN CONFIG
Midi devices: NOT ENABLED IN CONFIG
Timers:
7: system timer
Mixers: NOT ENABLED IN CONFIG
END QUOTE

Since I still have no sound, I have a a couple specific questions:
Question 1: Do I need to add lines to the /etc/modules file (see contents quoted below), and if so, what?
Question 2: Using update-modules, I altered /etc/modules.conf file (see below), following the http://www.alsa-project.org Intel 8x0 instructions, but I was not sure how to add the module options for snd-intel8x0 which were listed on the ALSA site as follows:
QUOTE
# description: "Intel 82801AA,82901AB,i810,i820,i830,i840,i845,MX440; SiS 7012; Ali 5455"
# author: "Jaroslav Kysela "
# license: "GPL"
# parm: index int array (min = 1, max = 8), description "Index value for Intel i8x0 soundcard."
# parm: id string array (min = 1, max = 8), description "ID string for Intel i8x0 soundcard."
# parm: enable int array (min = 1, max = 8), description "Enable Intel i8x0 soundcard."
# parm: ac97_clock int array (min = 1, max = 8), description "AC'97 codec clock (0 = auto-detect)."
# parm: joystick_port int array (min = 1, max = 8), description "Joystick port address for Intel i8x0 soundcard. (0 = disabled)"
# parm: mpu_port int array (min = 1, max = 8), description "MPU401 port # for Intel i8x0 driver."
END QUOTE
This all seemed rather verbose to me and I do not understand how to use it to set the options of the modules.

Here are the current contents of /etc/modules.conf file:
QUOTE
### This file is automatically generated by update-modules"
#
# Please do not edit this file directly. If you want to change or add
# anything please take a look at the files in /etc/modutils and read
# the manpage for update-modules.
#
### update-modules: start processing /etc/modutils/0keep
# DO NOT MODIFY THIS FILE!
# This file is not marked as conffile to make sure if you upgrade modutils
# it will be restored in case some modifications have been made.
#
# The keep command is necessary to prevent insmod and friends from ignoring
# the builtin defaults of a path-statement is encountered. Until all other
# packages use the new `add path'-statement this keep-statement is essential
# to keep your system working
keep

### update-modules: end processing /etc/modutils/0keep

### update-modules: start processing /etc/modutils/actions
# Special actions that are needed for some modules

# The BTTV module does not load the tuner module automatically,
# so do that in here
post-install bttv insmod tuner
post-remove bttv rmmod tuner

### update-modules: end processing /etc/modutils/actions

### update-modules: start processing /etc/modutils/aliases
# Aliases to tell insmod/modprobe which modules to use

# Uncomment the network protocols you don't want loaded:
# alias net-pf-1 off # Unix
# alias net-pf-2 off # IPv4
# alias net-pf-3 off # Amateur Radio AX.25
# alias net-pf-4 off # IPX
# alias net-pf-5 off # DDP / appletalk
# alias net-pf-6 off # Amateur Radio NET/ROM
# alias net-pf-9 off # X.25
# alias net-pf-10 off # IPv6
# alias net-pf-11 off # ROSE / Amateur Radio X.25 PLP
# alias net-pf-19 off # Acorn Econet
alias net-pf-24 pppoe

alias char-major-10-175 agpgart
alias char-major-10-200 tun
alias char-major-81 bttv
alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate

# Crypto modules (see http://www.kerneli.org/)
alias loop-xfer-gen-0 loop_gen
alias loop-xfer-3 loop_fish2
alias loop-xfer-gen-10 loop_gen
alias cipher-2 des
alias cipher-3 fish2
alias cipher-4 blowfish
alias cipher-6 idea
alias cipher-7 serp6f
alias cipher-8 mars6
alias cipher-11 rc62
alias cipher-15 dfc2
alias cipher-16 rijndael
alias cipher-17 rc5


### update-modules: end processing /etc/modutils/aliases

### update-modules: start processing /etc/modutils/alsa
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

### update-modules: end processing /etc/modutils/alsa

### update-modules: start processing /etc/modutils/apm
alias char-major-10-134 apm
alias /dev/apm_bios /dev/misc/apm_bios
alias /dev/misc/apm_bios apm

### update-modules: end processing /etc/modutils/apm

### update-modules: start processing /etc/modutils/paths
# This file contains a list of paths that modprobe should scan,
# beside the ones that are compiled into the modutils tools
# themselves.

### update-modules: end processing /etc/modutils/paths

### update-modules: start processing /etc/modutils/arch/i386
alias parport_lowlevel parport_pc
alias char-major-10-144 nvram
alias binfmt-0064 binfmt_aout
alias char-major-10-135 rtc

### update-modules: end processing /etc/modutils/arch/i386
END QUOTE

And finally, here are the contents of /etc/modules file:
QUOTE
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

ide-cd
ide-generic
sd_mod

END QUOTE

Perhaps adding lines to this last file will fix my problem?

I hope I have not provided too much information. Thanks in advance for any guidance.
 
Old 03-13-2005, 05:14 PM   #3
audibel
Member
 
Registered: Oct 2004
Distribution: Debian Sarge
Posts: 177

Rep: Reputation: 30
If you use KDE go to your Kmenu and select Multimedia and then Kmix and make sure everything that should be is unmuted and turned up, for some God awful reason it comes muted and turned down.
 
Old 03-13-2005, 09:27 PM   #4
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
Thx.
Well, I am using Gnome. When I check Multimedia/Volume Control, I get:
"Sorry, no mixer elements and or devices found."
When I choose Multimeida/CD Player, and put in a CD, I see it is playing the CD with the title, "Louis Armstrong's Sixteen Most Popular Songs," but I cannot hear any sound when it says it is playing "Mack the Knife."
Don't know whether this helps, or not . . .
 
Old 03-13-2005, 09:50 PM   #5
audibel
Member
 
Registered: Oct 2004
Distribution: Debian Sarge
Posts: 177

Rep: Reputation: 30
Do you have any MP3s to test out? A lot of the time what happens with CD-ROMS is that the company who made your computer was to cheap and/or lazy to run an audio cable from your CDROM to your soundcard, there are workarounds out there, do a search on my name and you should find a response to a similar complaint about CDROM sound. But if you can't get sound at all it's a different story. I do think you should have some kind of mixer program on your computer whatever it may be in gnome I don't know. If you try a MP3 and you can hear sound then it's your CDROM and not your sound.
 
Old 03-13-2005, 10:26 PM   #6
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
MP3 don't seem to play nor does anything I try to listen to from the WWW. My sound controller is Intel's integrated 8x0, so there is no separate sound card and I would guess cables are not an issue. Also, there was sound when WinXP booted up, before I hosed the C: drive. Also, I would guess the sndstat file below indicates that the problem is the software is not configured properly.


When I run cat /dev/sndstat the output reads:
QUOTE
Sound Driver:3.8.1a-980706 (ALSA v1.0.4 emulation code)
Kernel: Linux bighawk 2.6.8-2-386 #1 Sat Jan 8 14:46:01 EST 2005 i686
Config options: 0
Installed drivers:
Type 10: ALSA emulation
Card config:
Intel ICH5 at 0xfeb7fa00, irq 201
Audio devices: NOT ENABLED IN CONFIG
Synth devices: NOT ENABLED IN CONFIG
Midi devices: NOT ENABLED IN CONFIG
Timers:
7: system timer
Mixers: NOT ENABLED IN CONFIG
END QUOTE
 
Old 03-15-2005, 03:21 PM   #7
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
yeah, I have a question about the same topic. I'm using slackware 10.1, and there are no loaded drivers for my soundcard (dell integrated audio chipset). When I run cat /dev/sndstat, I get the response "no such device." any ideas?
 
Old 03-15-2005, 06:12 PM   #8
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
I think I must be overlooking something very basic, but I am too inexperienced to know what it might be. I have continued to read and try different adjustments. I still don't have any sound, but the output of cat | /dev/sndstat now reads shows my card and driver, so that may be some improvement:
QUOTE
Sound Driver:3.8.1a-980706 (ALSA v1.0.4 emulation code)
Kernel: Linux bighawk 2.6.8-2-386 #1 Sat Jan 8 14:46:01 EST 2005 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Intel ICH5 at 0xfeb7fa00, irq 201

Audio devices:
0: Intel ICH5 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: Analog Devices AD1980
END QUOTE

But as I said, still no sound at all.

I am thinking there might be some IRQ conflict or possibly some issue related to the snd-intel8x0 parameters which I don't know what to do with. They are listed on the ALSA Intel 8x0 page as:
QUOTE
The module options for snd-intel8x0

# description: "Intel 82801AA,82901AB,i810,i820,i830,i840,i845,MX440; SiS 7012; Ali 5455"
# author: "Jaroslav Kysela "
# license: "GPL"
# parm: index int array (min = 1, max = 8), description "Index value for Intel i8x0 soundcard."
# parm: id string array (min = 1, max = 8), description "ID string for Intel i8x0 soundcard."
# parm: enable int array (min = 1, max = 8), description "Enable Intel i8x0 soundcard."
# parm: ac97_clock int array (min = 1, max = 8), description "AC'97 codec clock (0 = auto-detect)."
# parm: joystick_port int array (min = 1, max = 8), description "Joystick port address for Intel i8x0 soundcard. (0 = disabled)"
# parm: mpu_port int array (min = 1, max = 8), description "MPU401 port # for Intel i8x0 driver."

END QUOTE
I have not done anything about these module options because I am not sure where to put them and exactly what for they should take. I thought the "#" mark at the start of each line meant the system would ignore it, so that can't be right, can it?

There are the lines in dmesg that made me wonder about the IRQ:
QUOTE
ICH5: IDE controller at PCI slot 0000:00:1f.1
ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 185
ICH5: chipset revision 2
ICH5: not 100% native mode: will probe irqs later
ICH5: port 0x0170 already claimed by ide1
ICH5: neither IDE port enabled (BIOS)
END QUOTE

Anyway, I will read a little more . . .

Last edited by tommilo; 03-15-2005 at 06:15 PM.
 
Old 03-16-2005, 09:44 PM   #9
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
Continuing along . . . I still have no sound and the questions in the previous post remain unanswered. However, I did read elsewhere on this site about using Synaptic, so I did so, and installed the apparently missing alsa components. So, now I can use commands alsamixer and alsa conf and everything seems to work great. Visually, that is. I unmuted everything in sight, but still, silence. I have tried to play some files will XMMS and tried to play a CD in both drives, but no sound. I can see that the CD is playing something and it even tells me the name of the song, but actually I would prefer to h e a r the song and try to identify the song for myself. I am running out of things to try, but will keep working to get some sound on this bad boy.
 
Old 03-16-2005, 10:38 PM   #10
j_bodnar
LQ Newbie
 
Registered: Mar 2005
Location: Canada
Distribution: Debian
Posts: 5

Rep: Reputation: 0
tommilo

I was having this problem with my sound as well. In the end I had to kill the sound server that was loading. After that it was just configuring the sound settings with gmix or something similar. Hope this helps.

Icarus


I would rather fail with linux than succeed with windows.
 
Old 03-16-2005, 10:56 PM   #11
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
I am willing to try anything. But what do you mean by "killing the sound server that was loading>"
Thx.
 
Old 03-17-2005, 12:08 AM   #12
j_bodnar
LQ Newbie
 
Registered: Mar 2005
Location: Canada
Distribution: Debian
Posts: 5

Rep: Reputation: 0
tommilo

If you're using gnome open the gnome control panel and then open sound. If you have the box checked to enable sound server startup then remove that. Not sure if you need to reboot, try the command /etc/init.d/alsa restart and then run alsaconf to set the mixer. It's what was griefing me and it could be what's griefing you. Good luck.

Icarus


I would rather fail with linux than succeed with windows.
 
Old 03-17-2005, 12:36 AM   #13
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
Thank you. I followed your instructions and had no difficulty carrying them out. But, I still have no sound. Thanks for your advice in any case.
 
Old 03-23-2005, 02:02 PM   #14
tommilo
Member
 
Registered: Jan 2005
Location: California
Distribution: Debian 3.1 (sarge) Kernel 2.6
Posts: 30

Original Poster
Rep: Reputation: 15
Continuing to read and work on these sound issues and making some progress . . .

I have the sound turned up in alsamixer and now I have sound in Gnome Desktop. However, I cannot hear music from the DVD or DC players (hdc and hdd), even though they seem to be recognized when the system boots up. I can even see the name of the song that is (silently) playing.

Also, for what it's worth, when I run command
# cat /dev/random > /dev/dsp
I get no sound, for some reason, but a lot of weird symbolic output to the shell window. (I read this command was a test for sound, but maybe I misunderstood something. Always a possibility, of course!)

How can I troubleshoot the lack of sound from the DVD and CD drives? Thanks in advance for suggestions.
 
Old 03-23-2005, 03:39 PM   #15
j_bodnar
LQ Newbie
 
Registered: Mar 2005
Location: Canada
Distribution: Debian
Posts: 5

Rep: Reputation: 0
hey tommilo

nice to hear you've got your sound working. was wondering if your cd's are being automounted when you put them in. if so, you may want to change the options in /etc/fstab to noauto.

here's mine...

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0


Icarus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound from Intel 915 GM Chipset? SgC.9711 Linux - Hardware 11 11-28-2005 10:21 AM
Intel 945G chipset and Debian jdavidow Linux - Hardware 3 11-09-2005 09:13 AM
Intel Driver Problems (82865G) drako12 Linux - Hardware 6 02-09-2004 01:09 AM
Intel 82865G can't work!!!! liangchen Linux - Hardware 1 01-27-2004 08:24 AM
Sound with Intel 810E Chipset danishmr Linux - Hardware 0 05-09-2002 05:51 AM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration