LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-16-2009, 02:18 PM   #1
bach-fiend
LQ Newbie
 
Registered: Feb 2009
Location: St Paul, Minnesota, USA
Distribution: Redhat Fedora 10; someday planet CCRMA
Posts: 11

Rep: Reputation: 0
sound is very faint (alsa and pulseaudio, Fedora 10)


I have built in Nvidia sound, HDA (intel?) ALC888 [?].

It works fine under Windows XP/Pro, but in linux I have to turn the volume on my stereo ALL THE WAY UP to listen to anything. Pulseaudio's volume master has to be set to 100% as well as must the volume controls in VLC dvd and RhythmBox, both Internet radio and extracted/ripped CD's. The problem is always the same: sound basically works, but at such low levels that I have to crank the volume of my stereo WAY to the max, so I get crosstalk and irritating noise even when nothing is playing.

The program aplay (ALSA player) has the same problem, so I'm not sure I can blame pulseaudio.

I have been scouring the manuals and the web for the last few days and saw only a couple mentions of anything remotely like this. I am running 64 bit Fedora, is that a known problem? I thought samples in CD quality were only 16 bits per channel to begin with.

If you can shed any light on this, I would greatly appreciate (especially if you could copy me at kenny dot david at comcast dot net since I don't know my way around these forums yet.)
 
Old 02-16-2009, 02:47 PM   #2
digerati1338
Member
 
Registered: May 2007
Location: CO
Distribution: Ubuntu
Posts: 152
Blog Entries: 1

Rep: Reputation: 18
Look in a mixer program such as alsamixer, amix, or something similar. Make sure ALL of your channels are turned on and the volume is at 100%.
 
Old 02-16-2009, 03:05 PM   #3
bach-fiend
LQ Newbie
 
Registered: Feb 2009
Location: St Paul, Minnesota, USA
Distribution: Redhat Fedora 10; someday planet CCRMA
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for replying digerati1338. You've brought up another issue that puzzles me. I've tried pulseaudio volume control from Fedora/Gnome sound and video menu, and alsamixer from the command line. I expected level sliders for PCM, CD etc as well as a master volumes. All I ever saw was Left and Right, even in alsamixer. Alsa is supposed to support pro audio applications, so I was amazed to see so little. My impression was that pulseaudio was the brain-dead "consumer" product and alsa should give you more control. Silly me!
 
Old 02-16-2009, 04:11 PM   #4
Laserman
LQ Newbie
 
Registered: Jun 2008
Distribution: Fedora 10, DSL, Zenwalk
Posts: 27

Rep: Reputation: 17
Try going to System > Preferences > Hardware > Sound
Test all of the Playback options, they are set to Autodetect by default.
Check 'Default Mixer Tracks' and make sure your sound card is there, try changing between Alsamixer and Pulse Audio selections and see if either of them work for you.
 
  


Reply

Tags
audio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Sound (Mic) not working in Fedora 9 pulseaudio MikeyCarter Linux - Software 0 07-30-2008 11:01 AM
unable to solve fedora 9 pulseaudio hda_intel sound problem flashl Linux - Hardware 2 06-30-2008 06:52 PM
LXer: How To Fix The Sound Issues Between Skype 2.0 And Pulseaudio On Fedora 9 LXer Syndicated Linux News 0 06-02-2008 07:11 AM
LXer: Using PulseAudio sound server on Fedora 8 LXer Syndicated Linux News 0 03-14-2008 04:10 PM
alsa woes (very faint sound) ferreter Slackware 11 05-20-2004 01:39 AM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration